Topic
  • 9 replies
  • Latest Post - ‏2012-10-07T20:35:18Z by hans001
mr_ibm
mr_ibm
4 Posts

Pinned topic ITNM 3.9 multi-server installation fails on RH Enterprise 6

‏2012-03-02T19:21:08Z |
Guys,

I am trying to install ITNM IP Edition 3.9 on a RH Enterprise 6.x server. The install fails.

There is a blurb in the release notes for ITNM 3.9 that states that it is only supported on RH Enterprise 5.x.

BUT, there is another link on another IBM site documenting the list of RPMs needed to install ITNM IP Edition 3.9 components on RH Enterprise 6.x. Like a good kid, I followed the list and got all of the RPMs, yet failed in the install.

The setup I am trying to achieve:
Server 1 (RH Enterprise 6.x): ObjectServer 7.3.1 + WebGUI 7.3.1 (installed and working beautifully)
Server 2 (RH Enterprise 6.x): ITNM IP Edition 3.9 (fails)

Question:
1. Has anybody successfully installed ITNM IP Edition 3.9 on RH Enterprise 6.x? If yes, can you please share your experience.
2. If not, does anybody know when RH Enterprise 6.x will be supported, considering this release has been out for a few years...I think two, but don't quote me on that.

thanks.
Updated on 2012-10-07T20:35:18Z at 2012-10-07T20:35:18Z by hans001
  • t_bar
    t_bar
    5 Posts

    Re: ITNM 3.9 multi-server installation fails on RH Enterprise 6

    ‏2012-03-02T20:40:56Z  
    1. Not yet
    2. Do not know. <but looking at your tag, you might be the best person to ask><joke intended>.
    Interesting questions tho.

    Hope you do not mind if i ask you something...

    A) I would expect an install on RH 6 not to be a problem, however. Out of interest what was the problem?
    B) Server 1. I guess if you have WebGUI you would make an install of ITNM GUI component after WebGUI.
    Did you? Did it work OK?

    Ta.
  • mr_ibm
    mr_ibm
    4 Posts

    Re: ITNM 3.9 multi-server installation fails on RH Enterprise 6

    ‏2012-03-05T16:47:53Z  
    • t_bar
    • ‏2012-03-02T20:40:56Z
    1. Not yet
    2. Do not know. <but looking at your tag, you might be the best person to ask><joke intended>.
    Interesting questions tho.

    Hope you do not mind if i ask you something...

    A) I would expect an install on RH 6 not to be a problem, however. Out of interest what was the problem?
    B) Server 1. I guess if you have WebGUI you would make an install of ITNM GUI component after WebGUI.
    Did you? Did it work OK?

    Ta.
    Thanks for the reply. Assuming that the tag is an accurate representation, minus vanity, I would be the appropriate person to ask. But, sadly, I have no clue...I can barely keep up with the alphabet soup of Tivoli product line :)

    Here's my interpretation of the problems with RH6 install (your question #1):

    1. First problem was with the failure to install COI/DE components. The exact message was:

    <start of snippet from console install output>
    The installation of the COI/DE components failed with the following message:
    Component: Start WebSphere Application Server
    Message:

    For more information, please review
    /opt/IBM/tivoli/netcool/log/install/Configuration.log and the logs found in
    /opt/IBM/tivoli/tipv2/logs, and correct any problems described therein before continuing.
    <end of snippet from console install output>

    This implies a problem starting tipv2. I follow the logs in tipv2 directory and it seems that the default server1 started successfully. configureSecurity.err is the only file that contains any error messages, but that too is a list of jar files.

    2. So, I continue with the install and keep a tail going on Configuration.log, which leads to the second error...

    <start of snippet from console install output>
    Problem installing Topology Database


    The installation of the ITNM Topology Database failed with an error code of 6.
    For more information, please review
    /opt/IBM/tivoli/netcool/log/install/Configuration.log and correct any problems described therein before continuing.
    <end of snippet from console install output>

    So, Informix install fails with error code 6. Looking into ids_install.log (which is the log file for informix install), I see the following:

    <begin of snippet from ids_install.log file>
    (Mar 1, 2012 5:55:22 PM), Install, CheckRequiredLibraries, msg1, BUFFER content: /lib64/libncurses.so.5: ELF 64-bit LSB shared object, x86-64,
    version 1 (SYSV), dynamically linked, stripped
    (Mar 1, 2012 5:55:22 PM), Install, CheckRequiredLibraries, msg1, file -L exitValue: 0
    (Mar 1, 2012 5:55:22 PM), Install, CheckRequiredLibraries, err, CUSTOM_BEAN_ERROR_BEGIN
    Missing shared library files: libncurses.so.5
    CUSTOM_BEAN_ERROR_END
    <end of snippet from ids_install.log file>

    But the libncurses.so.5 exists and I have both 32-bit/64-bit version of the libraries in the standard /lib64 and /lib directories.

    Searching for exit code 6 for informix install is a dead end.

    Conclusion, I am at a loss!

    Your question 2:

    About to start a fresh install on server 1 of just the ITNM core components. Then I am thinking about reinstalling the WebGUI components. The key is to understand whether I can get the basic components working before adding in more pieces...i.e. controlled install of one component at a time.

    I will post my "lessons learned"
  • mr_ibm
    mr_ibm
    4 Posts

    Re: ITNM 3.9 multi-server installation fails on RH Enterprise 6

    ‏2012-03-05T21:52:42Z  
    • mr_ibm
    • ‏2012-03-05T16:47:53Z
    Thanks for the reply. Assuming that the tag is an accurate representation, minus vanity, I would be the appropriate person to ask. But, sadly, I have no clue...I can barely keep up with the alphabet soup of Tivoli product line :)

    Here's my interpretation of the problems with RH6 install (your question #1):

    1. First problem was with the failure to install COI/DE components. The exact message was:

    <start of snippet from console install output>
    The installation of the COI/DE components failed with the following message:
    Component: Start WebSphere Application Server
    Message:

    For more information, please review
    /opt/IBM/tivoli/netcool/log/install/Configuration.log and the logs found in
    /opt/IBM/tivoli/tipv2/logs, and correct any problems described therein before continuing.
    <end of snippet from console install output>

    This implies a problem starting tipv2. I follow the logs in tipv2 directory and it seems that the default server1 started successfully. configureSecurity.err is the only file that contains any error messages, but that too is a list of jar files.

    2. So, I continue with the install and keep a tail going on Configuration.log, which leads to the second error...

    <start of snippet from console install output>
    Problem installing Topology Database


    The installation of the ITNM Topology Database failed with an error code of 6.
    For more information, please review
    /opt/IBM/tivoli/netcool/log/install/Configuration.log and correct any problems described therein before continuing.
    <end of snippet from console install output>

    So, Informix install fails with error code 6. Looking into ids_install.log (which is the log file for informix install), I see the following:

    <begin of snippet from ids_install.log file>
    (Mar 1, 2012 5:55:22 PM), Install, CheckRequiredLibraries, msg1, BUFFER content: /lib64/libncurses.so.5: ELF 64-bit LSB shared object, x86-64,
    version 1 (SYSV), dynamically linked, stripped
    (Mar 1, 2012 5:55:22 PM), Install, CheckRequiredLibraries, msg1, file -L exitValue: 0
    (Mar 1, 2012 5:55:22 PM), Install, CheckRequiredLibraries, err, CUSTOM_BEAN_ERROR_BEGIN
    Missing shared library files: libncurses.so.5
    CUSTOM_BEAN_ERROR_END
    <end of snippet from ids_install.log file>

    But the libncurses.so.5 exists and I have both 32-bit/64-bit version of the libraries in the standard /lib64 and /lib directories.

    Searching for exit code 6 for informix install is a dead end.

    Conclusion, I am at a loss!

    Your question 2:

    About to start a fresh install on server 1 of just the ITNM core components. Then I am thinking about reinstalling the WebGUI components. The key is to understand whether I can get the basic components working before adding in more pieces...i.e. controlled install of one component at a time.

    I will post my "lessons learned"
    Guys,

    This is the lessons learned part 1:

    Setup:

    Server 1 (RH Enterprise 6.x) with ITNM 3.9 Core components and some Netcool Probes
    Server 2 (RH Enterprise 6.x) with Netcool Tivoli Core 7.3.1 + WebGUI 7.3.1

    Exact OS Version:
    root# uname -a
    Linux <removed> 2.6.32-131.17.1.el6.x86_64 #1 SMP Thu Sep 29 10:24:25 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

    Prerequisite libraries for installing ITNM on server 1:
    root# rpm -qa > all_installed.103
    root# cat all_installed.103 | grep -i compat-libstdc
    compat-libstdc++-33-3.2.3-69.el6.x86_64
    compat-libstdc++-296-2.96-144.el6.i686
    compat-libstdc++-33-3.2.3-69.el6.i686
    root# cat all_installed.103 | grep -i libXp
    libXp-1.0.0-15.1.el6.x86_64
    libXpm-3.5.8-2.el6.x86_64
    libXp-1.0.0-15.1.el6.i686
    root# cat all_installed.103 | grep -i libXm
    libxml2-2.7.6-1.el6.i686
    libXmu-1.0.5-1.el6.x86_64
    libXmu-1.0.5-1.el6.i686
    libxml2-python-2.7.6-1.el6.x86_64
    libxml2-2.7.6-1.el6.x86_64
    root# cat all_installed.103 | grep -i openmotif
    openmotif22-2.2.3-19.el6.i686
    root# cat all_installed.103 | grep -i unixodbc
    unixODBC-2.2.14-11.el6.i686
    unixODBC-2.2.14-11.el6.x86_64
    root# cat all_installed.103 | grep -i curses
    ncurses-base-5.7-3.20090208.el6.x86_64
    ncurses-libs-5.7-3.20090208.el6.i686
    ncurses-term-5.7-3.20090208.el6.x86_64
    ncurses-libs-5.7-3.20090208.el6.x86_64
    ncurses-devel-5.7-3.20090208.el6.x86_64
    ncurses-5.7-3.20090208.el6.x86_64
    root# cat all_installed.103 | grep -i ksh
    ksh-20100621-6.el6.x86_64
    root# cat all_installed.103 | grep -i firefox
    firefox-3.6.23-2.el6_1.x86_64

    NOTE: before installing create a soft link for ksh, this is used after the informix db is installed and the password needs to be changed.
    root# ln -s /bin/ksh /usr/bin/ksh
    root# ls -al /usr/bin/ksh
    lrwxrwxrwx 1 root root 8 Mar 5 16:16 /usr/bin/ksh -> /bin/ksh
    Generic Process on server 1:
    1. uninstall EVERY Tivoli product include DE (deployment engine)
    2. Install the Omnibus Core and the probes. Configure things as needed for proper communication with server 2's object server.
    3. Install ITNM (options I selected):
    a. Installation Type = Custom
    b. Silent Response File = No
    c. # of Servers = Multi-server
    d. Default Values = Custom
    e. FIPS = No
    f. Install Network Manager Core Components
    g. Network Manager GUI on this server = No
    h. Do not install or configure Tivoli Netcool/Omnibus I am trying to get the basics working
    i. use IDS for Topology database
    Define the custom stuff for Topology database

    Conclusion: Things are looking MUCH better. Once I am happy with the setup, I will post a part 2 of the lessons learned.
  • mr_ibm
    mr_ibm
    4 Posts

    Re: ITNM 3.9 multi-server installation fails on RH Enterprise 6

    ‏2012-03-17T01:57:25Z  
    Take 2...lessons learned:

    This is not possible. I can not get ITNM 3.9 working on RH Enterprise 6.

    Components that work on RHEL 6: ITNM Core
    Components that don't work on RHEL 6: ITNM WebGUI

    I give up! Downgrading to RHEL 5, latest release and trying again.
  • SystemAdmin
    SystemAdmin
    430 Posts

    Re: ITNM 3.9 multi-server installation fails on RH Enterprise 6

    ‏2012-03-19T19:33:04Z  
    • mr_ibm
    • ‏2012-03-17T01:57:25Z
    Take 2...lessons learned:

    This is not possible. I can not get ITNM 3.9 working on RH Enterprise 6.

    Components that work on RHEL 6: ITNM Core
    Components that don't work on RHEL 6: ITNM WebGUI

    I give up! Downgrading to RHEL 5, latest release and trying again.
    In manual of instalation, the SO especific for RHEL is 5.0.
    Verify the manual.
  • NicholasHo
    NicholasHo
    5 Posts

    Re: ITNM 3.9 multi-server installation fails on RH Enterprise 6

    ‏2012-05-31T00:09:55Z  
    So I am in exactly the same boat. I looked up which OS's IDS 11.5 (I think IDS 11.5 is the one shipped with ITNM supported here:

    http://publib.boulder.ibm.com/infocenter/prodguid/v1r0/clarity/osForProduct.html

    IDS 11.5 is not supported. Grrrrrrrrr - this is not mentioned in the documentation AFAIK. however if you enter "network manager" and choose 3.9, it says RH 6 IS supported.
  • gulfsoft
    gulfsoft
    8 Posts

    Re: ITNM 3.9 multi-server installation fails on RH Enterprise 6

    ‏2012-05-31T02:29:01Z  
    So I am in exactly the same boat. I looked up which OS's IDS 11.5 (I think IDS 11.5 is the one shipped with ITNM supported here:

    http://publib.boulder.ibm.com/infocenter/prodguid/v1r0/clarity/osForProduct.html

    IDS 11.5 is not supported. Grrrrrrrrr - this is not mentioned in the documentation AFAIK. however if you enter "network manager" and choose 3.9, it says RH 6 IS supported.
    Here's a technote that specifically states that ITNM 3.9 does not support RHEL 6, and it was published or modified on Nov. 28, 2011:

    http://www-304.ibm.com/support/docview.wss?uid=swg21567158

    In general, if IBM/Tivoli says it's not supported, you really shouldn't try it.

    Frank

    We can make Tivoli software work for you!
    www.gulfsoft.com
  • GrantB@au
    GrantB@au
    1 Post

    Re: ITNM 3.9 multi-server installation fails on RH Enterprise 6

    ‏2012-10-05T05:36:06Z  
    • gulfsoft
    • ‏2012-05-31T02:29:01Z
    Here's a technote that specifically states that ITNM 3.9 does not support RHEL 6, and it was published or modified on Nov. 28, 2011:

    http://www-304.ibm.com/support/docview.wss?uid=swg21567158

    In general, if IBM/Tivoli says it's not supported, you really shouldn't try it.

    Frank

    We can make Tivoli software work for you!
    www.gulfsoft.com
    Not really good enough. RHEL5 is now over 5 years old and RHEL6 has been GA since 10 Nov 2010. Get with the programme Tivoli, and try to stay reasonably current with available enterprise distros if you want your products to gain an aura of good support and development. This will surely flow on to good take-up of your products by new customers, and good retention of existing customers. Mediocre at best.
  • hans001
    hans001
    4 Posts

    Re: ITNM 3.9 multi-server installation fails on RH Enterprise 6

    ‏2012-10-07T20:35:18Z  
    • GrantB@au
    • ‏2012-10-05T05:36:06Z
    Not really good enough. RHEL5 is now over 5 years old and RHEL6 has been GA since 10 Nov 2010. Get with the programme Tivoli, and try to stay reasonably current with available enterprise distros if you want your products to gain an aura of good support and development. This will surely flow on to good take-up of your products by new customers, and good retention of existing customers. Mediocre at best.
    Hi

    a new refreshed version of ITNM 3.9 is available now on Passport Advantage. It includes the ITNM Fixpack 2. According to my notes here, it should be possible to install it on RHEL 6... BUT without TCR, because the Cognos Version that is shipped with TCR does not support RHEL 6. Here is the instruction how this can be achieved:

    ITNM 3.9 Refresh Image - Installation
    Updates

    Reports do not need to be installed:
    ./install.sh -DinstallReports=0
    This allows ITNM 3.9 Refresh to install on Red Hat
    6, which Cognos (part of TCR) does not support yet.
    • Windows - can install into non-C: drive and directories with spaces
    • ConfigTCR scripts now provided for manual TCR configuration.
    • Specific logs now searched for error strings to aid debug

    • On 64-Bit TIP, ITNM 3.9 Refresh will not bundle/install with TCR.
    User is required to install TCR prior to ITNM.

    hth
    Hans