Topic
  • 4 replies
  • Latest Post - ‏2012-08-22T22:54:17Z by Berniebgbb
MokarromHossain
MokarromHossain
3 Posts

Pinned topic DS5100 Performance issue.........

‏2012-03-01T05:30:34Z |
Dear Guru`s

I am facing some performance issue. My storage is DS5100 which is running for SAP. When media scan run in ds5100 SAP getting performance slow.
Another problem when ERM (ds5100-ds5100) running that time also SAP getting performance slow.

Details: DS5100
Firmware version: 07.60.52.00

OS: RHEL5 (2.6.18-238)

Can some one help me ..............

Thanks
Updated on 2012-08-22T22:54:17Z at 2012-08-22T22:54:17Z by Berniebgbb
  • kopper
    kopper
    178 Posts

    Re: DS5100 Performance issue.........

    ‏2012-08-14T20:30:14Z  
    hi were you able to fix your issue with your DS5100? what the Storage? San Switch or Red Hat?

    I am having a similar issue
  • Berniebgbb
    Berniebgbb
    83 Posts

    Re: DS5100 Performance issue.........

    ‏2012-08-22T11:26:34Z  
    Statements from the Redbook.

    1. We have seen no effect on I/O with a 30 day setting (Default) unless the processor is utilized in excess
    of 95%.

    2. If the media scan process sees it is reaching its maximum run time and calculates
    that it is not going to complete in the time remaining, it will increase its priority and can impact
    host processing.

    3. Shorter schedules require lower utilization rates to avoid impact.
    Options.
    1. You could try setting the Srubbing to every 7 days and have it fall on a Saturday or Sunday, you will need to do a controller reset on Saturday or Sunday to start the correct Cycle.

    2. Disable Media Scan on ALL VOLUMES and Script it to run when you want, however I would not leave it beyond 30 days. Eventually the physical Disks will force a scan and it may take many hours to perform definitely impacting performance.

    Would be worth checking how much load is actually on the array.....Are you near the 95% utilisation mark?

    Bernie
  • kopper
    kopper
    178 Posts

    Re: DS5100 Performance issue.........

    ‏2012-08-22T15:47:50Z  
    Statements from the Redbook.

    1. We have seen no effect on I/O with a 30 day setting (Default) unless the processor is utilized in excess
    of 95%.

    2. If the media scan process sees it is reaching its maximum run time and calculates
    that it is not going to complete in the time remaining, it will increase its priority and can impact
    host processing.

    3. Shorter schedules require lower utilization rates to avoid impact.
    Options.
    1. You could try setting the Srubbing to every 7 days and have it fall on a Saturday or Sunday, you will need to do a controller reset on Saturday or Sunday to start the correct Cycle.

    2. Disable Media Scan on ALL VOLUMES and Script it to run when you want, however I would not leave it beyond 30 days. Eventually the physical Disks will force a scan and it may take many hours to perform definitely impacting performance.

    Would be worth checking how much load is actually on the array.....Are you near the 95% utilisation mark?

    Bernie
    thanks Bernie

    thanks a lot for the info

    just one question how do I "Would be worth checking how much load is actually on the array.....Are you near the 95% utilisation mark?"?

    How do I check the load on the Array?

    also you mention something related with processor 95% utilization...how do you check processor utilization? I searched and I found out check processor utilization on these DS was not possible

    thanks
  • Berniebgbb
    Berniebgbb
    83 Posts

    Re: DS5100 Performance issue.........

    ‏2012-08-22T22:54:17Z  
    Hi,

    You can get it via SMI-S, I know that IntelliMagic can get the info, I would think that TPC can as well.

    Bernie.