Topic
  • 3 replies
  • Latest Post - ‏2014-03-31T11:41:41Z by adiksw
SureshR19
SureshR19
3 Posts

Pinned topic Friendly Url's VS portal navigational model url's WPS 7.0.0.1

‏2012-02-23T13:46:08Z |
Hi,

I have a problem with my portal application which uses both Navigational Model SPI to generate some of the links to portal pages and other are using friendly url's. So in this case, if any friendly url is invalid my entire portal is breaking.

For Eg: http://mysite.com/wps/portal/test/test1/

where test1 does not exist, in this case as per portal's default behavior, it redirects to http://mysite.com/wps/portal/test/ + <it adds the navigational state of page, which is really difficult trace, how this is being added.>

Till now its fine, there is a page test and user redirects to test, but if i click on any other page link which is formed using Navigational model SPI, it breaks and shows me 404.

Is it ok, to add "keepNavigationalState" attribute value set to false to portal navigational model url's. Doing so, its working fine.

Thanks,
Suresh
Updated on 2012-08-06T17:55:40Z at 2012-08-06T17:55:40Z by SureshR19
  • jwbarnes
    jwbarnes
    872 Posts

    Re: Friendly Url's VS portal navigational model url's WPS 7.0.0.1

    ‏2012-03-21T19:59:20Z  
    what error are you seeing in the logs? so are you redirecting to test1 first is that the flow?


    IBM Certified System Administrator -- WebSphere Portal V6.0,
    IBM Certified Solution Developer -- WebSphere Portal v6.0, v6.1, V7.0

    The postings on this site are my own and do not necessarily represent the positions, strategies, or opinions of IBM
  • SureshR19
    SureshR19
    3 Posts

    Re: Friendly Url's VS portal navigational model url's WPS 7.0.0.1

    ‏2012-08-06T17:55:40Z  
    • jwbarnes
    • ‏2012-03-21T19:59:20Z
    what error are you seeing in the logs? so are you redirecting to test1 first is that the flow?


    IBM Certified System Administrator -- WebSphere Portal V6.0,
    IBM Certified Solution Developer -- WebSphere Portal v6.0, v6.1, V7.0

    The postings on this site are my own and do not necessarily represent the positions, strategies, or opinions of IBM
    Thanks for your reply Jim.

    Here's how I resolved the issue.

    http://www.ibm.com/developerworks/forums/thread.jspa?threadID=418697&tstart=0

    Thanks,
    Suresh
  • adiksw
    adiksw
    1 Post

    Re: Friendly Url's VS portal navigational model url's WPS 7.0.0.1

    ‏2014-03-31T11:41:41Z  

    Hi.

    How did you develop a friendly URLs without navigational state on Portal v7?

    Updated on 2014-03-31T11:43:36Z at 2014-03-31T11:43:36Z by adiksw