Topic
1 reply Latest Post - ‏2012-03-02T00:53:06Z by SystemAdmin
yuang
yuang
9 Posts
ACCEPTED ANSWER

Pinned topic telelogic synergy change 5.0 startup with errors

‏2012-02-22T10:03:31Z |
Hi.

I startup change 5.0 with errors , when i surf the website: http://hostname:8600/ (or http://hostname:8600/admin) , it appears error (no login interface):
HTTP ERROR: 500
Unable to compile class for JSP
Generated servlet error:
Feb 22, 2012 1:55:53 AM org.apache.jasper.compiler.Compiler generateClass
SEVERE: Javac exception
Error starting modern compiler
+ at org.apache.tools.ant.taskdefs.compilers.Javac13.execute(Javac13.java:63)+
+ at org.apache.tools.ant.taskdefs.Javac.compile(Javac.java:936)+
+ at org.apache.tools.ant.taskdefs.Javac.execute(Javac.java:758)+
+ at org.apache.jasper.compiler.Compiler.generateClass(Compiler.java:382)+
+ at org.apache.jasper.compiler.Compiler.compile(Compiler.java:472)+
+ at org.apache.jasper.compiler.Compiler.compile(Compiler.java:451)+
+ at org.apache.jasper.compiler.Compiler.compile(Compiler.java:439)+
+ at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:511)+
+ at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:295)+
+ at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:292)+
+ at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:236)+
+ at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)+
+ at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:428)+
+ at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler.java:473)+
+ at org.mortbay.jetty.servlet.Dispatcher.dispatch(Dispatcher.java:286)+
+ at org.mortbay.jetty.servlet.Dispatcher.forward(Dispatcher.java:171)+
+ at org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1085)+
+ at org.apache.struts.action.RequestProcessor.processForwardConfig(RequestProcessor.java:398)+
+ at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:241)+
+ at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)+
+ at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)...+

My java version is 1.6.0 , and i have tried to copy tools.jar to cs_app/lib and cs_app/ext and cs_app/webapps/synergy/WEB-INF/lib , it still not working.
Please help me! Thanks a lot!
Updated on 2012-03-02T00:53:06Z at 2012-03-02T00:53:06Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    174 Posts
    ACCEPTED ANSWER

    Re: telelogic synergy change 5.0 startup with errors

    ‏2012-03-02T00:53:06Z  in response to yuang
    A Google search for "Error starting modern compiler" suggests that an older version of Java may be confusing the JSP implementation when it attempts to invoke a Java compiler.

    I don't know what might be causing that in this case, but I would check for the existence of other Java installations and if they are in the system PATH. Also check for a system CLASSPATH that could also confuse what gets loaded.