Topic
6 replies Latest Post - ‏2012-02-29T13:15:09Z by Sammy1984
Sammy1984
Sammy1984
14 Posts
ACCEPTED ANSWER

Pinned topic Configuring NCPOLLDATA datasource to Oracle

‏2012-02-17T20:01:55Z |
Hi,

The below are the environment details:

Operating System: RHEL 5.5 64bit
IBM tools: ITNM 3.9, DB2 9.7, ITM agent for ITNM
Oracle 11g is used for TDW.

My issue is when I am trying to configure NCPOLLDATA datasource for Cognos, I am unable to make connection. I am getting below error code.

QE-DEF-0285 The logon failed


I have installed and configured ITM agent for ITNM as it is required for Performance Reports. KNP_POLL_DATA_COLLECTION table is created in TDW and I am able to view data in it. When I am trying to configure NCPOLLDATA datasource to TDW which is on Oracle, I am getting this error. However I successfully configured NCPOLLDATA datasource for ITNM BIRT based reports using below command.

trcmd.sh -modify -dataSources -reports -reportName 
"/content/package[@name='Network Manager']/folder[@name='Performance Reports']/report[@name='Device Availability Summarization']" -username tipadmin -password tipadmin -dataSource name=NCPOLLDATA -setDatasource odaURL=
"jdbc:oracle:thin:@tivolibocodb01:1532:TIVOPROD" odaDriverClass=
"oracle.jdbc.driver.OracleDriver" odaUser=xxxx odaPassword=xxxx


Kindly find the attachment along with this post for detailed information.

Any help in this regard is really appreciated.

Thank you.
Updated on 2012-02-29T13:15:09Z at 2012-02-29T13:15:09Z by Sammy1984
  • hansolobmxrider
    hansolobmxrider
    6 Posts
    ACCEPTED ANSWER

    Re: Configuring NCPOLLDATA datasource to Oracle

    ‏2012-02-22T09:45:41Z  in response to Sammy1984
    Hi Sammy,

    Nice to meet your on-line acquaintance.

    What user and password are you using to access the NCPOLLDATA datasource?

    For example what user have you got access from the DB2 command line to access the NCPOLLDATA source?

    (A default DB2 user is db2inst1 would have access).

    Many Thanks

    Neil
  • hansolobmxrider
    hansolobmxrider
    6 Posts
    ACCEPTED ANSWER

    Re: Configuring NCPOLLDATA datasource to Oracle

    ‏2012-02-22T10:18:16Z  in response to Sammy1984
    Hi Sammy,

    Ignore my above post. I failed to read the post properly in between doing other things.

    Looking at the attachment I vaguely remember a similar problem with ITNM 3.8 though.

    It was using a 10g client to connect to an 11g database.

    The DBA had SQLNET.ALLOWED_LOGON_VERSION set to 10 in the sqlnet.ora file. This meant that a minimum of 10g could connect. However, this was not working as desired
    and the only way I could connect was by commenting out this parameter.

    Perhaps you are encountering a similar problem as ITNM uses a mixture of thin and fat clients to connect.

    Thanks

    Neil
    • Sammy1984
      Sammy1984
      14 Posts
      ACCEPTED ANSWER

      Re: Configuring NCPOLLDATA datasource to Oracle

      ‏2012-02-22T18:59:35Z  in response to hansolobmxrider
      Hi Neil,

      Thank you for going through my post.

      I did not find any such option in sqlnet.ora file. I have set all the required environment variables etc., but still facing same issue.

      Kindly go through the attached document along with this post for detailed information.

      Awaiting for your reply
      Thank you.
      • Sammy1984
        Sammy1984
        14 Posts
        ACCEPTED ANSWER

        Re: Configuring NCPOLLDATA datasource to Oracle

        ‏2012-02-22T19:01:47Z  in response to Sammy1984
        Hi Neil,

        Sorry I missed the attachment.
        • Sammy1984
          Sammy1984
          14 Posts
          ACCEPTED ANSWER

          Re: Configuring NCPOLLDATA datasource to Oracle

          ‏2012-02-22T19:13:03Z  in response to Sammy1984
          Kindly find the attachment...
          • Sammy1984
            Sammy1984
            14 Posts
            ACCEPTED ANSWER

            Re: Configuring NCPOLLDATA datasource to Oracle

            ‏2012-02-29T13:15:09Z  in response to Sammy1984
            Hello everyone,

            We fixed this issue by manually entering TDW details in DbLoings.<domain>.cfg file under $NCHOME/etc/precision directory.

            Thank you.