Topic
  • 8 replies
  • Latest Post - ‏2012-12-10T15:51:35Z by SystemAdmin
ogniemi
ogniemi
5 Posts

Pinned topic no DLPAring possible

‏2012-02-08T11:04:05Z |
HMC and LPARs can communitate in both directions on 657 udp/tcp but DLPARing is not possible (HMC says thet RMC doesn;t work).

on LPARs:
lsrsrc IBM.MCP --- doesn't reurn HMC info

on HMC:
lspartition -dlpar ---- return nothig.

"hmcshutdown -r -t now" -- doesn't solve the problem.

Also LPAR restart doesn't fix problem. RMC subsystems are running, telnet o port 657 works.

there are different types of servers (P6 and P7) managed by that HMC but noone in DLPARable....

HMC version:
"version= Version: 7
Release: 7.4.0
Service Pack: 0
HMC Build level 20111010.1
MH01275: Required fix for HMC V7R7.4.0 (10-10-2011)
MH01296: Fix for HMC V7R7.4.0 (11-07-2011)
","base_version=V7R7.4.0
Example P7 server version:
LPAR: AIX 6.1 TL7
VIOS: 2.2.1.0
Firmware: AL730_049
so supported according to http://www-933.ibm.com/support/fixcentral/firmware/supportedCombinations

Firewall on HMC has enabled 657 tcp/udp port

any idea what else can be checked?
best regards,
oo
Updated on 2012-12-10T15:51:35Z at 2012-12-10T15:51:35Z by SystemAdmin
  • j.gann
    j.gann
    193 Posts

    Re: no DLPAring possible

    ‏2012-02-08T13:03:33Z  
    there used to be an excellent dlpar checklist on dw which has gone now..

    but this one might be as helpful, (should be in an faq...) : http://www-01.ibm.com/support/docview.wss?rs=111&context=SWG10&q1=dcaps&uid=isg3T1010615&loc=en_US&cs=utf-8&lang=en
  • ogniemi
    ogniemi
    5 Posts

    Re: no DLPAring possible

    ‏2012-02-08T15:32:31Z  
    • j.gann
    • ‏2012-02-08T13:03:33Z
    there used to be an excellent dlpar checklist on dw which has gone now..

    but this one might be as helpful, (should be in an faq...) : http://www-01.ibm.com/support/docview.wss?rs=111&context=SWG10&q1=dcaps&uid=isg3T1010615&loc=en_US&cs=utf-8&lang=en
    this is exactly the url which I have tested before I decided to wrote here on forum....

    alas i didn;t find any solution there.... it only says that for my case IBM support can only help...

    if yes, thany it would mean that newest HMC version has a bug....
  • SystemAdmin
    SystemAdmin
    6902 Posts

    Re: no DLPAring possible

    ‏2012-02-08T16:44:59Z  
    I had the same problem couple weeks ago... A new restriction introduced with v7r7.4, you cannot have 2 partitions (1 off and 1 active)with the same IP address managed by a HMC.
  • SystemAdmin
    SystemAdmin
    6902 Posts

    Re: no DLPAring possible

    ‏2012-02-08T16:55:37Z  
    I had the same problem couple weeks ago... A new restriction introduced with v7r7.4, you cannot have 2 partitions (1 off and 1 active)with the same IP address managed by a HMC.
    In my case, it was just some partitions... not all, maybe it's not the same problem
  • Romingw
    Romingw
    1 Post

    Re: no DLPAring possible

    ‏2012-03-23T13:58:27Z  
    In my case, it was just some partitions... not all, maybe it's not the same problem
    I have the same problem, anyone knows a solution? Should I downgrade HMC to V7R7.3?

    Sherry
  • SystemAdmin
    SystemAdmin
    6902 Posts

    Re: no DLPAring possible

    ‏2012-03-26T04:07:44Z  
    • Romingw
    • ‏2012-03-23T13:58:27Z
    I have the same problem, anyone knows a solution? Should I downgrade HMC to V7R7.3?

    Sherry
    1. What are common reasons for failures with Dynamic Logical partitioning ?

    Maximum time cause will be the broken RMC connection between HMC and LPARs.

    a) Login to HMC cli.

    b) lspartition -dlpar

    if you can't see any o/p then there is an RMC problem.

    c) close all Serviceable Events and reboot the HMC.

    d) hmcshutdown -r -t now

    After HMC reboot wait go for a coffee :)

    e) lspartition -dlpar

    if still no o/p then log a call with IBM.

    Assume DLPAR is working for other LPARs on this HMC :

    a) login to the LPAR

    b) su - root

    c) lssrc -a |grep rsct

    root# lssrc -a|grep rsct
    ctrmc rsct 291002 active
    IBM.ServiceRM rsct_rm 422096 active
    IBM.CSMAgentRM rsct_rm 327864 active
    IBM.DRM rsct_rm 286890 active
    IBM.SensorRM rsct_rm 426212 active
    IBM.ConfigRM rsct_rm 323612 active
    ctcas rsct inoperative
    IBM.AuditRM rsct_rm inoperative
    IBM.LPRM rsct_rm inoperative
    IBM.ERRM rsct_rm inoperative
    IBM.HostRM rsct_rm inoperative
    IBM.MgmtDomainRM rsct_rm inoperative
    IBM.FSRM rsct_rm inoperative
    IBM.WLMRM rsct_rm inoperative

    IBM.DRM is the most important daemon for DLPAR !
    You can try stop and starting RMC as below ,

    d) /usr/sbin/rsct/bin/rmcctrl -Z

    e) /usr/sbin/rsct/bin/rmcctrl -A

    f) /usr/sbin/rsct/bin/rmcctrl -P

    now try with below command again if you luckly.

    g) lssrc -a|grep rsct

    check for IBM.DRM if yes then this is resolved !

    go to HMC cli again

    h) lspartition -dlpar

    if you can see the O/P then it's resolved
    Hope this will have you guys !
    Dipak Warade
    www.unix4you.com
  • SystemAdmin
    SystemAdmin
    6902 Posts

    Re: no DLPAring possible

    ‏2012-11-16T09:34:13Z  
    Hi Ken,
    have you solved your problem?
    I have a similar problem. I have a IP NAT between HMC and some LPAR.
    In old p5 worked well but in new p7 (and AIX6.1 LPAR) this communication does not work.
    Do you have a NAT? If yes, how did you solve it?
    TKS
  • SystemAdmin
    SystemAdmin
    6902 Posts

    Re: no DLPAring possible

    ‏2012-12-10T15:51:35Z  
    Hi Ken,
    have you solved your problem?
    I have a similar problem. I have a IP NAT between HMC and some LPAR.
    In old p5 worked well but in new p7 (and AIX6.1 LPAR) this communication does not work.
    Do you have a NAT? If yes, how did you solve it?
    TKS
    we have some problem. AIX 7.1 and NAT LPAR do not work :/