Topic
  • 4 replies
  • Latest Post - ‏2012-02-08T06:33:34Z by SystemAdmin
yhlvqz
yhlvqz
23 Posts

Pinned topic license error in linux cluster

‏2012-02-08T03:02:01Z |
I recently tried to run cplexlsqlin on linux cluster
but it showed error as following:
CPLEX Error 32201: ILM Error 16: CPLEX:
license file not found or unreadable

I have set up environment variable: export ILOG_LICENSE_FILE = path which include the access key

I used : echo $ILOG_LICENSE_FILE to check I added the environment variable successfully.
and I used: ls path/access.ilm to check no .txt extension there

But the error is still there. Anyone can give me some suggestions? Thanks
Updated on 2012-02-08T06:33:34Z at 2012-02-08T06:33:34Z by SystemAdmin
  • yhlvqz
    yhlvqz
    23 Posts

    Re: license error in linux cluster

    ‏2012-02-08T03:08:11Z  
    in the quick start manual, it is said make sure this environment variable is initialized each time I use the software. How do this step? Thanks
  • yhlvqz
    yhlvqz
    23 Posts

    Re: license error in linux cluster

    ‏2012-02-08T03:42:03Z  
    solve the problem. I should include the license file name on environment variable path.
  • SystemAdmin
    SystemAdmin
    7929 Posts

    Re: license error in linux cluster

    ‏2012-02-08T06:27:03Z  
    • yhlvqz
    • ‏2012-02-08T03:42:03Z
    solve the problem. I should include the license file name on environment variable path.
    Correct. The environment variable must point to the license file itself, not to the folder that contains the file.
    This detail is mentioned several times on the Forum here.
  • SystemAdmin
    SystemAdmin
    7929 Posts

    Re: license error in linux cluster

    ‏2012-02-08T06:33:34Z  
    • yhlvqz
    • ‏2012-02-08T03:08:11Z
    in the quick start manual, it is said make sure this environment variable is initialized each time I use the software. How do this step? Thanks
    One way to achieve that is to add the variable setting to your local shell-startup configuration. This is $HOME/.bashrc if you use bash or $HOME/.cshrc if you use csh. You may also ask your administrator to add this setting to the global shell initialization file.