IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 6 replies
  • Latest Post - ‏2013-11-21T08:43:51Z by Sherif Zaki
bud_235
bud_235
1 Post

Pinned topic not able to create a profile

‏2012-02-03T06:34:30Z |
i am using WAS 7 and RAD 7.5, when i am trying to create a profile i am getting the error "The profile creation tool cannot be launched. Ensure that the runtime location is correct."

so can anyone help me to resolve this problem...

Thanks in Advance.
Updated on 2013-02-28T11:15:20Z at 2013-02-28T11:15:20Z by SystemAdmin
  • mdowden
    mdowden
    2 Posts

    Re: not able to create a profile

    ‏2012-02-21T21:31:54Z  
    I am experiencing a similar problem in RAD 8.0.3 iFix 1 with WAS 6.1.

    When trying to run the Profile Management Tool I receive a message "The profile creation tool cannot be launched. Ensure that the runtime location is correct." The WAS 6.1 path (shown in the screenshot) is D:\IBM\SDP\runtimes\base_v61, which is correct. I encountered this problem when trying to create a new profile immediately after deleting an old profile. I have checked my environment variables and WAS location, have tried restarting RAD and restarting the computer, but no luck.
  • mdowden
    mdowden
    2 Posts

    Re: not able to create a profile

    ‏2012-02-22T22:26:30Z  
    • mdowden
    • ‏2012-02-21T21:31:54Z
    I am experiencing a similar problem in RAD 8.0.3 iFix 1 with WAS 6.1.

    When trying to run the Profile Management Tool I receive a message "The profile creation tool cannot be launched. Ensure that the runtime location is correct." The WAS 6.1 path (shown in the screenshot) is D:\IBM\SDP\runtimes\base_v61, which is correct. I encountered this problem when trying to create a new profile immediately after deleting an old profile. I have checked my environment variables and WAS location, have tried restarting RAD and restarting the computer, but no luck.
    I may have accidentally stumbled upon the solution... I'm working in Windows 7 and it seems I need to run RAD as Administrator.

    Instead of having to remember this each time you can set this permanently by right-clicking on your link, selecting Properties > Advanced and checking Run as administrator.

    I hope this helps someone.
  • SystemAdmin
    SystemAdmin
    14225 Posts

    Re: not able to create a profile

    ‏2012-08-08T11:34:59Z  
    For 64 bit WAS there is a Tech note "An error occurs when attempting to run the Profile Management Tools on 64-bit WebSphere Application Server v7 test environments" saying that the Profile Management Tool is not provided and you need to use the command line version of the tool.
    http://www-01.ibm.com/support/docview.wss?uid=swg21590525

    I hope this helps.
  • REXQ_Sundareswaran_Selvaraj
    1 Post

    Re: not able to create a profile

    ‏2012-08-13T03:51:48Z  
    • mdowden
    • ‏2012-02-22T22:26:30Z
    I may have accidentally stumbled upon the solution... I'm working in Windows 7 and it seems I need to run RAD as Administrator.

    Instead of having to remember this each time you can set this permanently by right-clicking on your link, selecting Properties > Advanced and checking Run as administrator.

    I hope this helps someone.
    hey.. thanks for your posting.

    it really helped.
  • SystemAdmin
    SystemAdmin
    14225 Posts

    Re: not able to create a profile

    ‏2013-02-28T11:15:20Z  
    I was also using RAD7.5 and WAS 7.0 and not able to create profile or even launch Run Profile Management Tool. When I tried to launch RAD with "Run As Administrator" I was able to launch it and created profile successfully.
    Also we use utility manageprofiles available in app_server_root/bin directory.
  • Sherif Zaki
    Sherif Zaki
    1 Post

    Re: not able to create a profile

    ‏2013-11-21T08:43:51Z  
    I was also using RAD7.5 and WAS 7.0 and not able to create profile or even launch Run Profile Management Tool. When I tried to launch RAD with "Run As Administrator" I was able to launch it and created profile successfully.
    Also we use utility manageprofiles available in app_server_root/bin directory.

    As of WAS 7.0.0.23+ 64-bit , support was introduced for a 64-bit PMT
    GUI application based on eclipse , as per WAS 7.0 APAR:             
    - PM58927: ADD 64 BIT Profile Management Tool(PMT) SUPPORT          
    http://www-01.ibm.com/support/docview.wss?uid=swg1PM58927           
    , fixed in WAS 7.0.0.23+ 64-bit.                                   

     

    Regarding RAD there is a known issue that is fixed in version 9
    APAR is PI06339, you may need to open a PMR to ask for a testfix if you need a non-admin to run RAD and create a WAS profile from there.