Topic
2 replies Latest Post - ‏2012-02-05T07:59:50Z by wgwega
wgwega
wgwega
2 Posts
ACCEPTED ANSWER

Pinned topic websphere Web service error

‏2012-02-02T14:48:43Z |
i am trying to deploy a web service generated from oracle database using jdeveloper 10g to websphere v.7 fix 19, i am always getting errors in the SystemOut.log file that says :

2/2/12 16:39:18:598 EET 00000013 CompositionUn A WSVR0190I: Starting composition unit WebSphere:cuname=WebServices_war_test in BLA WebSphere:blaname=WebServices_war_test.
2/2/12 16:39:18:609 EET 00000013 ApplicationMg A WSVR0200I: Starting application: WebServices_war_test
2/2/12 16:39:18:610 EET 00000013 ApplicationMg A WSVR0204I: Application: WebServices_war_test Application build level: Unknown
2/2/12 16:39:18:629 EET 00000013 WSServerImpl W WSWS1040W: The Web services binding file WEB-INF/ibm-webservices-bnd.xmi was not found in module WebServices.war in application WebServices_war_test. Certain functionality, such as Web services security is not available.
2/2/12 16:39:18:634 EET 00000013 WSServerImpl W WSWS1041W: No Web service description binding is found in the Web services binding file WEB-INF/ibm-webservices-bnd.xmi with the name CUG2.
2/2/12 16:39:18:641 EET 00000013 SystemOut O WSWS3185I: Info: Parsing XML file: /data2/websphere2/IBM/WebSphere/AppServer/profiles/AppSrv01/test/WebServices_war_test.ear/WebServices.war/WEB-INF/wsdl/CUG2.wsdl
2/2/12 16:39:18:644 EET 00000013 SystemOut O Retrieving document at 'file:/data2/websphere2/IBM/WebSphere/AppServer/profiles/AppSrv01/test/WebServices_war_test.ear/WebServices.war/WEB-INF/wsdl/CUG2.wsdl'.
2/2/12 16:39:18:648 EET 00000013 WSDDPort W com.ibm.ws.webservices.engine.deployment.wsdd.WSDDPort expand WSWS3114E: Error: Internal error.
java.lang.ArrayIndexOutOfBoundsException: Array index out of range: 1
at java.util.Vector.elementAt(Vector.java:341)
at com.ibm.ws.webservices.wsdl.symbolTable.BindingOperationEntry.getParameter(BindingOperationEntry.java:206)
at com.ibm.ws.webservices.wsdl.mapping.MappingMetaData.processServiceEndpointInterfaceMapping(MappingMetaData.java:791)
at com.ibm.ws.webservices.wsdl.mapping.MappingMetaData.postSymbolTable(MappingMetaData.java:407)
at com.ibm.ws.webservices.wsdl.toJava.JavaGeneratorFactory.generatorPass(JavaGeneratorFactory.java:528)
at com.ibm.ws.webservices.wsdl.Parser.generate(Parser.java:425)
at com.ibm.ws.webservices.wsdl.Parser.generate(Parser.java:412)
at com.ibm.ws.webservices.wsdl.Parser.run(Parser.java:314)
at com.ibm.ws.webservices.tools.WSDLQuery.parse(WSDLQuery.java:142)
at com.ibm.ws.webservices.engine.deployment.wsdd.WSDDGen.getWSDLQuery(WSDDGen.java:214)
at com.ibm.ws.webservices.engine.deployment.wsdd.WSDDPort.expand(WSDDPo

also in the SystemErr.log i have the following errors:
SystemErr R WSWS3155E: Error: Id not found as an input part OR an output part.
00000017 SystemErr R WSWS3155E: Error: number not found as an input part OR an output part.
00000017 SystemErr R WSWS3155E: Error: type not found as an input part OR an output part.

is this a bug in the server this version or i am missing some thing

also, i tried to use the WSDL2Java.sh on my WSDL file, and it generated the files correctly, so, i don't understand what is the problem
can any one help me?
Updated on 2012-02-05T07:59:50Z at 2012-02-05T07:59:50Z by wgwega
  • mburati
    mburati
    352 Posts
    ACCEPTED ANSWER

    Re: websphere Web service error

    ‏2012-02-02T15:10:37Z  in response to wgwega
    This forum is targetted at Web Experience Factory (formerly WebSphere Portlet Factory) developers using that tool to consume web services from portlets/webapps generated with the WEF product, so it doesn't necessarily have experts on using web services generated by a 3rd party tool on WebSphere Application Server. You may want to try posting your question/issue in the WebSphere Application Server forum. If you have no luck there, then you may need to contact customer support.

    ..mb1
    • wgwega
      wgwega
      2 Posts
      ACCEPTED ANSWER

      Re: websphere Web service error

      ‏2012-02-05T07:59:50Z  in response to mburati
      thank you, i will try to post the issue on websphere application server forums