Topic
  • 8 replies
  • Latest Post - ‏2012-02-16T20:10:16Z by yangling
mistryd
mistryd
28 Posts

Pinned topic Error: Gateway Timeout for launching reports

‏2012-02-01T07:12:12Z |
Hi,

We have many reports in Cognos Upfront.Out of them one of the report started throwing the below error:
The Gateway Timeout has expired. Rest of the reports are running fine.

Any suggestions what could be wrong with that report.

Thanx in advance.

Regards,
Mistry
Updated on 2012-02-16T20:10:16Z at 2012-02-16T20:10:16Z by yangling
  • yangling
    yangling
    38 Posts

    Re: Error: Gateway Timeout for launching reports

    ‏2012-02-01T19:11:24Z  
    Were you able to run this particular report in impserver.exe?

    Also you may refer to this.
  • yangling
    yangling
    38 Posts

    Re: Error: Gateway Timeout for launching reports

    ‏2012-02-01T19:18:17Z  
    Did you check the Event Viewer to see the corresponding errors?

    You may also check here...
  • mistryd
    mistryd
    28 Posts

    Re: Error: Gateway Timeout for launching reports

    ‏2012-02-10T12:50:22Z  
    • yangling
    • ‏2012-02-01T19:18:17Z
    Did you check the Event Viewer to see the corresponding errors?

    You may also check here...
    Hi Vangling,

    Thanx for your reply. But I have observed a strange thing that this reports work fine after 5pm UK time. So do i still have to set the prompttimeout attribute.
    Suggestions appreciated.

    Regards,
    Mistry
  • yangling
    yangling
    38 Posts

    Re: Error: Gateway Timeout for launching reports

    ‏2012-02-13T23:00:59Z  
    • mistryd
    • ‏2012-02-10T12:50:22Z
    Hi Vangling,

    Thanx for your reply. But I have observed a strange thing that this reports work fine after 5pm UK time. So do i still have to set the prompttimeout attribute.
    Suggestions appreciated.

    Regards,
    Mistry
    Is this error only happening for a picklist prompt report?

    Are you on SAN disk for the Cognos 7 install?

    Do you know the exact version of your Cognos 7?
  • mistryd
    mistryd
    28 Posts

    Re: Error: Gateway Timeout for launching reports

    ‏2012-02-14T09:08:57Z  
    • yangling
    • ‏2012-02-13T23:00:59Z
    Is this error only happening for a picklist prompt report?

    Are you on SAN disk for the Cognos 7 install?

    Do you know the exact version of your Cognos 7?
    Hi Vangling,

    We have Cognos 7.4 version installed on Solaris 9. Yes the report have file picklist prompts.

    Thanx in advance.

    Regards,
    Mistry
  • yangling
    yangling
    38 Posts

    Re: Error: Gateway Timeout for launching reports

    ‏2012-02-14T15:10:55Z  
    • mistryd
    • ‏2012-02-14T09:08:57Z
    Hi Vangling,

    We have Cognos 7.4 version installed on Solaris 9. Yes the report have file picklist prompts.

    Thanx in advance.

    Regards,
    Mistry
    7.4 MR2 or MR4?

    Are you on SAN (Storage area network)?

    Yangling, Shaanxi, China.
  • mistryd
    mistryd
    28 Posts

    Re: Error: Gateway Timeout for launching reports

    ‏2012-02-14T16:03:55Z  
    • yangling
    • ‏2012-02-14T15:10:55Z
    7.4 MR2 or MR4?

    Are you on SAN (Storage area network)?

    Yangling, Shaanxi, China.
    Hi Yangling,

    We have Congos 7.4 MR2 . We are not on SAN. Do you have any hints on this problem.
    Your feedback is appreciated.

    Thanx.

    Warm Regards,
    Mistry
  • yangling
    yangling
    38 Posts

    Re: Error: Gateway Timeout for launching reports

    ‏2012-02-16T20:10:16Z  
    • mistryd
    • ‏2012-02-14T16:03:55Z
    Hi Yangling,

    We have Congos 7.4 MR2 . We are not on SAN. Do you have any hints on this problem.
    Your feedback is appreciated.

    Thanx.

    Warm Regards,
    Mistry
    This could be a network performance issue. You may confirm this by running the reports in a web browser locally or close to the IWR server.

    You may run the reports in question for your users by openinig them up in an impserver.exe located in bin directory. And email the PDF to them...