Topic
2 replies Latest Post - ‏2013-02-26T12:10:27Z by SystemAdmin
SystemAdmin
SystemAdmin
7615 Posts
ACCEPTED ANSWER

Pinned topic Error "can't find favorite" - while trying to run Human Service via URL

‏2012-01-26T14:26:29Z |
Hi all,

I'm trying to run a human service via link and getting weird results

Here are some details:
1. The link:

http://<serverName>:<serverPort>/teamworks/executeServiceByName?processApp=FCPAPH&serviceName=V1_FCPA_GlobalSystem

2. The human service is exposed as url (teamworks 7.1) to "All Users" group.

3. Our "WAS" is synchronized with "Active Directory".

In our production environment, we have more than 50 users that managed successfully to run the service.
The problem is with several users that get "can't find favorite" error screen (see screenshot attached), right after the log In Page.

(The full exception in our log is: 2012-01-26 13:06:04,546 WebContainer : 8 ERROR com.lombardisoftware.servlet.ExecuteServiceByNameServlet - com.lombardisoftware.core.TeamWorksException: can't find favorite)

Why did i get "can't find favorite" error, when i actually tried to run human service and NOT bpd?

Is there any configuration issue that I'm missing around those particular users?
Thank's,
Asaf.
Updated on 2013-02-26T12:10:27Z at 2013-02-26T12:10:27Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    7615 Posts
    ACCEPTED ANSWER

    Re: Error "can't find favorite" - while trying to run Human Service via URL

    ‏2012-02-02T18:20:51Z  in response to SystemAdmin
    There is a known issue that, in some use-cases the user data does not synchronize on login. I do not know if this is one. One way you can confirm if it is woudl be to have the user who saw that problem login to the portal and then try the URL. Since I know the portal login synchronizes the user, if that fixes the problem I would suspect that you have found another Use Case where the user does not synchonize so their group membership is not up to date when they attempt to run the service.
    • SystemAdmin
      SystemAdmin
      7615 Posts
      ACCEPTED ANSWER

      Re: Error "can't find favorite" - while trying to run Human Service via URL

      ‏2013-02-26T12:10:27Z  in response to SystemAdmin
      Hi,

      Looks like IBM has provided fixpack (5) for this issue for 7.2 product version.

      Here is the IC details:
      http://www-01.ibm.com/support/docview.wss?uid=swg1IC84745

      Fix pack 5 list for 7.2 product version:
      (Fix release date: 15 February 2013)
      http://www-01.ibm.com/support/docview.wss?uid=swg27022274#7.1.0.3

      I've tried longing into BPM portal, but it didn't fix the problem.
      However, adding the user manually to "allUsers" group via process admin fixed it.