Topic
  • 3 replies
  • Latest Post - ‏2012-02-02T18:50:05Z by SystemAdmin
rnandan
rnandan
2 Posts

Pinned topic Install of the IBM MTP Tool[kit]

‏2012-01-25T16:10:55Z |
1. This is with reference to installation of the mtp toolkit (ibm-mobile-tech-preview-tools-20120109.zip FILES). I was able to successfully install it in eclipse - indigo; but not in RSA 8.0.3. Here is the error:

Cannot complete the install because one or more required items could not be found.
Software being installed: IBM Mobile Platform Development Tools 1.0.0.v20120104_1508 (com.ibm.imp.tools.feature.feature.group 1.0.0.v20120104_1508)
Missing requirement: IBM J2EE UI Component 6.0.203.v20111118_1841 (com.ibm.etools.j2ee.ui 6.0.203.v20111118_1841) requires 'bundle org.eclipse.wst.server.ui [1.1.209,2.0.0)' but it could not be found
Cannot satisfy dependency:
From: IBM Java EE Editors 1.0.0.v20111118_1841 (com.ibm.etools.javaee.editors.feature.feature.group 1.0.0.v20111118_1841)
To: com.ibm.etools.j2ee.ui http://6.0.203.v20111118_1841
Cannot satisfy dependency:
From: IBM Mobile Platform Development Tools 1.0.0.v20120104_1508 (com.ibm.imp.tools.feature.feature.group 1.0.0.v20120104_1508)
To: com.ibm.etools.javaee.editors.feature.feature.group http://1.0.0.v20111118_1841

Any pointers as to the resolution?

2. In the successful install on eclipse-indigo, the samples/tutorials do not show up in the help. Any pointers regarding this?

TIA.

Raghu Harithas.
Updated on 2012-02-02T18:50:05Z at 2012-02-02T18:50:05Z by SystemAdmin
  • jim_zhang
    jim_zhang
    2 Posts

    Re: Install of the IBM MTP Tool[kit]

    ‏2012-01-25T22:40:46Z  
    Raghu,

    The tools does not support install on top of RSA or RAD. You have to start with eclipse 3.7.1 or WTP 3.3.1, as instructed in the file Documentation/ibm_mobile_techpreview_install.html.

    There are no samples or tutorials included in this Tech Preview. In the download for Android or iOS, you get sample projects which you can import into the Eclipse environment (for Android) or XCode (for iOS). Make sure to follow the instructions in the documentation (documentation/index.html).
  • rnandan
    rnandan
    2 Posts

    Re: Install of the IBM MTP Tool[kit]

    ‏2012-02-02T18:44:40Z  
    • jim_zhang
    • ‏2012-01-25T22:40:46Z
    Raghu,

    The tools does not support install on top of RSA or RAD. You have to start with eclipse 3.7.1 or WTP 3.3.1, as instructed in the file Documentation/ibm_mobile_techpreview_install.html.

    There are no samples or tutorials included in this Tech Preview. In the download for Android or iOS, you get sample projects which you can import into the Eclipse environment (for Android) or XCode (for iOS). Make sure to follow the instructions in the documentation (documentation/index.html).
    Hi Jim Zhang:

    I downloaded eclipse-SDK-3.7.1-win32.zip as per the site: http://eclipse.org/downloads/packages/eclipse-classic-371/indigosr1 indicated in the install documented that you provided. I now get a different error:

    Cannot complete the install because one or more required items could not be found.
    Software being installed: IBM Mobile Platform Development Tools 1.0.0.v20120104_1508 (com.ibm.imp.tools.feature.feature.group 1.0.0.v20120104_1508)
    Missing requirement: IBM EMF Workbench UI 5.1.201.v20111114_1856 (com.ibm.etools.emf.workbench.ui 5.1.201.v20111114_1856) requires 'bundle org.eclipse.wst.sse.ui [1.0.101,2.0.0)' but it could not be found
    Cannot satisfy dependency:
    From: IBM J2EE Common UI 7.0.201.v20111114_1856 (com.ibm.etools.j2ee.common.feature.group 7.0.201.v20111114_1856)
    To: com.ibm.etools.emf.workbench.ui http://5.1.201.v20111114_1856
    Cannot satisfy dependency:
    From: IBM Mobile Platform Development Tools 1.0.0.v20120104_1508 (com.ibm.imp.tools.feature.feature.group 1.0.0.v20120104_1508)
    To: com.ibm.etools.j2ee.common.feature.group http://7.0.201.v20111114_1856

    Could you please point me to what the resolution is?

    Thanks.

    regards,
    raghunandan
  • SystemAdmin
    SystemAdmin
    59 Posts

    Re: Install of the IBM MTP Tool[kit]

    ‏2012-02-02T18:50:05Z  
    • rnandan
    • ‏2012-02-02T18:44:40Z
    Hi Jim Zhang:

    I downloaded eclipse-SDK-3.7.1-win32.zip as per the site: http://eclipse.org/downloads/packages/eclipse-classic-371/indigosr1 indicated in the install documented that you provided. I now get a different error:

    Cannot complete the install because one or more required items could not be found.
    Software being installed: IBM Mobile Platform Development Tools 1.0.0.v20120104_1508 (com.ibm.imp.tools.feature.feature.group 1.0.0.v20120104_1508)
    Missing requirement: IBM EMF Workbench UI 5.1.201.v20111114_1856 (com.ibm.etools.emf.workbench.ui 5.1.201.v20111114_1856) requires 'bundle org.eclipse.wst.sse.ui [1.0.101,2.0.0)' but it could not be found
    Cannot satisfy dependency:
    From: IBM J2EE Common UI 7.0.201.v20111114_1856 (com.ibm.etools.j2ee.common.feature.group 7.0.201.v20111114_1856)
    To: com.ibm.etools.emf.workbench.ui http://5.1.201.v20111114_1856
    Cannot satisfy dependency:
    From: IBM Mobile Platform Development Tools 1.0.0.v20120104_1508 (com.ibm.imp.tools.feature.feature.group 1.0.0.v20120104_1508)
    To: com.ibm.etools.j2ee.common.feature.group http://7.0.201.v20111114_1856

    Could you please point me to what the resolution is?

    Thanks.

    regards,
    raghunandan
    You'll have to make sure that http://download.eclipse.org/releases/indigo/, the Indigo Update Site, is in the list of available software sites and that you've checked the box to let it work with all of the known sites when installing software.