Topic
  • 2 replies
  • Latest Post - ‏2012-01-16T19:34:32Z by alon24
alon24
alon24
2 Posts

Pinned topic Working on RAD 8.0.4

‏2012-01-16T11:33:21Z |
Hi,

I am trying IBM-Mobile-Tech-Preview-Tools-update-site-20120105_1421 on my linux ubuntu installation, using RAD 8.0.4, Should this be possible????

When I try creating the LoanInput widget example and get to editing the loanInput HTML file, it does not display the Palette window

Can anyone help?

This is the error:

java.lang.IncompatibleClassChangeError
at com.ibm.etools.webedit.palette.view.HTMLPalettePage.createControl(Unknown Source)
at org.eclipse.gef.ui.views.palette.PaletteView.doCreatePage(Unknown Source)
at org.eclipse.ui.part.PageBookView.createPage(Unknown Source)
at org.eclipse.ui.part.PageBookView.partActivated(Unknown Source)
at org.eclipse.ui.part.PageBookView.showBootstrapPart(Unknown Source)
at org.eclipse.ui.part.PageBookView.createPartControl(Unknown Source)
at org.eclipse.gef.ui.views.palette.PaletteView.createPartControl(Unknown Source)
at org.eclipse.ui.internal.ViewReference.createPartHelper(Unknown Source)
at org.eclipse.ui.internal.ViewReference.createPart(Unknown Source)
at org.eclipse.ui.internal.WorkbenchPartReference.getPart(Unknown Source)
at org.eclipse.ui.internal.Perspective.showView(Unknown Source)
at org.eclipse.ui.internal.WorkbenchPage.busyShowView(Unknown Source)
at org.eclipse.ui.internal.WorkbenchPage$20.run(Unknown Source)
at org.eclipse.swt.custom.BusyIndicator.showWhile(Unknown Source)
at org.eclipse.ui.internal.WorkbenchPage.showView(Unknown Source)
at org.eclipse.ui.internal.WorkbenchPage.showView(Unknown Source)
at org.eclipse.ui.handlers.ShowViewHandler.openView(Unknown Source)
at org.eclipse.ui.handlers.ShowViewHandler.openOther(Unknown Source)
at org.eclipse.ui.handlers.ShowViewHandler.execute(Unknown Source)
at org.eclipse.ui.internal.handlers.HandlerProxy.execute(Unknown Source)
at org.eclipse.core.commands.Command.executeWithChecks(Unknown Source)
at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(Unknown Source)
at org.eclipse.ui.internal.handlers.HandlerService.executeCommand(Unknown Source)
at org.eclipse.ui.internal.handlers.SlaveHandlerService.executeCommand(Unknown Source)
at org.eclipse.ui.internal.ShowViewMenu$3.run(Unknown Source)
at org.eclipse.jface.action.Action.runWithEvent(Unknown Source)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(Unknown Source)
at org.eclipse.jface.action.ActionContributionItem.access$2(Unknown Source)
at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(Unknown Source)
at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
at org.eclipse.ui.internal.Workbench.runEventLoop(Unknown Source)
Updated on 2012-01-16T19:34:32Z at 2012-01-16T19:34:32Z by alon24
  • jim_zhang
    jim_zhang
    2 Posts

    Re: Working on RAD 8.0.4

    ‏2012-01-16T15:45:33Z  
    When installing the Mobile Tech Preview Tools, please follow the instructions included in the download. It should not be installed on top of any version of RAD at this point. Specifically you can only install the mobile tools on top of eclipse 3.7.1 at this point. If you don't already have an eclipse 3.7.1, The best way to get started is by download any of these flavors of eclipse Indigo:

    Eclipse IDE for Java Developers: http://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/indigosr1
    Eclipse IDE for Java EE Developers: http://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/indigosr1
    Eclipse Classic 3.7.1: http://www.eclipse.org/downloads/packages/eclipse-classic-371/indigosr1
  • alon24
    alon24
    2 Posts

    Re: Working on RAD 8.0.4

    ‏2012-01-16T19:34:32Z  
    • jim_zhang
    • ‏2012-01-16T15:45:33Z
    When installing the Mobile Tech Preview Tools, please follow the instructions included in the download. It should not be installed on top of any version of RAD at this point. Specifically you can only install the mobile tools on top of eclipse 3.7.1 at this point. If you don't already have an eclipse 3.7.1, The best way to get started is by download any of these flavors of eclipse Indigo:

    Eclipse IDE for Java Developers: http://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/indigosr1
    Eclipse IDE for Java EE Developers: http://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/indigosr1
    Eclipse Classic 3.7.1: http://www.eclipse.org/downloads/packages/eclipse-classic-371/indigosr1
    Thanks, I installed on Eclipse and it works, Just thought there might be a workaround (like many other times).

    Thanks.