Topic
  • 2 replies
  • Latest Post - ‏2012-01-11T15:25:57Z by geneK
geneK
geneK
7 Posts

Pinned topic Using "Secure Command" operator to invoke script on remote server

‏2012-01-10T22:11:28Z |
I created a control flow in Design Studio that uses a "Secure Command" operator (using SSH).
Then I successfully tested it in the studio.

Now I need to deploy modified application WebSphere server as usual. At this point I am asked to map the server resource from Design Studio client to a System Resource defined in WebSphere. So I go to "Manage System Resources" and try to add a new resource.

No matter what I try, I get back error message:
"The system cannot test the system resource imcloud. Reason Validation of System Resource failed. Reason: RES37626E: The system cannot validate system resource imcloud for the following reason Unknown host: imcloud.torolab.ibm.com"

That message is bogus because the hostname is known on the server (I also tried IP address). Because connection is over SSH I tried to use port 22, but same result.

Anybody had any luck with this operator? If not, I guess I will have to set up a cron job on the remote server.
Updated on 2012-01-11T15:25:57Z at 2012-01-11T15:25:57Z by geneK
  • SystemAdmin
    SystemAdmin
    203 Posts

    Re: Using "Secure Command" operator to invoke script on remote server

    ‏2012-01-10T22:49:28Z  
    Hi.

    I've encountered this error before. We use the Informix packaged version of Infosphere Warehouse(Informix SQL Warehousing Tool). I set up a System Resource of type "Plain Server" to run a "Secure Command". When I tried the option to "Test System Resource", I received the same error you are having.

    I logged this with Support and this was the reply from the support member:
    ----
    I discussed your case with development team. It seems the problem you
    reported is a known issue which you must have an FTP server running on
    your remote system in order for the validate function to work. We have
    take this requirement and consider to improve the function using telnet
    or ssh for the plain server option in our next major release.

    To help your case moving further, could you please try to see if you can
    use the Plain server machine type with a port number of 22 to make the
    Secure Command operator works? You are not able to use the Test button
    to verify the machine information, but based on the feedback from
    development team, the underlying functionality should work. Please give
    it a try and let me know the result.

    If this did not work, you can try to pass the firewall first from your
    Virtual system (using http, telnet, ftp, etc..), then use FTP server
    with port number 21 (automatic fill in if you select FTP server) as
    Admin Console did not do the firewall authentication.. Also please
    confirm if you have only SFTP works, but not for telnet or ftp on your
    Informix system?
    ----

    In my case the System Resource worked fine. It was just the test functionality that caused the error.

    Regards.
  • geneK
    geneK
    7 Posts

    Re: Using "Secure Command" operator to invoke script on remote server

    ‏2012-01-11T15:25:57Z  
    Absolutely right: I ignored the result of the "test" functionality and the job execution went fine.

    Thank you very much Vov & JP.

    Regards,

    Gene