Topic
  • 4 replies
  • Latest Post - ‏2014-06-16T11:55:26Z by Tchayvaz
DMSCORP
DMSCORP
29 Posts

Pinned topic How can I change "Profiling" mode on WAS8 Development Server?

‏2012-01-10T17:06:22Z |
Hi,

I have WAS 8 Test Server installed in my RAD 8 development environment and when it starts, it comes up showing "WebSphere Application Server v8.0 at localhost (Profiling, Synchronized)". Every time I make a change in the project and want to "Run on Server" to see the changes in my browser, it shows a message: "The server is not in run mode. Select from one of the following options" and then the choices of "Switch Mode" or "Continue in the current mode".

This means that everytime I make a change to a HATS transformation or project settings, I have to wait for the server to start twice each time which is very inefficient.

Where do I make a change in the WAS configuration to get it out of "Profiling" mode? I cannot find it in the server configuration.

Many thanks!

Frank Davis
Updated on 2012-01-10T20:11:24Z at 2012-01-10T20:11:24Z by tmparker
  • SystemAdmin
    SystemAdmin
    1192 Posts

    Re: How can I change "Profiling" mode on WAS8 Development Server?

    ‏2012-01-10T17:55:00Z  
    Hi Frank,

    Don't start the WAS 8 server. While in the HATS project view, right click on the project and select Run On Server... or Debug On Server.... This should start the server in Run or Debug mode and not Profile mode.

    Thanks,
    Steve
  • DMSCORP
    DMSCORP
    29 Posts

    Re: How can I change "Profiling" mode on WAS8 Development Server?

    ‏2012-01-10T19:43:40Z  
    Hi Steve,

    I did as you said and stopped the server then right-clicked the project and selected "Run on Server". It spawned a new dialog named "Profile on Server" which didn't allow canceling the profiling so I chose "Debug on Server" and it ran fine without any profiling.

    It appears that "Profiling" must be configured somewhere for "Run on Server" but I cannot find a setting anywhere. Do you have any further suggestions for how to turn profiling off?

    Frank Davis
  • tmparker
    tmparker
    518 Posts

    Re: How can I change "Profiling" mode on WAS8 Development Server?

    ‏2012-01-10T20:11:24Z  
    • DMSCORP
    • ‏2012-01-10T19:43:40Z
    Hi Steve,

    I did as you said and stopped the server then right-clicked the project and selected "Run on Server". It spawned a new dialog named "Profile on Server" which didn't allow canceling the profiling so I chose "Debug on Server" and it ran fine without any profiling.

    It appears that "Profiling" must be configured somewhere for "Run on Server" but I cannot find a setting anywhere. Do you have any further suggestions for how to turn profiling off?

    Frank Davis
    Hi Frank,

    The only time in the past where I experienced a similar situation where the sever always started in Profile mode was when I had installed a third party tool which did Java profiling. It modified the server.xml with some configuration changes and every time I started the server it would automatically go to the Profiling mode. I am not sure if you ave installed and profiling tools on you system that you configured to run with the WAS instance. If you did then this would most likely be the reason for what you are seeing.

    If you want to check your configuration then I would look at the server.xml located at <WS_HOME>\profiles\<APP_SERVER_NAME>\config\cells\<CELL_NAME>\nodes\<NODE_NAME>\servers\<SERVER_NAME>\server.xml

    In my server.xml I found that in the processDefinitions section there was a line for jvmEntries that had been modified. In that line, debugMode was set to true and there were values added to the genericJvmArguments.

    Hopefully this information will help you figure this out.

    Thanks
    Tim
  • Tchayvaz
    Tchayvaz
    1 Post

    Re: How can I change "Profiling" mode on WAS8 Development Server?

    ‏2014-06-16T11:55:26Z  
    • tmparker
    • ‏2012-01-10T20:11:24Z
    Hi Frank,

    The only time in the past where I experienced a similar situation where the sever always started in Profile mode was when I had installed a third party tool which did Java profiling. It modified the server.xml with some configuration changes and every time I started the server it would automatically go to the Profiling mode. I am not sure if you ave installed and profiling tools on you system that you configured to run with the WAS instance. If you did then this would most likely be the reason for what you are seeing.

    If you want to check your configuration then I would look at the server.xml located at <WS_HOME>\profiles\<APP_SERVER_NAME>\config\cells\<CELL_NAME>\nodes\<NODE_NAME>\servers\<SERVER_NAME>\server.xml

    In my server.xml I found that in the processDefinitions section there was a line for jvmEntries that had been modified. In that line, debugMode was set to true and there were values added to the genericJvmArguments.

    Hopefully this information will help you figure this out.

    Thanks
    Tim

    This was helpful. In genericJvmArguments attribute removed arg:  -agentlib:getClasses and server now starts in the correct mode. If i put back  the argument, the server goes back to always start in Profiling mode.

    I dont understand why this worked: For what I know,  -agentlib:getClasses is a ClassLoader viewer related setting.

    Updated on 2014-06-16T11:55:57Z at 2014-06-16T11:55:57Z by Tchayvaz