Topic
3 replies Latest Post - ‏2012-12-13T10:33:42Z by SystemAdmin
PontiacGeronimo
PontiacGeronimo
3 Posts
ACCEPTED ANSWER

Pinned topic installios issue (HMC7.7.4)

‏2012-01-09T09:12:29Z |
Why the installios fails with belowerror and how to skip it?


Do you accept the license agreement? y/n: y nimol_config ERROR: The NIMOL_SERVER hostname 
"10.XXX.XXX.XXX" already exists in /etc/nimol.conf. nimol_config MESSAGE: Running undo... ERROR 

for nimol_config. umount2: Invalid argument umount: /media/cdrom: not mounted nimol_install ERROR: Unable to find the label corresponding to ioserver in /etc/nimol.conf ERROR unconfiguring nimol_install.

as you know HMC has restricted shell so how to modify /etc/nimol.conf to get installios satisfied?

I can mount /media/cdrom manually and list files on it so it is not mounting issue.
All client informations I enter is valid:

The following objects of type 
"virtual I/O server partition" were found.  Please select one:   1. vios01 2. vios02   Enter a number (1-2): 1   The following objects of type 
"profile" were found.  Please select one:   1. Normal   Enter a number: 1 Enter the source of the installation images [/dev/cdrom]: Enter the client
's intended IP address: 10.XXX.XXX.XXX Enter the client
's intended subnet mask: 255.255.255.0 Enter the client
's gateway: 10.XXX.XXX.XXX Enter the client
's speed [100]: auto Enter the client
's duplex [full]: auto Would you like to configure the client
's network after the installation [yes]/no? yes Please select an adapter you would like to use 

for 

this installation. (WARNING: The client IP address must be reachable through 

this adapter! 1. eth0 10.XXX.XXX.XXX 2. eth1 192.168.128.1 3. eth2 Enter a number (1-3): 1

Is it strange because I had already installed VIO servers in the same subnet from that HMC server in the past....

How to reset/modify nimol.conf on HMC?

kind regards,
P.
Updated on 2012-12-13T10:33:42Z at 2012-12-13T10:33:42Z by SystemAdmin
  • PontiacGeronimo
    PontiacGeronimo
    3 Posts
    ACCEPTED ANSWER

    Re: installios issue (HMC7.7.4)

    ‏2012-01-09T09:21:27Z  in response to PontiacGeronimo
    I have run "installios -u" first.

    now checking the installation process...
    • PontiacGeronimo
      PontiacGeronimo
      3 Posts
      ACCEPTED ANSWER

      Re: installios issue (HMC7.7.4)

      ‏2012-01-09T09:36:50Z  in response to PontiacGeronimo
      looks better...

      
      nimol_config MESSAGE: Successfully configured NIMOL. nimol_config MESSAGE: target directory: /extra/default1 nimol_config MESSAGE: source directory: /media/cdrom/nimol/ioserver_res nimol_config MESSAGE: Copying /media/cdrom/nimol/ioserver_res/booti.chrp.mp.ent.Z to /extra/default1... nimol_config MESSAGE: Copying /media/cdrom/nimol/ioserver_res/ispot.tar.Z to /extra/default1... nimol_config MESSAGE: Copying /media/cdrom/nimol/ioserver_res/mksysb to /extra/default1/mksysb... nimol_config MESSAGE: Processing multivolume 1...
      
    • SystemAdmin
      SystemAdmin
      1744 Posts
      ACCEPTED ANSWER

      Re: installios issue (HMC7.7.4)

      ‏2012-12-13T10:33:42Z  in response to PontiacGeronimo
      Thanks, man.
      That helped me as well.