Topic
  • 1 reply
  • Latest Post - ‏2012-01-09T15:34:53Z by DGawron
SystemAdmin
SystemAdmin
1493 Posts

Pinned topic Web Experience Factory and Peoplesfot Versions supported

‏2012-01-06T14:10:23Z |
We are trying out the Web Experience Factory builder for Peoplesoft and are running into several issues. The documentation states that peopletools version 9.0 is supported, however our developer says that the latest version of peopletools is 8.5 with version 9.1 of the peoplesoft HRMS. Can you please clarify which version of peoplesoft is supported with whoch version of peopletools. here is an excerpt of his comments

I tried to use both Websphere Experience Factory 7.0.1 and Websphere Portlet Factory 6.1.5. However, I was not able to connect to PeopleSoft using either of the two, the reason seems to be a very strong dependency of the two versions of Websphere Portlet Factory on a specific version of PeopleTools. Websphere Experience Factory 7.0.1 documentation says that it works with PeopleTools 9.0 and Websphere Portlet Factory 6.1.5 documentation says it works with PeopleTools 8.48.

Its not the PeopleSoft HRMS version, but the associated PeopleTools version that dictates whether Websphere Portlet factory will work or not. We have PeopleTools 8.50 with PeopleSoft HRMS 9.1 installation. I am not sure if we can change PeopleTools versions across various implementations. There is a jar file that PeopleTools provides, we need that jar to be able to connect to PeopleSoft. Whenever I try to configure the portlet model to connect to PeopleSoft, the portlet factory shows an error indicating an unsupported class version.

Updated on 2012-01-09T15:34:53Z at 2012-01-09T15:34:53Z by DGawron
  • DGawron
    DGawron
    76 Posts

    Re: Web Experience Factory and Peoplesfot Versions supported

    ‏2012-01-09T15:34:53Z  
    You're correct, it's the PeopleTools version that is important since WEF uses the PSJOA JAR from the PeopleSoft install to communicate with the server. I'll have the doc team look into correcting the release notes for 7.0.1.

    The unsupported class version error indicates you are trying to run a JAR compiled with a more recent Java compiler (say 1.6) on an older JVM (say 1.5). What JVM version are you running with Portal and what version was used to compile the JAR?