Topic
13 replies Latest Post - ‏2012-12-05T13:48:25Z by SystemAdmin
ssstew
ssstew
18 Posts
ACCEPTED ANSWER

Pinned topic Error backing up for upgrade from 6.2 to 6.3

‏2012-01-04T00:42:31Z |
Hi All

I’ve got a problem trying to update our IBM Director install from v6.2 to v6.3. I have followed all the notes and am at the part of installing where it asks you to save and migrate your data, this goes through to the point of me clicking Install at which point it starts the smsave command to backup the data but fails with the error :-

Failed to get tiv Guid

Which I have found an article on linked to below, but it doesn’t help me as it says the fix in 6.3, which I cannot seem to update to so I can get the fix, I’m stuck in a catch 22 it seems.

http://www-01.ibm.com/support/docview.wss?uid=isg1IC76834

What do you think? Anything I can do? If I untick the save and migrate option above I’m thinking it’s going to install a blank install of 6.3 which is no good…..

Cheers
Updated on 2012-12-05T13:48:25Z at 2012-12-05T13:48:25Z by SystemAdmin
  • bstrampel
    bstrampel
    1 Post
    ACCEPTED ANSWER

    Re: Error backing up for upgrade from 6.2 to 6.3

    ‏2012-01-05T08:20:09Z  in response to ssstew
    I have the exact same problem. If you do the installation without backup you get a scratch install, no upgrade. I have uninstalled TSM agent(s), didn't help. Downloaded the latest install (with the a extention), same error.
  • JRRichard
    JRRichard
    34 Posts
    ACCEPTED ANSWER

    Re: Error backing up for upgrade from 6.2 to 6.3

    ‏2012-01-09T19:41:32Z  in response to ssstew
    The link to the APAR may say that the problem is fixed in 6.3 but that can mean that 6.3 going forward would not hae the problem.
    Since in the upgrade/migration flow the smsave getting called is the 6.2.x version of smsave which could still have the problem.

    The APAR lists
    REFERENCE: 20110610-LAFix
    Possibly that patch needs to be applied to the 6.2 server before upgrade?

    JR Niemi
    IBM STG
  • LaurentVanel
    LaurentVanel
    11 Posts
    ACCEPTED ANSWER

    Re: Error backing up for upgrade from 6.2 to 6.3

    ‏2012-01-09T20:47:01Z  in response to ssstew
    I had the same problem, the smsave command would fail with version 6.2.1.2 of systems director , installing the fix (a 525kb file named pextensions.jar) would fix the smsave, and this part of the upgrade to 6.3 has worked.
    • ssstew
      ssstew
      18 Posts
      ACCEPTED ANSWER

      Re: Error backing up for upgrade from 6.2 to 6.3

      ‏2012-01-09T21:14:27Z  in response to LaurentVanel
      Laurent - this sounds interesting. how do you install the fix? (pextensions.jar)
  • LaurentVanel
    LaurentVanel
    11 Posts
    ACCEPTED ANSWER

    Re: Error backing up for upgrade from 6.2 to 6.3

    ‏2012-01-09T21:28:06Z  in response to ssstew
    If you have support ask for fix IC76834, and they will give you the official procedure.
    Else
    1. Stop ISD server
    2. Go to the directory {Director Install Path}\bin\pdata\
    3. Move the existing pextensions.jar file to a backup directory
    4. Copy the new jar below into the directory
  • LaurentVanel
    LaurentVanel
    11 Posts
    ACCEPTED ANSWER

    Re: Error backing up for upgrade from 6.2 to 6.3

    ‏2012-01-09T21:31:12Z  in response to ssstew
    Be Careful, the fix I provided, is not the same as the one just above.
    The one I put, solve a conflict problem between TivGuid from director and some other Tivoli tool, in my case TSM.
    and the smsave command would fail in director 6.2.1 , and after taht the same command during the migration to 6.3
    would fail as well.
  • LaurentVanel
    LaurentVanel
    11 Posts
    ACCEPTED ANSWER

    Re: Error backing up for upgrade from 6.2 to 6.3

    ‏2012-01-09T21:31:15Z  in response to ssstew
    Be Careful, the fix I provided, is not the same as the one just above.
    The one I put, solve a conflict problem between TivGuid from director and some other Tivoli tool, in my case TSM.
    and the smsave command would fail in director 6.2.1 , and after taht the same command during the migration to 6.3
    would fail as well.
    • ssstew
      ssstew
      18 Posts
      ACCEPTED ANSWER

      Re: Error backing up for upgrade from 6.2 to 6.3

      ‏2012-01-09T22:05:36Z  in response to LaurentVanel
      Yes i see what you mean, the attached DBCS recovery fix contains a 271k pextensions.jar, where as just the pextensions.jar you attached to your post laurent is 525k, and the original one on my server at the moment is 525k, so think i will try your new 525k one....
      • ssstew
        ssstew
        18 Posts
        ACCEPTED ANSWER

        Re: Error backing up for upgrade from 6.2 to 6.3

        ‏2012-02-16T03:49:45Z  in response to ssstew
        Just wanted to provide a quick update, this fix worked for me, I was able to complete the upgrade without issue, thanks to everyone for their input on this thread :)

        Ive blogged the process for reference here -

        http://sssstew.wordpress.com/2012/02/16/how-to-upgrade-ibm-director-v6-2-to-v6-3/
        • dc_san
          dc_san
          1 Post
          ACCEPTED ANSWER

          Re: Error backing up for upgrade from 6.2 to 6.3

          ‏2012-04-24T21:06:28Z  in response to ssstew
          Thanks a million for posting your answers and your blog link - I had the exact same issue and this fixed it!!
          • ssstew
            ssstew
            18 Posts
            ACCEPTED ANSWER

            Re: Error backing up for upgrade from 6.2 to 6.3

            ‏2012-04-26T02:08:37Z  in response to dc_san
            Cool good to hear. You're welcome :)
  • SystemAdmin
    SystemAdmin
    13279 Posts
    ACCEPTED ANSWER

    Re: Error backing up for upgrade from 6.2 to 6.3

    ‏2012-12-05T13:48:25Z  in response to ssstew
    Hi all,

    I got a similar problem when trying to upgrade form 6.2 to 6.3 on AIX. When I try smsave, the output is like

    Starting execution of Save/Restore/Reset Operations
    Execution: Operation is save to the following location /opt/ibm/director/backup/2012_12_5_15.48.2
    Execution: Loading AgentFile.ext
    Execution: Loading BaseFile.ext
    Execution: Loading MetricsMigration.ext
    Execution: Loading StartAgentFile.ext
    Execution: Loading StopAgentFile.ext
    Execution: Loading ThresholdMigration.ext
    Execution: Loading aem.ext
    Execution: Loading console.ext
    Execution: Loading database.ext
    Execution: Loading databaseMigration.ext
    Execution: Loading defaults.ext
    Execution: Loading discovery.ext
    Execution: Loading elementstorage.ext
    Execution: Loading persistentstorage.ext
    Execution: Loading security.ext
    Execution: Loading skm.ext
    Execution: Loading ssm.ext
    Execution: Loading updates.ext
    Execution: Executing Extensions

    Execution(15:48:2): Starting extension StopAgentFile.ext
    Execution(15:48:2): Extension StopAgentFile.ext failed!

    Execution: Execution of extensions failed. See log for details

    May be I have to replace a similar jar file?

    Kind regards,
    Ekrem