Topic
8 replies Latest Post - ‏2012-11-12T15:05:08Z by SystemAdmin
varadero95
varadero95
4 Posts
ACCEPTED ANSWER

Pinned topic installp_r: the R-Flag Is Currently required for this command

‏2011-12-27T08:12:20Z |
hello
When I want to install an AIX 5.3 TL09 or TL10
I have the following error message:
installp_r: the R-Flag Is Currently required for this command.
Can you tell me the action I need to do.
thank you
Updated on 2012-11-12T15:05:08Z at 2012-11-12T15:05:08Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    6907 Posts
    ACCEPTED ANSWER

    Re: installp_r: the R-Flag Is Currently required for this command

    ‏2011-12-27T09:08:28Z  in response to varadero95
    Hi,

    Could you please repharse your question.

    Are you trying to install the fresh OS with AIX 5.3 TL9 / 10 or you're trying to upgrade the Technology Level ?
    Kannan
  • varadero95
    varadero95
    4 Posts
    ACCEPTED ANSWER

    Re: installp_r: the R-Flag Is Currently required for this command

    ‏2011-12-27T09:42:29Z  in response to varadero95
    In fact I want to move from AIX 5300-08 to 5300-10.
    thank you
    • HemantRamparia
      HemantRamparia
      7 Posts
      ACCEPTED ANSWER

      Re: installp_r: the R-Flag Is Currently required for this command

      ‏2011-12-27T15:34:40Z  in response to varadero95
      Can you please explain the procedure you are using to upgrade.
      • SystemAdmin
        SystemAdmin
        6907 Posts
        ACCEPTED ANSWER

        Re: installp_r: the R-Flag Is Currently required for this command

        ‏2011-12-28T00:53:28Z  in response to HemantRamparia
        This is TL upgrade then..

        You need to download the FULL package for TL9 from IBM site.

        then you can take the alternate disk copy and perform smit update_all.
        Thanks,
        Kannan
  • varadero95
    varadero95
    4 Posts
    ACCEPTED ANSWER

    Re: installp_r: the R-Flag Is Currently required for this command

    ‏2011-12-28T06:55:26Z  in response to varadero95
    Hello and thank you for your answers.
    Sorry for my English
    This is what I did:
    I was in AIX 5.3 TL08
    I upgraded in 5.3 TL09 to install Oracle 11. but that was not enough. So I wanted to upgrade in TL10 but I had a failure during installation. I restored my system and I returned to TL08. Since when I want to upgrade from TL10 smit update_all from ibm package file (bff) I get the message: installp_r: the R-Flag Is Currently required for this command.
    Perhaps you want to delete a file somewhere.
    Thank you for your answers
    • varadero95
      varadero95
      4 Posts
      ACCEPTED ANSWER

      Re: installp_r: the R-Flag Is Currently required for this command

      ‏2012-01-04T09:54:19Z  in response to varadero95
      Hello

      I still have no solution to my problem. I think it was after I restore my message. If someone had a solution or a track, it suits me. Thank you in advance
      • Kosala
        Kosala
        141 Posts
        ACCEPTED ANSWER

        Re: installp_r: the R-Flag Is Currently required for this command

        ‏2012-01-06T10:46:11Z  in response to varadero95
        Before jumping in to the upgrade, I think you need to find out where your system at now. Can you post the output of the following.

        1. lppchk -v
        2. instfix -i | egrep "_ML|_SP"
        3. oslevel -sq

        Cheers,
        Ko
  • SystemAdmin
    SystemAdmin
    6907 Posts
    ACCEPTED ANSWER

    Re: installp_r: the R-Flag Is Currently required for this command

    ‏2012-11-12T15:05:08Z  in response to varadero95
    Hello,

    I am facing the same problem on a AIX 6.1 server
    All operations I am trying to do with installp end up in this error message

    host $ installp -c all
    installp_r: the -R flag is currently required for this command.
    I think something went wrong during a recent update or migration but I can't see the cause.
    Everything looks fine :

    host $ lppchk -v

    host $ lslpp -l bos.rte.install
    Fileset Level State Description
    ----------------------------------------------------------------------------
    Path: /usr/lib/objrepos
    bos.rte.install 6.1.6.16 APPLIED LPP Install Commands

    Path: /etc/objrepos
    bos.rte.install 6.1.6.16 APPLIED LPP Install Commands

    host $ oslevel -rq
    Known Recommended Maintenance Levels
    ------------------------------------
    6100-06
    6100-05
    6100-04
    6100-03
    6100-02
    6100-01
    6100-00

    Any idea is welcome.