Topic
28 replies Latest Post - ‏2013-06-26T18:14:30Z by Lee Wei 2
Lee Wei
Lee Wei
598 Posts
ACCEPTED ANSWER

Pinned topic Report Available: Asset Dashboard

‏2010-05-16T16:00:25Z |

Overview:

  • Displays the summary of 4 selected properties, filtered by computer groups.


Installation:

You should have a \wwwroot\ext-3.2.0 directory.

  • If the \ext-3.2.0 directory already exists, the easiest is to rename it first.
  • Create the report by going to the Reports link/tab in Web Reports.

Scroll to the bottom to find button "Import Report"
Browse to the Asset Management Dashboard v1.2.beswrpt report file in the \ext-3.2.0 directory
It is in an XML format

Requirements:

  • The report has been tested with BigFix 7.2.
  • The charts are produce entirely in JavaScript.
  • FireFox 3.x gives the best experience, but the report will work in IE, Chrome and Safari.
  • The export to Excel function requires Firefox.

Bug Fixes/Enhancements:

  • 2010-05-21 v1.2 Fixed problem with Asset Management report not able to find all analysis.
  • 2010-05-16 v1.1 Initial release on the forum.


Notes:

  • This report is related to and uses the same library as the following reports. So as a bonus, import and try the other reports as well.

Fixlet Compliance by Computer Group v1.6.beswrpt
https://www.ibm.com/developerworks/community/forums/html/topic?id=77777777-0000-0000-0000-000014743529&ps=25

Fixlet Compliance by Content v1.1.beswrpt
https://www.ibm.com/developerworks/community/forums/html/topic?id=77777777-0000-0000-0000-000014744033&ps=25

Lee Wei



Select the properties to display using the Configure button.

 

 

Updated on 2013-09-26T15:08:26Z at 2013-09-26T15:08:26Z by Lee Wei
  • russwm91
    russwm91
    5 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-05-17T23:16:30Z  in response to Lee Wei
    Hello Lee,

    Having and issue with the latest report. I got it to work fine in IE8 and Safari on client workstation, but it just sits and spins under latest version of Firefox 3.6.3. Each report weather it be the Asset Management Dashboard or the Fixlet Compliance report seems to have same issue. On the Asset report you click on it you get a message "loading computer group filter" with a spinning icon in background. I tried uninstall Firefox then rebooting same thing. I use Firefox as my browser since it's more secure. If there is something that I need on my end please advise me.

    Thanks,

    Russ
  • Lee Wei
    Lee Wei
    598 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-05-18T05:03:06Z  in response to Lee Wei
    Hi Russ,

    I use FireFox 3.6.3 primarily, so the browser is probably not the issue.
    Under Tools/Error Console, what is the error that you are getting?

    Lee Wei
  • russwm91
    russwm91
    5 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-05-18T20:29:58Z  in response to Lee Wei
    Hello Lee,

    I checked the error console these are the errors I'm getting.

    1) Syntax error

    http://servername:port/webreports

    100

    2) Ext is not defined

    http://servername:port/ext-3.2.0/ux/highchartpanel/ext.ux.highchartpanel.js

    3) Ext is not defined

    http://servername:port/ext-3.2.0/asset_managment.js

    I also had some one check Google Chrome and it worked great too. I'm completely lost why it works on 3 other browser with no issues.

    Thanks,

    Russ
  • Lee Wei
    Lee Wei
    598 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-05-19T21:29:10Z  in response to Lee Wei
    Russ,

    If other browsers work, it would imply that the server side configurations are good.
    Send me a private message, and I will help debug this.
    I am interested to get to the bottom of this.

    Lee Wei
  • Lee Wei
    Lee Wei
    598 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-05-21T18:44:57Z  in response to Lee Wei
    Russ imported the .beswrpt reports as HTML.
    They should be imported as XML.
    It is interesting to us that some browsers tolerated the extra XML tags, but FireFox didn't like them.

    Lee Wei

    http://www.leewei.com/bigfix/prod/forum_images/forum_topic_5082_image1.png
  • anthonymap91
    anthonymap91
    14 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-05-21T20:40:47Z  in response to Lee Wei
    THIS IS A GREAT REPORT!!!!!! This is what I have been looking for......

    I did notice that it does not show all the properties in all analysis, is there a setting or reason for this?

    I was thinking maybe the rate (every report, every hour..ETC) in which the property is retrieved?
    Thanks for this great report....

    Anthony
  • Lee Wei
    Lee Wei
    598 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-05-21T20:51:17Z  in response to Lee Wei
    anthonymap
    I did notice that it does not show all the properties in all analysis, is there a setting or reason for this?
    Hi,

    Did you notice what types of properties are missing from the analysis? I might be missing something.
    Are they from custom sites? I can't think of a reason offhand, but would love to track it down.

    Lee Wei
  • anthonymap91
    anthonymap91
    14 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-05-21T21:28:04Z  in response to Lee Wei
    I have a custom site some properties showed up and some did not.

    I noticed that the properties that showed up are set to a period of every 1 hour and below. I changed those to every 6 hours and they all where not available anymore from the (Great) report.

    I am not sure why this is happening, I changed some of the anyalsis on the custom site to every report and they still do not appear. It does seem to be something about the custom site though.......I think

    Thanks
  • Lee Wei
    Lee Wei
    598 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-05-21T22:36:40Z  in response to Lee Wei
    I look at the source and there are 2 issues.

    • Firstly, the Analysis filter is currently showing only those Activated. We can change this, but it wouldn't make sense because those not activated have no data.

    • Secondly, on line 178 of the asset_management.js file, change
    
    and active flag of activation of source analysis of it = 
    
    true
    

    to
    
    and exists activations of source analysis of it
    
  • anthonymap91
    anthonymap91
    14 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-05-21T22:48:30Z  in response to Lee Wei
    I would agree that the first change is not necessary.

    I made the change like you suggested to line 178 and it works now. I see all the analysis.

    Thank you very much.
    Just a thought; would there be any way to remove the configure button. Once I create and publish reports as public it would be nice to make sure that no one can change them.
  • Lee Wei
    Lee Wei
    598 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-05-21T22:57:16Z  in response to Lee Wei
    anthonymap
    Just a thought; would there be any way to remove the configure button. Once I create and publish reports as public it would be nice to make sure that no one can change them.
    On line 173, if you comment out the line
    
    renderTo: 
    'configureButton',
    

    to
    
    // renderTo: 'configureButton',
    

    The Configure Button will no longer show up.
    I won't change this in the source and will leave this as a custom change for your use.

    Lee Wei
  • Lee Wei
    Lee Wei
    598 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-05-21T22:58:18Z  in response to Lee Wei
    Thanks for helping to track down this bug.
    I have updated the download link with the fix.

    Lee Wei
  • Lee Wei
    Lee Wei
    598 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-05-22T02:22:02Z  in response to Lee Wei
    anthonymap,

    I just realized that what you want to do by freezing the pre-defined properties won't work.
    The Report saves the properties selected in the browser cookies. So everything browser will start with my defaults (OS, CPU, RAM).

    If you want the report to have the different defaults, you need to modify line 26.
    The relevance statement picks up the IDs for OS, CPU and RAM. You can just change the properties to the other names as desired.

    Let me know if you have issues or need help.

    Lee Wei
  • abinash91
    abinash91
    1 Post
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-08-27T13:12:04Z  in response to Lee Wei
    Hi Lee,

    how can we add patch size in detail tab of Fixlet compliance by content version1.1 ?

    Abinash Kumar
  • Lee Wei
    Lee Wei
    598 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2010-08-27T17:08:55Z  in response to Lee Wei
    Hi Abinash,

    I will respond to the question over in the thread for the Fixlet Compliance by Content report.
    http://forum.bigfix.com/viewtopic.php?pid=23681#p23681

    Lee Wei
  • mistervernon91
    mistervernon91
    1 Post
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2011-03-10T13:34:16Z  in response to Lee Wei
    I'm somewhat of a noob here ...
    Can anyone tell me, "from an operational standpoint, what are the most fundamental differences between using the BES Console versus using BES Web Reports to manage and maintain the BigFix (SCM) solution?

    Thanks!
  • Lee Wei
    Lee Wei
    598 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2011-03-10T16:21:37Z  in response to Lee Wei
    mistervernon
    Can anyone tell me, "from an operational standpoint, what are the most fundamental differences between using the BES Console versus using BES Web Reports to manage and maintain the BigFix (SCM) solution?
    Since Web Reports is read-only, you use that for reporting and general access, but the Console for actual management such as creating the control parameters, and enforcing the policies.
    This usually falls in place when we don't want casual and business BigFix users to have to deal with a Win32 based Console program. The HTML based Web Reports will work better.

    Lee Wei
  • Nitin_Gupta91
    Nitin_Gupta91
    2 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2011-04-08T13:43:02Z  in response to Lee Wei
    Hi,

    Can someone confirm if the Asset Management Dashboard works with BF v8.x.

    The report looks great and want the same to be installed on my web reporting tool for getting data related to all assets.

    Thanks,
  • Lee Wei
    Lee Wei
    598 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2011-04-08T15:53:45Z  in response to Lee Wei
    Nitin,

    Yes the report works with version 8.x.
    I know of one problem where the screen is cut off at the top when configuring the properties.
    What problems are you having? Let us know so that we can help.

    Lee Wei
  • Nitin_Gupta91
    Nitin_Gupta91
    2 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2011-04-08T20:11:37Z  in response to Lee Wei
    Thanks Lee, will surely ask if i got any issues.
  • SystemAdmin
    SystemAdmin
    890 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2011-04-08T20:48:27Z  in response to Lee Wei
    I just imported this dashboard yesterday and I am having issue with it. I think the issue might be more with the Web Reports setup than with the dashboard itself. We upgraded to 8.1 about a month ago.

    recently we moved the Web Reports to a new server to keep some of the workload off the main TEM server. All of the normal Web Reports functionality is working properly. However when I try to access this dashboard I receive a message "Loading Computer Group Filter". If I try to access it from the TEM server I am getting a message that is headed View Web Reports: The following TEM Web Reports servers are aggregating your current.... I cannot read the rest of the line because it is covered by the table that shows the old and the new Server URL's for Web Reports. No matter which one I select I do not get any results

    I verified that the old Web Reports server on the TEM server is stopped.

    Any ideas/thoughts?
  • Lee Wei
    Lee Wei
    598 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2011-04-09T00:30:41Z  in response to Lee Wei
    tsikma,

    This means that the JavaScript library is not extracted into the correct directory.
    This post has the notes on what to test for.
    http://forum.bigfix.com/viewtopic.php?pid=17553#p17553

    Lee Wei
  • jspanitz
    jspanitz
    4 Posts
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2013-05-15T20:03:14Z  in response to Lee Wei

    Any chance these will be updated to work in TEM 9.x

    • Lee Wei
      Lee Wei
      598 Posts
      ACCEPTED ANSWER

      Re: Report Available: Asset Dashboard

      ‏2013-05-17T01:41:56Z  in response to jspanitz

      Hi John,

      The report works in 9.x, and I just tested on 9.0.586.

      What errors are you getting?

      Lee Wei

       

      Updated on 2013-05-22T03:05:59Z at 2013-05-22T03:05:59Z by Lee Wei
      • jspanitz
        jspanitz
        4 Posts
        ACCEPTED ANSWER

        Re: Report Available: Asset Dashboard

        ‏2013-05-21T15:39:11Z  in response to Lee Wei

        We were hoping the Export to Excel would be enhanced to work with IE.

        • Lee Wei
          Lee Wei
          598 Posts
          ACCEPTED ANSWER

          Re: Report Available: Asset Dashboard

          ‏2013-05-22T03:14:35Z  in response to jspanitz

          Sorry that the technique that I use to export data on the client-side does not work on IE.

          Server-side exports to PDF, Excel is much easier, but this application is client-side only, hence the limitations.

           

  • JFannon
    JFannon
    1 Post
    ACCEPTED ANSWER

    Re: Report Available: Asset Dashboard

    ‏2013-06-26T15:35:15Z  in response to Lee Wei

    Hello Lee,

     

    your reports are great. They provide exactly the information my company is looking for, and the presentation looks really good too.

    I  am having a problem with the Asset Management report though :(

    We've created about 260 automatic groups based on subnet to represent our geographic sites in TEM. When I open the asset management report it shows no data on some of those groups. It works perfectly on others. Same problem in IE/Firefox, same problem with other WebReport users. It seems to always be the same groups, although we've not exhaustively tested all 260 groups!!!

    BF 9.0.649, BES server on W2k8 r2, db is SQL 2008 full.

     

    Thanks again for your great work

     

     

    • Lee Wei 2
      Lee Wei 2
      10 Posts
      ACCEPTED ANSWER

      Re: Report Available: Asset Dashboard

      ‏2013-06-26T18:14:30Z  in response to JFannon

      Hi John,

      Very sorry to hear of the problem, and I will try to help to figure this out.

      This is unlikely to be a problem with BES version or with Web Reports. Probably an error on my side.

      I am using only Computer Group names to do the filtering, and not the ID. So it is possible that the query is not right.

      Can you please run the following Session Relevance to help determine if a group with problems will return the members?

      number of (members whose (exists name of it) of bes computer groups whose (name of it = "Name_Of_a_Group_With_Problem"))

      If you are comfortable with looking at the source code, you can also do the following.

      The file with the code is located at: C:\Program Files\BigFix Enterprise\BES Server\BESReportsServer\wwwroot\ext-3.2.0\asset_management.js.

      Go to around line 809 where it starts with "var relevaneStatementPie1", then add a line after that to print out the Session Relevance generated.

      alert(relevanceStatementPie1);

      When you run the report again, an alert dialog will pop up with the statement, which we can run to see if the correct data is being returned. If the dialog does not pop-up, please clear the browser cache to ensure that the correct JavaScript file is being read and executed.

      Mine has something like the following

      (it as string) of number of values of results from (elements of unions of ((sets of members whose (exists name of it) of bes computer groups whose (name of it = "Clifden Site")))) of (bes property whose (item 0 of id of it =2299642399 and item 1 of id of it =5 and item 2 of id of it =1));(multiplicity of it as string & "|" & it) of unique values of values of results from (elements of unions of ((sets of members whose (exists name of it) of bes computer groups whose (name of it = "Clifden Site")))) of (bes property whose (item 0 of id of it =2299642399 and item 1 of id of it =5 and item 2 of id of it =1))

      Hopefully, this will help us narrow down where the error is coming from.

      Lee Wei

      Updated on 2013-06-26T18:16:09Z at 2013-06-26T18:16:09Z by Lee Wei 2