Topic
19 replies Latest Post - ‏2014-03-24T03:52:14Z by Novikov_Alexander
Xenpangu
Xenpangu
3 Posts
ACCEPTED ANSWER

Pinned topic Firmware 7.01 for TotalStorage DS300 DS400

‏2011-12-06T15:45:16Z |
Hi to all,

I am using a IBM TotalStorage DS400 which runs a very old firmware 4.15 at the moment. I would like to upgrade to the latest firmware 7.01. Unfortunately it's not available for download at IBMs support site. The info says: Contact technical support. I tried to register with the system model name and my serial but it was not able. I get an error that this product cannot be serviced. I'm confused! Is this firmware 7.01 somehow possible to download? If so, please tell me how.

I would like to tell the DS400 not to use loop mode, but Point-To-Point mode. I cannot find a command to do that. The only stuff I found is per Telnet command "initiator mode". I can use either "initiator mode lunmapped" or "initiator mode auto". Actually the system is in lunmapped mode. When I execute the command "initiator mode auto" I get the error message

Adaptec DS400 Command Line Interface
Adaptec (c)2003-2004
IBM TotalStorage DS Series 4.15
Type '?' for help
The TAB key will list the valid parameters

Operator level password: ********
ds400> administrator
Administrator level password: *******
ds400# initiator mode auto
Changing the mode will destroy all storage. Proceed? No: yes

***ERRORS***
Failed setting configuration mode
Sorry, can't switch modes just yet. Forced to LUN Mapped.

ds400#

Why that? How else can I tell the system to switch to Point-To-Point Mode ?? Any help is appreciated.

PS: All logical volumes and arrays are intentionally destroyed on the SAN. I use 12 discs which at the moment are not in use because I haven't defined any array. Also I removed all initators and LUN mapping before trying this command. Here you see a screenshot:

ds400# array info
--- No arrays ---

ds400# logical info

No logical drives

ds400# initiator info
---- Initiators ---------------------------------------------------------------------------------
-----No Initiators-----

ds400# system info
---- System information -------------------------------------------------------------------------
Date: Tue Dec 6 16:46:37 2011 GMT+1
Uptime: 2 Hours and 9 Minutes
CPU Loads: current 18.1% peak 18.1%

System status: Normal

Hardware Serial number: SN 11S13N1806ZJ1000001127
BIOS version: 04.08.12
System version and date: 2.4.21-timesys-4.1.193 Oct 25 15:55:05 Local time zone must be set

Current firmware image: [1] IBM TotalStorage DS Series
Firmware version: 4.15
Firmware build date: 25/10/2004


ds400#
Thanks a lot to any help in advance.
Updated on 2011-12-08T17:31:04Z at 2011-12-08T17:31:04Z by Novikov_Alexander