Topic
  • 1 reply
  • Latest Post - ‏2011-12-06T05:05:52Z by Shawn_Jiang
SystemAdmin
SystemAdmin
2233 Posts

Pinned topic Tapestry 5 does not startup on WASCE v3.x even it works fine on WASCE v2.x

‏2011-11-22T15:52:09Z |
I am running a "Hello World" Tapestry 5.2.6 Web application and it initiates just fine on Tomcat v6.x, Tomcat v7.x and WAS-CE v2.1.1.5.

Now I am moving out to WAS-CE v3.0 although for some reason I am not longer able to run same "Hello World" application.

At the time there are no hints about why it may be the root cause for this issue neither a fix to apply.

Would somebody know about a configuration change from WAS-CE/Geronimo v2.x to WAS-CE Geronimo 3.x that may be causing this?
*************************************************************
This is start-up time "server.log" for WAS-CE v2.1.1.5:

Lines #4 and #5 states that "Index" has been resolved as
available Tapestry page
*************************************************************

2011-11-22 09:05:19,200 INFO RegistryBuilder Adding module definition for class org.apache.tapestry5.ioc.services.TapestryIOCModule
2011-11-22 09:05:19,535 INFO RegistryBuilder Adding module definition for class org.apache.tapestry5.services.TapestryModule
2011-11-22 09:05:20,010 INFO RegistryBuilder Adding module definition for class org.apache.tapestry5.internal.services.InternalModule
2011-11-22 09:05:21,162 INFO ComponentClassResolver Available pages:
(blank): com.inbitame.t5.demo.pages.Index
ExceptionReport: org.apache.tapestry5.corelib.pages.ExceptionReport
Index: com.inbitame.t5.demo.pages.Index
PropertyDisplayBlocks: org.apache.tapestry5.corelib.pages.PropertyDisplayBlocks
PropertyEditBlocks: org.apache.tapestry5.corelib.pages.PropertyEditBlocks
ServiceStatus: org.apache.tapestry5.corelib.pages.ServiceStatus

2011-11-22 09:05:21,163 INFO ComponentClassResolver Available components:
ActionLink: org.apache.tapestry5.corelib.components.ActionLink
AddRowLink: org.apache.tapestry5.corelib.components.AddRowLink
AjaxFormLoop: org.apache.tapestry5.corelib.components.AjaxFormLoop
Any: org.apache.tapestry5.corelib.components.Any

..etc...etc...etc....

2011-11-22 09:05:21,177 INFO TapestryFilter Startup status:

Application 'app' (Tapestry version 5.2.6).

Startup time: 706 ms to build IoC Registry, 1,722 ms overall.

Startup services status:
ActionRenderResponseGenerator: DEFINED
AjaxComponentEventRequestHandler: DEFINED
AjaxComponentEventResultProcessor: DEFINED

..etc...etc...etc....

*************************************************************
This is start-up time "server.log" for WAS-CE v3.0:

The available Tapestry pages section is completing missing
after line #3 and it skips directly to the "Application 'app'
(Tapestry version 5.2.6)" message
*************************************************************

2011-11-22 09:33:07,906 INFO RegistryBuilder Adding module definition for class org.apache.tapestry5.ioc.services.TapestryIOCModule
2011-11-22 09:33:07,944 INFO RegistryBuilder Adding module definition for class org.apache.tapestry5.services.TapestryModule
2011-11-22 09:33:07,999 INFO RegistryBuilder Adding module definition for class org.apache.tapestry5.internal.services.InternalModule
2011-11-22 09:33:08,230 INFO TapestryFilter Startup status:

Application 'app' (Tapestry version 5.2.6).

Startup time: 79 ms to build IoC Registry, 288 ms overall.

Startup services status:
ActionRenderResponseGenerator: DEFINED
AjaxComponentEventRequestHandler: DEFINED
AjaxComponentEventResultProcessor: DEFINED
AjaxFormUpdateController: DEFINED
AjaxPartialResponseRenderer: DEFINED
Alias: REAL

..etc...etc...etc....
Updated on 2011-12-06T05:05:52Z at 2011-12-06T05:05:52Z by Shawn_Jiang
  • Shawn_Jiang
    Shawn_Jiang
    154 Posts

    Re: Tapestry 5 does not startup on WASCE v3.x even it works fine on WASCE v2.x

    ‏2011-12-06T05:05:52Z  
    There are classloader changes from WASCE 2.x to CE 3.0.0.0, I can't tell what's the root cause from your log. Can you share us your hello-world application so that we can recreate and diagnose it locally ?