Topic
19 replies Latest Post - ‏2015-01-28T05:07:35Z by tsullyman
Berniebgbb
Berniebgbb
34 Posts
ACCEPTED ANSWER

Pinned topic Can't get E-mail alerts from iMM

‏2011-05-08T23:36:56Z |
Hi All,

I have 4 x IBM x3650 M3's that I have configured the iMM functionality in these machines but can not for the life of me get the E-mail alerts working!!
Despite trying all different settings SMTP by IP, SMTP by DNS.. I have set the Contact and Location information (which I believe is used partly to form the E-mail address...) and entered in the SMTP IP (and tried DNS).... We check out mail server and see nothing come through in the SMPTP logs, so it seems that nothing is leaving the iMM card??

Not sure what else to check, have logged a call with IBM however can anyone provide and info or "Got Ya's" on this subject? All 4 machines not working with respect to E-mail so it is something I am doing I presume...... All other iMM functionality is working..

iMM Firmware - YUOO91K
UEFI Firmware - D6E150C
DSA Firmware - DSYT85T

If you need more info let me know.

regards

Bernie
Updated on 2012-06-30T19:41:12Z at 2012-06-30T19:41:12Z by massimiliano.rizzi
  • Novikov_Alexander
    Novikov_Alexander
    6863 Posts
    ACCEPTED ANSWER

    Re: Can't get E-mail alerts from iMM

    ‏2011-05-09T10:04:06Z  in response to Berniebgbb
    Dear Bernie,

    could you provide DSA log.

    Regards,
    Alexander Novikov
    Russia, Moscow
    • Berniebgbb
      Berniebgbb
      34 Posts
      ACCEPTED ANSWER

      Re: Can't get E-mail alerts from iMM

      ‏2011-11-11T18:36:48Z  in response to Novikov_Alexander
      DSA Logs as requested.

      NOTE: We had set the card back to default to try and rule out some of the settings, so you may find only the contact details and IP for SMTP setup....
      Updated on 2011-11-11T18:36:48Z at 2011-11-11T18:36:48Z by Berniebgbb
      • Novikov_Alexander
        Novikov_Alexander
        6863 Posts
        ACCEPTED ANSWER

        Re: Can't get E-mail alerts from iMM

        ‏2011-05-10T07:03:11Z  in response to Berniebgbb
        Hi Bernie,

        check the next:

        • can you ping iMM IP from DNS server?
        • can you ping iMM IP from SMTP server?
        • do you see DNS requests from iMM on DNS server logs?
        • disable iMM SSH and try SMTP tests again.

        Regards,
        Alexander Novikov
        Russia, Moscow
        • Berniebgbb
          Berniebgbb
          34 Posts
          ACCEPTED ANSWER

          Re: Can't get E-mail alerts from iMM

          ‏2011-05-10T07:28:44Z  in response to Novikov_Alexander
          Hi All,

          Thanks for you comments, I have spent many hours on this..... very annoying. (I hope it is not something simple I am missing)...

          Have tried the following........today

          1. Reset Bios to defaults
          2. Reset IMM to defaults
          3. Confirmed latest firmware/bios
          4. Setup Dummy SMTP server and connected to iMM interface via crossover cable (confirmed IP connectivity)
          5. Configured iMM with basic contact details, SMTP Dummy server IP (via crossover)
          6. Set alert configuration details
          7. Tested SMTP (Generate test alert)... no response to DUmmy SMTP server....Nothing at all.

          Regarding your requests,

          1. "making sure that the location field contains the FQDN domain name of the sender address." --> Tried this already, did not work.
          2. Disabled SSH in iMM --> Still not working.
          3. DNS, we have disabled all DNS configuration parameters and are working off pure IP.

          Thanks for all of your help, it is appreciated.

          Keep the help coming, I will let you know if I hear anything from IBM.

          Bernard
          • BrettShortland
            BrettShortland
            2 Posts
            ACCEPTED ANSWER

            Re: Can't get E-mail alerts from iMM

            ‏2011-05-11T06:25:09Z  in response to Berniebgbb
            Hi Bernie,

            It's not us, it's the firmware...

            IBM have just advised that they have confirmed a fault with the v1.25 IMM firmware (YUOO91E)
            I am waiting for downlevel firmware to be emailed through to me along with downgrade instructions.

            Cheers,
            Brett
            • Berniebgbb
              Berniebgbb
              34 Posts
              ACCEPTED ANSWER

              Re: Can't get E-mail alerts from iMM

              ‏2011-05-11T10:26:16Z  in response to BrettShortland
              Got the same news today, see below
              XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
              Its seems there is an issue with the Latest IMM f/w 1.25
              & is believed to be causing the issue with the mail alerts via the IMM.

              IBM is currently investigating this & working on a new IMM update to
              correct this issue. In the meantime there is a workaround
              which envolves back leveling the IMM firmware to level YU0073M.

              Workaround:

              1. Back level IMM f/w to YU0073M.

              2. Restore the default settings & save

              3. Reflash IMM firmware to latest level YU0091K

              The SMTP alerts symptom will be back to normal.
              XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

              Once I confirm this workaround I will let you know.

              Bernie
              • Berniebgbb
                Berniebgbb
                34 Posts
                ACCEPTED ANSWER

                Re: Can't get E-mail alerts from iMM

                ‏2011-05-16T07:00:25Z  in response to Berniebgbb
                Tried the instructions received by IBM....downgrade firmware and then upgrade again....Still same issue!

                • ISSUE NOT RESOLVED **

                Has anyone else tried these steps and got their E-mail alerts working?

                regards

                BT>
                • Berniebgbb
                  Berniebgbb
                  34 Posts
                  ACCEPTED ANSWER

                  Re: Can't get E-mail alerts from iMM

                  ‏2011-05-30T01:41:47Z  in response to Berniebgbb
                  • BUMP --

                  Is anyone else still have problems with this "Fix" from IBM?

                  Or if you have had success please let me know if the procedure from IBM worked for you.

                  Thanks

                  Bernie
                  • SystemAdmin
                    SystemAdmin
                    9111 Posts
                    ACCEPTED ANSWER

                    Re: Can't get E-mail alerts from iMM

                    ‏2011-08-09T21:55:43Z  in response to Berniebgbb
                    The only thing I have found that works is to use version 1.22 yuoo84c.

                    You can find it in the ibm_utl_uxsp_d6sp05a-150_windows_32-64 update xpress system pack.

                    Be nice if they every fix this. Version 1.28 does not work for email alerts so if your asked to go to it, well it's wasted time..

                    Good Luck...
                    • Novikov_Alexander
                      Novikov_Alexander
                      6863 Posts
                      ACCEPTED ANSWER

                      Re: Can't get E-mail alerts from iMM

                      ‏2011-08-10T05:18:28Z  in response to SystemAdmin
                      Kevin, Bernie, Brett, colleagues,

                      there is fresh doc about this issue:

                      iMM level YU0091K SMTP Alert generated with System - IBM System x
                      https://www-947.ibm.com/support/entry/myportal/docdisplay?lndocid=MIGR-5088340&brandind=5000008&myns=x008&mync=E

                      Best regards,
                      Alexander Novikov
                      Russia, Moscow
                      • SystemAdmin
                        SystemAdmin
                        9111 Posts
                        ACCEPTED ANSWER

                        Re: Can't get E-mail alerts from iMM

                        ‏2011-08-11T21:05:43Z  in response to Novikov_Alexander
                        Hi Novikov,

                        I just found that article this morning and was going to update this post.

                        You beta me to it.
                        Thanks....
  • BrettShortland
    BrettShortland
    2 Posts
    ACCEPTED ANSWER

    Re: Can't get E-mail alerts from iMM

    ‏2011-05-10T07:05:37Z  in response to Berniebgbb
    Hi Bernie,

    I'm not wanting to be a "me too", but hopefully I can add some troubleshooting results to the mix.

    I too have spent a number of hours attempting to find a solution to this. With previous versions of the firmware I have
    been able to get it to work by making sure that the location field contains the FQDN domain name of the sender address. It does not work at all with this YUOO91K firmware. The server I am currently battling with also has the D6E150C UEFI firmware

    I have tried using local and remote DNS names as the SMTP server. I have confirmed via packet sniffing our gateway that there is no traffic hitting it from the IMM. I can see DNS packets when the IMM starts up so i know tht that part is working.

    Various configurations of hostname, and location and domain name have been tried without success. I have even ensured that the hostname and recipient address does not have any non-alpha characters.(apart from dots)

    There seems to be no way to downgrade the firmware as I have this model sending SMTP alerts OK with YUOO84C firmware.

    Alerting is the primary reason we have these IMM cards so failure is not an option.

    Cheers,
    Brett
  • massimiliano.rizzi
    massimiliano.rizzi
    4 Posts
    ACCEPTED ANSWER

    Re: Can't get E-mail alerts from iMM

    ‏2012-06-30T19:41:12Z  in response to Berniebgbb
    Hi Bernie,

    could you please confirm where exactly sender/reply address and sender email domain must be entered within the IMM so that e-mail notifications and alerts can reach the intended recipients as expected instead of being dropped when they hit external email servers as the sender/reply address is not valid or the sender domain itself is not a valid email domain ?

    Any help/information based on your past experience will be greatly appreciated.

    Thanks and Regards,

    Massimiliano
  • Mike Krotov
    Mike Krotov
    2 Posts
    ACCEPTED ANSWER

    Re: Can't get E-mail alerts from iMM

    ‏2013-09-16T12:29:20Z  in response to Berniebgbb

    I have the same issue!

    I put my mail server host name into SMTP server field and enable relay option to IMM card ip.

    What I see in mailserver report: The message is relayed with sender name alertmgr@WHATiPUTinSMTPserverFIELD... doesnt matter what is it - ip address or host name, but the next relay server (our provider) send it back with error - BAD SENDER ADDRESS SYNTAX. 

    As one of solving - replace the needed field on allowed, but cant manage it.... 

    so what to do?

     

    Cheers, Mike!

    • BNQS_Mark_Henkel
      BNQS_Mark_Henkel
      1 Post
      ACCEPTED ANSWER

      Re: Can't get E-mail alerts from iMM

      ‏2014-02-12T14:33:09Z  in response to Mike Krotov

      Hallo,

      is there an solution for the problem? I also put the ip or the fqdn of my mail-server into SMTP server field in IMM. Now our smarthost (external provider) reject the mails because of bad sender address (alertmgr@IP or FQDN of Mail-Server)
      Where can i edit the sender for outgoing mails? The value for the mail-server can´t be the value for the sender domain in same time!!!

      Please help me.

       

      Best regards
      Mark

      Updated on 2014-02-12T14:33:27Z at 2014-02-12T14:33:27Z by BNQS_Mark_Henkel
      • CHEN Zi-zhao
        CHEN Zi-zhao
        1 Post
        ACCEPTED ANSWER

        Re: Can't get E-mail alerts from iMM

        ‏2014-03-14T05:47:29Z  in response to BNQS_Mark_Henkel

        modify it to hostname via the DDNS tab

        • tsullyman
          tsullyman
          1 Post
          ACCEPTED ANSWER

          Re: Can't get E-mail alerts from iMM

          ‏2015-01-28T05:07:35Z  in response to CHEN Zi-zhao

          This fixed it for me instantly. You will find the IMM generates the alert it is just being rejected at the end route mail server due to incorrect reverse DNS or being dropped by senderID filtering etc.

          Make sure your domain in DDNS tab is correct. Stupid/Dumb design by IBM because who doesn't put their IMM addresses on a different VLAN? It can't route to the DNS servers properly over different VLAN by default hence it cant lookup the domain name to use for sending address.

  • MilosUrosevic
    MilosUrosevic
    1 Post
    ACCEPTED ANSWER

    Re: Can't get E-mail alerts from iMM

    ‏2014-10-29T13:07:48Z  in response to Berniebgbb

    Hi,

    it seems that I have the same problem. I have five x3550 M4 servers with IMM II installed. None of them sends an email notification to the recipient, although I have tried a number of options how to configure the IMM network settings and recipient settings.

    iMM Firmware - version 1.97, build 1AOO36R, 
    UEFI Firmware - version 1.30, build D7E124AUS
    DSA Firmware - version 9.28,  build DSYTAA4

    Are there any updates about this issue?

    I'm more than happy to provide any additional information if needed.

    Thanks in advance,

    Milos.

     

  • DE2014
    DE2014
    3 Posts
    ACCEPTED ANSWER

    Re: Can't get E-mail alerts from iMM

    ‏2014-11-12T11:45:32Z  in response to Berniebgbb

    I have the same problem too. Installed the newest iMM Firmware.

    The email Sender adress is name-Serialnumber@ipadress_Exchange_Server f.E. hyperv2-ab59cd@192.168.2.113

    When I change the server-ip to hostname, then iMM gets no connection to mailserver. (ping hostname is giving the correct ip adress back)

    IBM told me, that server is out of warrenty anda support call costs money. Great answer!!! (i will help them to correct their technical issues and I should pay for it. Normally they have to pay us, for helping them)

    Does anybody gets this feature working with a System x server?

     

    System x3400 M3 7379KFG

     

    IMM YUOOG6C-1.44 06/10/2014
    UEFI Y4E150C-1.08 02/08/2011
    DSA DSYT83D-3.33 01/07/2011

     

     

    Updated on 2014-11-12T12:26:21Z at 2014-11-12T12:26:21Z by DE2014