Topic
  • 12 replies
  • Latest Post - ‏2012-11-23T18:10:12Z by oliverqg
abalasu1
abalasu1
10 Posts

Pinned topic Flume fails to start in biginsights redhat vm

‏2011-11-11T10:10:00Z |
flume failed <com.ibm.xap.mgmt.DeployException: failed to check flume 'master' process on some nodes -- localhost=-1 (failed to start flume service on node localhost)>com.ibm.xap.mgmt.DeployException: failed to check flume 'master' process on some nodes -- localhost=-1 (failed to start flume service on node localhost)
at com.ibm.xap.mgmt.flume.FlumeDeployer.startService(FlumeDeployer.java:1346)
at com.ibm.xap.mgmt.DeployManager$StartThread.work(DeployManager.java:1566)
at com.ibm.xap.mgmt.DeployManager$WorkerThread.run(DeployManager.java:1462)

ERROR] DeployManager - Start; SUCCEEDED components: [; FAILED components: flume

Flume fails to start with this error on biginsights redhat vm. I redeployed oozie.ar with the extjs files, but that doesnt solve the problem with flume.
Updated on 2012-11-23T18:10:12Z at 2012-11-23T18:10:12Z by oliverqg
  • EmiliePOCCIOLI
    EmiliePOCCIOLI
    12 Posts

    Re: Flume fails to start in biginsights redhat vm

    ‏2012-02-06T13:14:23Z  
    Hey,

    I have the same problem. Have you solved it?

    Thank you
  • SystemAdmin
    SystemAdmin
    603 Posts

    Re: Flume fails to start in biginsights redhat vm

    ‏2012-02-08T14:53:55Z  
    Hey,

    I have the same problem. Have you solved it?

    Thank you
    Hi Emilie,

    For starters, let us check few things:

    --What version/edition of BigInsights do you have installed?
    --What are the steps for getting the problem?
    --Does /var/ibm/biginsights/flume/pids/flumemaster.pid exist? If yes, what is the content?
    --What is the error information in /var/ibm/biginsights/flume/logs/flumemaster.out?

    Thanks,
    Zach
  • EmiliePOCCIOLI
    EmiliePOCCIOLI
    12 Posts

    Re: Flume fails to start in biginsights redhat vm

    ‏2012-02-08T15:13:09Z  
    Hi Zach,

    Thanks for your reply.
    After troubleshooting a couple of errors, I decided to install the latest version of BigInsights 1.3 (I was using the 1.2 version)

    Regarding my flume problem, I checked the logs and I had a message saying that my pid was already used (even after killing the process I had the same error)

    So I gave up, cleaned up my VM and everything went well with this new version.
    Anyway, thanks for your help!
  • EmiliePOCCIOLI
    EmiliePOCCIOLI
    12 Posts

    Re: Flume fails to start in biginsights redhat vm

    ‏2012-02-08T15:13:15Z  
    Hi Zach,

    Thanks for your reply.
    After troubleshooting a couple of errors, I decided to install the latest version of BigInsights 1.3 (I was using the 1.2 version)

    Regarding my flume problem, I checked the logs and I had a message saying that my pid was already used (even after killing the process I had the same error)

    So I gave up, cleaned up my VM and everything went well with this new version.
    Anyway, thanks for your help!
  • openeis
    openeis
    1 Post

    Re: Flume fails to start in biginsights redhat vm

    ‏2012-02-16T06:20:12Z  
    Hi Emilie,

    For starters, let us check few things:

    --What version/edition of BigInsights do you have installed?
    --What are the steps for getting the problem?
    --Does /var/ibm/biginsights/flume/pids/flumemaster.pid exist? If yes, what is the content?
    --What is the error information in /var/ibm/biginsights/flume/logs/flumemaster.out?

    Thanks,
    Zach
    env:IBM InfoSphere BigInsights Basic Edition 1.3 on oracle linux(redhat) 6.1 vm

    status: Partially started .can't stop and start .
  • KhandekarAkram
    KhandekarAkram
    14 Posts

    Re: Flume fails to start in biginsights redhat vm

    ‏2012-03-29T12:50:10Z  
    Hi Emilie,

    For starters, let us check few things:

    --What version/edition of BigInsights do you have installed?
    --What are the steps for getting the problem?
    --Does /var/ibm/biginsights/flume/pids/flumemaster.pid exist? If yes, what is the content?
    --What is the error information in /var/ibm/biginsights/flume/logs/flumemaster.out?

    Thanks,
    Zach
    Hi Zach,

    I am facing the same problem. Previously flume was working fine. But it is giving error.
    Here the details for your help:

    BigInsights version: EnterPrise version 1.3
    OS: 64 bit RHEL 5.5 vmware
    Error steps: not able to start(./start.sh flume).It is giving the error like:
    ERROR DeployManager - flume failed <com.ibm.xap.mgmt.DeployException: failed to check flume 'master' process on some nodes -- localhost.localdomain=-1 (failed to start flume service on node localhost.localdomain)>com.ibm.xap.mgmt.DeployException: failed to check flume 'master' process on some nodes -- localhost.localdomain=-1 (failed to start flume service on node localhost.localdomain)
    at com.ibm.xap.mgmt.flume.FlumeDeployer.startService(FlumeDeployer.java:1374)
    at com.ibm.xap.mgmt.DeployManager$StartThread.work(DeployManager.java:2071)
    at com.ibm.xap.mgmt.DeployManager$WorkerThread.run(DeployManager.java:1935)

    ERROR] DeployManager - Start; SUCCEEDED components: [; FAILED components: flume

    Web Console: In "cluster status" it is showing that flume node is running but flume-master status is "Connection Refused".

    flumemaster.pid exist: it exists and have the text 9598

    error information in /var/ibm/biginsights/flume/logs/flumemaster.out:
    Master already running, pid=9598
    Thanks in advance.

    Warm Regards,
    Akram.
  • SystemAdmin
    SystemAdmin
    603 Posts

    Re: Flume fails to start in biginsights redhat vm

    ‏2012-03-30T18:04:33Z  
    Hi Zach,

    I am facing the same problem. Previously flume was working fine. But it is giving error.
    Here the details for your help:

    BigInsights version: EnterPrise version 1.3
    OS: 64 bit RHEL 5.5 vmware
    Error steps: not able to start(./start.sh flume).It is giving the error like:
    ERROR DeployManager - flume failed <com.ibm.xap.mgmt.DeployException: failed to check flume 'master' process on some nodes -- localhost.localdomain=-1 (failed to start flume service on node localhost.localdomain)>com.ibm.xap.mgmt.DeployException: failed to check flume 'master' process on some nodes -- localhost.localdomain=-1 (failed to start flume service on node localhost.localdomain)
    at com.ibm.xap.mgmt.flume.FlumeDeployer.startService(FlumeDeployer.java:1374)
    at com.ibm.xap.mgmt.DeployManager$StartThread.work(DeployManager.java:2071)
    at com.ibm.xap.mgmt.DeployManager$WorkerThread.run(DeployManager.java:1935)

    ERROR] DeployManager - Start; SUCCEEDED components: [; FAILED components: flume

    Web Console: In "cluster status" it is showing that flume node is running but flume-master status is "Connection Refused".

    flumemaster.pid exist: it exists and have the text 9598

    error information in /var/ibm/biginsights/flume/logs/flumemaster.out:
    Master already running, pid=9598
    Thanks in advance.

    Warm Regards,
    Akram.
    Hi Akram,

    I am checking for you. Hope to have something soon.

    Thanks for your patience.

    --Zach
  • SystemAdmin
    SystemAdmin
    603 Posts

    Re: Flume fails to start in biginsights redhat vm

    ‏2012-04-06T15:58:46Z  
    Hi Zach,

    I am facing the same problem. Previously flume was working fine. But it is giving error.
    Here the details for your help:

    BigInsights version: EnterPrise version 1.3
    OS: 64 bit RHEL 5.5 vmware
    Error steps: not able to start(./start.sh flume).It is giving the error like:
    ERROR DeployManager - flume failed <com.ibm.xap.mgmt.DeployException: failed to check flume 'master' process on some nodes -- localhost.localdomain=-1 (failed to start flume service on node localhost.localdomain)>com.ibm.xap.mgmt.DeployException: failed to check flume 'master' process on some nodes -- localhost.localdomain=-1 (failed to start flume service on node localhost.localdomain)
    at com.ibm.xap.mgmt.flume.FlumeDeployer.startService(FlumeDeployer.java:1374)
    at com.ibm.xap.mgmt.DeployManager$StartThread.work(DeployManager.java:2071)
    at com.ibm.xap.mgmt.DeployManager$WorkerThread.run(DeployManager.java:1935)

    ERROR] DeployManager - Start; SUCCEEDED components: [; FAILED components: flume

    Web Console: In "cluster status" it is showing that flume node is running but flume-master status is "Connection Refused".

    flumemaster.pid exist: it exists and have the text 9598

    error information in /var/ibm/biginsights/flume/logs/flumemaster.out:
    Master already running, pid=9598
    Thanks in advance.

    Warm Regards,
    Akram.
    Hi Akram,

    Please try the following suggestion:

    "
    • Please make sure the flume master port is open: netstat nltp | grep "master port". "master port" can be found in flume-conf.xml
    • Please restart flume by:
    stop.sh flume
    start.sh flume

    If the problem still exists, please provide the log in /var/ibm/biginsights/flume/log."

    Thanks,
    --Zach
  • HarishMH
    HarishMH
    9 Posts

    Re: Flume fails to start in biginsights redhat vm

    ‏2012-04-20T16:04:30Z  
    Hi Zach,

    I am facing the same problem. Previously flume was working fine. But it is giving error.
    Here the details for your help:

    BigInsights version: EnterPrise version 1.3
    OS: 64 bit RHEL 5.5 vmware
    Error steps: not able to start(./start.sh flume).It is giving the error like:
    ERROR DeployManager - flume failed <com.ibm.xap.mgmt.DeployException: failed to check flume 'master' process on some nodes -- localhost.localdomain=-1 (failed to start flume service on node localhost.localdomain)>com.ibm.xap.mgmt.DeployException: failed to check flume 'master' process on some nodes -- localhost.localdomain=-1 (failed to start flume service on node localhost.localdomain)
    at com.ibm.xap.mgmt.flume.FlumeDeployer.startService(FlumeDeployer.java:1374)
    at com.ibm.xap.mgmt.DeployManager$StartThread.work(DeployManager.java:2071)
    at com.ibm.xap.mgmt.DeployManager$WorkerThread.run(DeployManager.java:1935)

    ERROR] DeployManager - Start; SUCCEEDED components: [; FAILED components: flume

    Web Console: In "cluster status" it is showing that flume node is running but flume-master status is "Connection Refused".

    flumemaster.pid exist: it exists and have the text 9598

    error information in /var/ibm/biginsights/flume/logs/flumemaster.out:
    Master already running, pid=9598
    Thanks in advance.

    Warm Regards,
    Akram.
    Hi Akram,

    Even I have come across the same error and the reason for this is flume must have stopped without graceful shutdown.

    Solution:

    Remove the pid file(s) from the /var/ibm/biginsights/flume/pids file directory.

    For example:

    rm /var/ibm/biginsights/flume/pids/flumemaster.pid
    rm /var/ibm/biginsights/flume/pids/flumenode-XXXX.pid

    After that, you will be able to start Flume

    Thanks,
    Harish
  • SystemAdmin
    SystemAdmin
    603 Posts

    Re: Flume fails to start in biginsights redhat vm

    ‏2012-04-20T16:09:13Z  
    • HarishMH
    • ‏2012-04-20T16:04:30Z
    Hi Akram,

    Even I have come across the same error and the reason for this is flume must have stopped without graceful shutdown.

    Solution:

    Remove the pid file(s) from the /var/ibm/biginsights/flume/pids file directory.

    For example:

    rm /var/ibm/biginsights/flume/pids/flumemaster.pid
    rm /var/ibm/biginsights/flume/pids/flumenode-XXXX.pid

    After that, you will be able to start Flume

    Thanks,
    Harish
    Thanks, Harish.
    We also have a technote about this:
    http://www-01.ibm.com/support/docview.wss?uid=swg21587785

    -Zach
  • KhandekarAkram
    KhandekarAkram
    14 Posts

    Re: Flume fails to start in biginsights redhat vm

    ‏2012-05-02T12:41:15Z  
    • HarishMH
    • ‏2012-04-20T16:04:30Z
    Hi Akram,

    Even I have come across the same error and the reason for this is flume must have stopped without graceful shutdown.

    Solution:

    Remove the pid file(s) from the /var/ibm/biginsights/flume/pids file directory.

    For example:

    rm /var/ibm/biginsights/flume/pids/flumemaster.pid
    rm /var/ibm/biginsights/flume/pids/flumenode-XXXX.pid

    After that, you will be able to start Flume

    Thanks,
    Harish
    Hi Harish,

    Thanks a lot for the information; now flume is working fine.

    Regards,
    Akram
  • oliverqg
    oliverqg
    1 Post

    Re: Flume fails to start in biginsights redhat vm

    ‏2012-11-23T18:10:12Z  
    • HarishMH
    • ‏2012-04-20T16:04:30Z
    Hi Akram,

    Even I have come across the same error and the reason for this is flume must have stopped without graceful shutdown.

    Solution:

    Remove the pid file(s) from the /var/ibm/biginsights/flume/pids file directory.

    For example:

    rm /var/ibm/biginsights/flume/pids/flumemaster.pid
    rm /var/ibm/biginsights/flume/pids/flumenode-XXXX.pid

    After that, you will be able to start Flume

    Thanks,
    Harish
    I had the same problem, and this solution worked for me perfectly... Thanks