Topic
  • 4 replies
  • Latest Post - ‏2012-08-15T23:32:20Z by SystemAdmin
SystemAdmin
SystemAdmin
1250 Posts

Pinned topic Cast Iron Studio v 6.1.0.2 - The SAP Jar is not found.

‏2011-11-09T09:42:25Z |
Hi,
We recently updated form 6.0 to 6.1.0.2. in 6.0 we had the SAP connector working just fine. For 6.1.0.2 we followed the same installation instructions for the SAP connector (http://publib.boulder.ibm.com/infocenter/wci/v6r0m0/index.jsp?topic=%2Fcom.ibm.websphere.cast_iron.doc%2FDownloading_and_Installing_the_SAP_Jar_File_and_DLLs.html) but it does not work. Is there something else we should try?
Regards.
Updated on 2012-08-15T23:32:20Z at 2012-08-15T23:32:20Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    1250 Posts

    Re: Cast Iron Studio v 6.1.0.2 - The SAP Jar is not found.

    ‏2011-11-09T09:50:38Z  
    Hi,
    SAP connector in release 6.1 was updated to support 3.x version of JCO librairies. Please refer to
    http://publib.boulder.ibm.com/infocenter/wci/v6r1m0/topic/com.ibm.websphere.cast_iron.doc/Downloading_and_Installing_the_SAP_Jar_File_and_DLLs.html
    You may need to upload the 3.X librairies instead of 2.6.1

    Regards,
    Magali
  • PrabhuAppirio
    PrabhuAppirio
    1 Post

    Re: Cast Iron Studio v 6.1.0.2 - The SAP Jar is not found.

    ‏2011-11-17T21:57:04Z  
    Hi,
    SAP connector in release 6.1 was updated to support 3.x version of JCO librairies. Please refer to
    http://publib.boulder.ibm.com/infocenter/wci/v6r1m0/topic/com.ibm.websphere.cast_iron.doc/Downloading_and_Installing_the_SAP_Jar_File_and_DLLs.html
    You may need to upload the 3.X librairies instead of 2.6.1

    Regards,
    Magali
    We upgraded recently and have issues connecting to SAP from the appliance. The Studio works properly.

    http://www.approuter.com/module/sap/: java.lang.NoClassDefFoundError: com.sap.conn.jco.JCoException

    Any thoughts please?
  • JeffYin
    JeffYin
    1 Post

    Re: Cast Iron Studio v 6.1.0.2 - The SAP Jar is not found.

    ‏2012-06-04T06:19:07Z  
    We upgraded recently and have issues connecting to SAP from the appliance. The Studio works properly.

    http://www.approuter.com/module/sap/: java.lang.NoClassDefFoundError: com.sap.conn.jco.JCoException

    Any thoughts please?
    Any update on this thread?
    I met with the same problem, I added libsapjco3.so, sapjco3.jar, sapidoc3.jar but the appliance throws exception like
    java.lang.NoClassDefFoundError: com.sap.conn.jco.JCoException
    Although this class is in sapjco3.jar. The studio, however, works fine.
  • SystemAdmin
    SystemAdmin
    1250 Posts

    Re: Cast Iron Studio v 6.1.0.2 - The SAP Jar is not found.

    ‏2012-08-15T23:32:20Z  
    Hi guys,

    I need some help here, I'm facing an issue in Studio (I haven't tried it yet on the Appliance), after installing the SAP modules (sapjco3.dll, sapjco3.jar and sapidoc3.jar) I restarted manually the Studio but when I try to test the connector it doesn't see the modules, I get the unable to connect required sap jco jars are not found. install version 3.x error. I'm running Studio 6.1.0.9, I think I'm using the right libraries.

    Do I have to do something extra besides loading the modules on the Add Providers wizard?

    Have you faced this issue?

    Regards!