Topic
  • 3 replies
  • Latest Post - ‏2011-12-12T07:38:09Z by SystemAdmin
Dhriti
Dhriti
1 Post

Pinned topic WASCE deployment issue - SPRING-JMS

‏2011-10-31T12:54:20Z |
I tried to deploy a Spring-JMS http:// Spring 2.5.6Application in WASCE Server http://2.1.1.4. And unfortunately it failed while deploying the WAR and the following Error encountered

Error Console :-


org.apache.geronimo.common.DeploymentException: Operation failed: start of monet/monet/1.0/car failed
Unknown start exception
Configuration monet/monet/1.0/car failed to start due to the following reasons:
The service J2EEApplication=null,j2eeType=WebModule,name=monet/monet/1.0/car did not start because ContainerBase.addChild: start: LifecycleException: java.io.IOException: Context did not start for an unknown reason

at org.apache.geronimo.deployment.cli.CommandRedeploy.execute(CommandRedeploy.java:391)
at org.apache.geronimo.deployment.cli.DeployTool.execute(DeployTool.java:171)
at org.apache.geronimo.kernel.util.MainConfigurationBootstrapper.main(MainConfigurationBootstrapper.java:45)
at org.apache.geronimo.cli.AbstractCLI.executeMain(AbstractCLI.java:67)
at org.apache.geronimo.cli.deployer.DeployerCLI.main(DeployerCLI.java:31)

Please suggest me a quick solution to resolve this issue.

Regards,

Dhritiranjan
Updated on 2011-12-12T07:38:09Z at 2011-12-12T07:38:09Z by SystemAdmin
  • Jeff_chi
    Jeff_chi
    62 Posts

    Re: WASCE deployment issue - SPRING-JMS

    ‏2011-11-02T11:22:54Z  
    A little bit more information about your deployment plan and the structure of your application would be more helpful. If possible, please describe the steps you performed during the deployment.
    Thanks.

    Jeff
  • C99E_Dhriti_Ranjan_Das
    1 Post

    Re: WASCE deployment issue - SPRING-JMS

    ‏2011-11-02T14:55:42Z  
    • Jeff_chi
    • ‏2011-11-02T11:22:54Z
    A little bit more information about your deployment plan and the structure of your application would be more helpful. If possible, please describe the steps you performed during the deployment.
    Thanks.

    Jeff
    Hi Jeff,

    I attached my application as a zip. I deployed the war file in linux environment using WASCE 2.1.1.4.
    I am deploying the war file using emt tool using the following command:
    ./emt -ApplicationName wasce-devinstance -Action Deploy -CommandOptions \""deploy /export/wasceapps/wasce-devinstance/wasce/2.1.1.4/war_deployments/springJms.war\"" -Verbose true

    Note: If i removed the
    <listener>
    <listener-class>org.springframework.web.context.ContextLoaderListener</listener-class>
    </listener>
    from web.xml file the war is deployed.

    Thanks,
    Dhriti

    Attachments

  • SystemAdmin
    SystemAdmin
    2233 Posts

    Re: WASCE deployment issue - SPRING-JMS

    ‏2011-12-12T07:38:09Z  
    Hi Jeff,

    I attached my application as a zip. I deployed the war file in linux environment using WASCE 2.1.1.4.
    I am deploying the war file using emt tool using the following command:
    ./emt -ApplicationName wasce-devinstance -Action Deploy -CommandOptions \""deploy /export/wasceapps/wasce-devinstance/wasce/2.1.1.4/war_deployments/springJms.war\"" -Verbose true

    Note: If i removed the
    <listener>
    <listener-class>org.springframework.web.context.ContextLoaderListener</listener-class>
    </listener>
    from web.xml file the war is deployed.

    Thanks,
    Dhriti
    Hi Dhriti,
    I am looking into your issue.
    I download the zip file you provided, and use "jar cvf springJms.war WebContent" to generate a war. Start ce2.1.1.4 server and use admin console to deploy the war package.
    The result is I can deploy and start the war.

    I don't know what the emt tool you used but can you try to use admin console to deploy and start war file?

    BTW, I do not remove
    <listener>
    <listener-class>org.springframework.web.context.ContextLoaderListener</listener-class>
    </listener>
    from web.xml.

    Anyway, can you paste the full war package in this thread?

    Thanks!