Topic
6 replies Latest Post - ‏2011-12-19T08:37:49Z by ChengLuo
spatil@i3-soft.com
spatil@i3-soft.com
3 Posts
ACCEPTED ANSWER

Pinned topic ITCAM for Broker installation on Unix platform

‏2011-10-21T10:02:15Z |
Hi,

I am installing ITCAM for Broker agent on Unix platform, with non root user on /opt/IBM/ITM

getting below WARNING Message, Please let me know if this can ignored or need to created the links manually ?
WARNING - Current user lacks permission to link lil files.
Please have an authorized user manually create the links after the install completes.
Updated on 2011-12-19T08:37:49Z at 2011-12-19T08:37:49Z by ChengLuo
  • alethad
    alethad
    10 Posts
    ACCEPTED ANSWER

    Re: ITCAM for Broker installation on Unix platform

    ‏2011-10-21T16:08:32Z  in response to spatil@i3-soft.com
    You really need to post this on the ITM forum.
    http://www.ibm.com/developerworks/forums/forum.jspa?forumID=796

    Your user id does not have permissions to perform this installation. You need to install this as root user.

    You've got to continue to grow, or you're just like last night's cornbread -- stale & dry Loretta Lynn
    • spatil@i3-soft.com
      spatil@i3-soft.com
      3 Posts
      ACCEPTED ANSWER

      Re: ITCAM for Broker installation on Unix platform

      ‏2011-10-21T17:08:22Z  in response to alethad
      Hi,

      Thanks for your quick reply

      Since this is related to ITCAM product I have posted in ITCAM forum.

      The user has all the rights to install the agent, infact I the installation is successful and agent is also up.

      I am not clear on the warning "WARNING - Current user lacks permission to link lil files." what is it trying to link and why this WARNING for only Broker agent not for MQ and other ITCAM agents. Same package is used to install the MQ with same user and permissions I dont have any WARNING.
      • alethad
        alethad
        10 Posts
        ACCEPTED ANSWER

        Re: ITCAM for Broker installation on Unix platform

        ‏2011-10-21T18:10:22Z  in response to spatil@i3-soft.com
        Do they both create links to files? I thought only root could do that.

        If it worked for the other agent the only thing I can tell you is there inconsistencies between agents. Not all the agents are created the same. You just have to figure it out sometimes.

        I run several agents and they are all different with installing. Under the covers not the install script itself. It's kind of frustrating from an admin point of view for some of it. Your only recourse is to go look in the log files.

        Maybe someone else may have a better explanation for you. But each agent is different from the others.
        good luck.
        You've got to continue to grow, or you're just like last night's cornbread -- stale & dry Loretta Lynn+
      • raygun
        raygun
        1 Post
        ACCEPTED ANSWER

        Re: ITCAM for Broker installation on Unix platform

        ‏2011-10-24T16:03:08Z  in response to spatil@i3-soft.com
        The installation is trying to link the message broker lil files that allow the insertion of candle monitor nodes into your message flows to gather messageflow statistics. This is described in detail in the installation guide for the QI agent, but to answer your question, you can run this command (assuming you've installed the agent on 64-bit AIX) as root after the install.

        ln -s /opt/IBM/ITM/aix523/qi/bin/kqipnode64.lil /opt/IBM/mqsi/6.1/lil/kqipnode.lol
        ln -s /opt/IBM/ITM/aix523/qi/bin/kqipnode.cfg /opt/IBM/mqsi/6.1/lil/kqipnode.cfg

        Piper Jones
        Raygun Software - Innovative IBM Tivoli Monitoring Solutions
        http://www.raygunsoftware.net
        • spatil@i3-soft.com
          spatil@i3-soft.com
          3 Posts
          ACCEPTED ANSWER

          Re: ITCAM for Broker installation on Unix platform

          ‏2011-10-25T15:31:33Z  in response to raygun
          I am getting error as below when running below commands

          ln -s /opt/IBM/ITM/aix523/qi/bin/kqipnode64.lil /opt/IBM/mqsi/6.1/lil/kqipnode.lol
          ln -s /opt/IBM/ITM/aix523/qi/bin/kqipnode.cfg /opt/IBM/mqsi/6.1/lil/kqipnode.cfg

          error : "ln: A file or directory in the path name does not exist".

          so manually created the directory lil under /opt/IBM/mqsi/6.1 and able to run the commands. But even after that not able to see the workspaces populating the data and broker view

          Thanks in advance for your response
  • ChengLuo
    ChengLuo
    3 Posts
    ACCEPTED ANSWER

    Re: ITCAM for Broker installation on Unix platform

    ‏2011-12-19T08:37:49Z  in response to spatil@i3-soft.com
    I am afraid there is something wrong with the suffix of the file kqipnode. It should be kqipnode.lil instead of kqipnode.lol.
    ln -s /opt/IBM/ITM/aix523/qi/bin/kqipnode64.lil /opt/IBM/mqsi/6.1/lil/kqipnode.lil
    Thanks