Topic
  • 2 replies
  • Latest Post - ‏2011-10-14T13:43:19Z by hgpilai
hgpilai
hgpilai
3 Posts

Pinned topic ilv file not loading with correct colors and Background color not changing

‏2011-10-13T10:46:23Z |
Hi,

I am using a simple C++ program in Visual Studio on a pc with ILV studio 5.2, to read an .ilv file, which was created in ILV studio 5.1 in Linux env. Though the file is loaded, the colors used on the .ilv file (which is a window with text boxes, tabs, etc) seem to be distorted.

The background color for the .ilv file (text box for e.g.) in Linux was set to gray55, but what appears on the screen as the output of C++ code in Windows is not gray. The screen shot from Linux and Windows are attached.


Further, I tried to create a new .ilv file in ILV studio 5.2 on windows, only to find out that the background color is not changing. i.e. a created a new .ilv and dragged a text box and tried to change it to some color, it doesnt change.

I am afraid I am new to ILOG world, hence kindly throw some light into the issue. I am not sure whether its any settings issue,version issue, any .dll issue or even an O.S. issue.

Thanks
Hari

here is the code:

IlvDisplay* display = new IlvDisplay("IlvRead", "", argc, argv);
if (!display || display->isBad()) {
if (display) delete display;
IlvFatalError("Can't open display...");
return 1;
}

display->setPath (path);
const char* filePath = display->findInPath(fileName);
if (filePath)
IlvPrint("File %s found at %s", fileName, filePath);
else
IlvWarning("File %s not found", fileName);
IlvContainer* container = new IlvContainer(display, title, title,
IlvRect(startXint, startYint, widthint, heightint),
IlvTrue, IlvFalse);
container->setDestroyCallback(Quit);
container->readFile(fileName);
container->show();
IlvMainLoop();
return 0;
Updated on 2011-10-14T13:43:19Z at 2011-10-14T13:43:19Z by hgpilai
  • FPen
    FPen
    11 Posts

    Re: ilv file not loading with correct colors and Background color not changing

    ‏2011-10-13T12:22:26Z  
    Hello,

    the default look&feel may be different, you can have a look at the following FAQ that may help :
    http://www-01.ibm.com/support/docview.wss?uid=swg21401888

    Hope this helps

    Florian
  • hgpilai
    hgpilai
    3 Posts

    Re: ilv file not loading with correct colors and Background color not changing

    ‏2011-10-14T13:43:19Z  
    • FPen
    • ‏2011-10-13T12:22:26Z
    Hello,

    the default look&feel may be different, you can have a look at the following FAQ that may help :
    http://www-01.ibm.com/support/docview.wss?uid=swg21401888

    Hope this helps

    Florian
    Thanks Florian, it works now.