Topic
  • 11 replies
  • Latest Post - ‏2011-12-19T17:31:49Z by Roman@aformatik
SystemAdmin
SystemAdmin
590 Posts

Pinned topic Error installing Tools for Eclipse to Eclipse Indigo

‏2011-10-12T10:52:09Z |
When installing IBM WebSphere Application Server Developer Tools for Eclipse to Eclipse Indigo (v3.7.x)
(when I include WAS v7 and v8 tools).
I get error

Cannot complete the install because one or more required items could not be found.
Software currently installed: WebSphere® Application Server V8.0 Tools 1.0.100.v20110929_2121 (com.ibm.websphere.wdt.st.v8.feature.group 1.0.100.v20110929_2121)
Missing requirement: WebSphere Application Common Server Tools UI 6.1.505.v20110921_1907 (com.ibm.ws.ast.st.common.ui 6.1.505.v20110921_1907) requires 'bundle org.eclipse.jpt.core 2.3.0' but it could not be found
Cannot satisfy dependency:
From: Shared Server Tools 1.0.100.v20110929_2121 (com.ibm.websphere.wdt.st.common.feature.group 1.0.100.v20110929_2121)
To: com.ibm.ws.ast.st.common.ui http://6.1.505.v20110921_1907
Cannot satisfy dependency:
From: WebSphere® Application Server V8.0 Tools 1.0.100.v20110929_2121 (com.ibm.websphere.wdt.st.v8.feature.group 1.0.100.v20110929_2121)
To: com.ibm.websphere.wdt.st.common.feature.group http://1.0.100.v20110929_2121

Seems that that this plugin develoopers have tested with very old Helios version, in my Helios there is org.eclipse.jpt.core_2.3.2.v201008252310.jar
I'll tried to copy that jar to Indigo, but seems that exact version about plugin is needed
  • JoeChacko
    JoeChacko
    15 Posts

    Re: Error installing Tools for Eclipse to Eclipse Indigo

    ‏2011-10-12T11:09:07Z  
    Sorry you are getting this error. I think you have correctly identified that the V8.0 tools were developed for an earlier version of Eclipse.

    On Indigo, I suggest you install just the V8.5 tools, which will let you develop and test web applications that you can then package and deploy to V8.0 servers.
    --
    Joe
  • SystemAdmin
    SystemAdmin
    590 Posts

    Re: Error installing Tools for Eclipse to Eclipse Indigo

    ‏2011-10-12T12:24:39Z  
    • JoeChacko
    • ‏2011-10-12T11:09:07Z
    Sorry you are getting this error. I think you have correctly identified that the V8.0 tools were developed for an earlier version of Eclipse.

    On Indigo, I suggest you install just the V8.5 tools, which will let you develop and test web applications that you can then package and deploy to V8.0 servers.
    --
    Joe
    I tested V8.5 tools in Indigo and it worked ok.

    But we want use WAS v7 and v8 tools from Indigo because of publishing from RAD (v8.0.3) is so slow...

    We would want to use in development pure Eclipse (Indigo) e.g. developing User Interface (JSF2).

    If there is any speeding against RAD publishing?
  • SystemAdmin
    SystemAdmin
    590 Posts

    Re: Error installing Tools for Eclipse to Eclipse Indigo

    ‏2011-10-12T16:13:41Z  
    I tested V8.5 tools in Indigo and it worked ok.

    But we want use WAS v7 and v8 tools from Indigo because of publishing from RAD (v8.0.3) is so slow...

    We would want to use in development pure Eclipse (Indigo) e.g. developing User Interface (JSF2).

    If there is any speeding against RAD publishing?
    The WebSphere Application Server (WAS) v7.0 and v8.0 requires a different version of Eclipse (Helios). If you want WAS v7 and/or v8 support, then you'll need to get the Helios package as the prerequisite:
    For 3.6.2 (Helios): http://eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/heliossr2

    Note that WebSphere Application Server V8.5 Alpha Liberty Profile will also work with Helios. Therefore, you can install all the version supports when using Helios.

    For details on the prerequisites and installation instructions, you can refer to this document:
    http://publib.boulder.ibm.com/infocenter/wasinfo/beta/index.jsp?topic=%2Fcom.ibm.websphere.w4d.nd.multiplatform.doc%2Ftopics%2FwdtV85_overview.html

    Elson
  • korhojo
    korhojo
    5 Posts

    Re: Error installing Tools for Eclipse to Eclipse Indigo

    ‏2011-10-19T08:49:18Z  
    The WebSphere Application Server (WAS) v7.0 and v8.0 requires a different version of Eclipse (Helios). If you want WAS v7 and/or v8 support, then you'll need to get the Helios package as the prerequisite:
    For 3.6.2 (Helios): http://eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/heliossr2

    Note that WebSphere Application Server V8.5 Alpha Liberty Profile will also work with Helios. Therefore, you can install all the version supports when using Helios.

    For details on the prerequisites and installation instructions, you can refer to this document:
    http://publib.boulder.ibm.com/infocenter/wasinfo/beta/index.jsp?topic=%2Fcom.ibm.websphere.w4d.nd.multiplatform.doc%2Ftopics%2FwdtV85_overview.html

    Elson
    Hi!

    I found the "easy install" instructions a bit confusing :-) I didn't realize at first they meant just the tools. It wasn't until a much further step after installing the server tools that I read from the Info Center that one can use Eclipse to load the server installation itself when adding a new server. I prefer to load all the packages beforehand manually and it would be better to know what one needs from the start.

    Eclipse 3.6+ doesn't work with out proxy since Eclipse broke proxy auth somewhat. I had to use GPRS to load the tools in Eclipse. Well, our proxy may need a little tuning I suppose.

    Anyhow, CQ and maybe CC screw up the Windows env vars, PATH at least, since they use long file names with spaces and was4d doesn't start then. I had to fix the env's to use
    C:\PROGRA~2 (since we have 64b, C:\PROGRA~1 is 64b) to get it to work. I'm gonna PMR this as a CQ problem.

    I first changed PATH and JAVA_HOME and JRE_HOME to point to the WAS 7 JRE from RAD 8.0.3. I was able to start was4j ok from the cmd line. But I then tried to start Indigo using WAS7 JRE but it wouldn't. I created a script that sets the env to use Oracle JRE 6 and starts Eclipse. was4j still started ok using the tools.
  • PVSY_Nabil_Abdi
    PVSY_Nabil_Abdi
    2 Posts

    Re: Error installing Tools for Eclipse to Eclipse Indigo

    ‏2011-10-22T01:49:42Z  
    • JoeChacko
    • ‏2011-10-12T11:09:07Z
    Sorry you are getting this error. I think you have correctly identified that the V8.0 tools were developed for an earlier version of Eclipse.

    On Indigo, I suggest you install just the V8.5 tools, which will let you develop and test web applications that you can then package and deploy to V8.0 servers.
    --
    Joe
    It's odd, on Eclipse 3.7 there is support for WAS 6 but not for WAS 7 and 8.
    and on Eclipse 3.6.2 there is support for WAS 7, 8 and 8.5 alpha.

    Is there any rational for not supporting WAS 7 and 8 in Eclipse 3.7 ?
  • deboer
    deboer
    19 Posts

    Re: Error installing Tools for Eclipse to Eclipse Indigo

    ‏2011-10-24T12:47:33Z  
    It's odd, on Eclipse 3.7 there is support for WAS 6 but not for WAS 7 and 8.
    and on Eclipse 3.6.2 there is support for WAS 7, 8 and 8.5 alpha.

    Is there any rational for not supporting WAS 7 and 8 in Eclipse 3.7 ?
    Hi,

    In the alpha the WAS v7 and v8 tools only work on Eclipse 3.6, but this is point-in-time. There is some API breakage in Eclipse 3.7 that we have to work around, but hope to be able to expand the support soon.

    The WAS v8.5 Alpha Liberty Profile tools work on both 3.6 and 3.7.

    FYI/FWIW, the WAS v6 you're seeing is a basic adapter developed as part of Eclipse WTP many years ago and is not from IBM.

    Thanks,
    Tim deBoer
  • PVSY_Nabil_Abdi
    PVSY_Nabil_Abdi
    2 Posts

    Re: Error installing Tools for Eclipse to Eclipse Indigo

    ‏2011-10-24T12:54:52Z  
    • deboer
    • ‏2011-10-24T12:47:33Z
    Hi,

    In the alpha the WAS v7 and v8 tools only work on Eclipse 3.6, but this is point-in-time. There is some API breakage in Eclipse 3.7 that we have to work around, but hope to be able to expand the support soon.

    The WAS v8.5 Alpha Liberty Profile tools work on both 3.6 and 3.7.

    FYI/FWIW, the WAS v6 you're seeing is a basic adapter developed as part of Eclipse WTP many years ago and is not from IBM.

    Thanks,
    Tim deBoer
    Thank you for the explaination.
  • kemo
    kemo
    3 Posts

    Re: Error installing Tools for Eclipse to Eclipse Indigo

    ‏2011-11-16T22:20:17Z  
    Hi

    tried to install this into helios

    Cannot drag .. which is understandable... but I cannot configure the repo either ... I get the following error
    Unable to read repository at http://marketplace.eclipse.org/node/131344.
    Unable to read repository at http://marketplace.eclipse.org/node/131344.
    http://marketplace.eclipse.org/node/131344 is not a valid repository location.
    Any assistance would be ost apreciated.

    Thanks
  • deboer
    deboer
    19 Posts

    Re: Error installing Tools for Eclipse to Eclipse Indigo

    ‏2011-11-23T13:44:52Z  
    • kemo
    • ‏2011-11-16T22:20:17Z
    Hi

    tried to install this into helios

    Cannot drag .. which is understandable... but I cannot configure the repo either ... I get the following error
    Unable to read repository at http://marketplace.eclipse.org/node/131344.
    Unable to read repository at http://marketplace.eclipse.org/node/131344.
    http://marketplace.eclipse.org/node/131344 is not a valid repository location.
    Any assistance would be ost apreciated.

    Thanks
    Hi Kemo,

    Sorry for the slow reply. From the information you provided I cannot tell whether you were installing correctly or not, or the Eclipse Marketplace website was simply having trouble on the day you tried. Either way, I have just tested and it is working fine for me. Please go to Help > Eclipse Marketplace, type 'WebSphere', search, select the WAS v7 or v8 tools, Install, and then follow the installation wizard.

    FWIW, Helios did not support the drag-to-install and that's why the instructions use the standard Marketplace for 3.6. Drag support was added in Indigo/3.7.

    Tim
  • Roman@aformatik
    Roman@aformatik
    3 Posts

    Re: Error installing Tools for Eclipse to Eclipse Indigo

    ‏2011-12-19T17:30:35Z  
    • deboer
    • ‏2011-11-23T13:44:52Z
    Hi Kemo,

    Sorry for the slow reply. From the information you provided I cannot tell whether you were installing correctly or not, or the Eclipse Marketplace website was simply having trouble on the day you tried. Either way, I have just tested and it is working fine for me. Please go to Help > Eclipse Marketplace, type 'WebSphere', search, select the WAS v7 or v8 tools, Install, and then follow the installation wizard.

    FWIW, Helios did not support the drag-to-install and that's why the instructions use the standard Marketplace for 3.6. Drag support was added in Indigo/3.7.

    Tim
    Tim,

    perhaps it's you who can bring light in my current situation.

    I have Eclipse 3.7 SR 1 for Java EE Developers, as stated in the project requirements.
    I'm running this on the newest oracle 6 JRE (1.6.0.29).
    I try to download the WAS V8.5 Tools and during plugin-installation, I get the following error:

    An error occurred while collecting items to be installed
    session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
    Problems downloading artifact: osgi.bundle,com.ibm.etools.webedit.xulrunner,1.0.0.v20111114_1856.
    MD5 hash is not as expected. Expected: 7ba3e2d94c1883a229a5ca9be3ffe405 and found 2d8c3173f6d1e5ed36e1a3db6c96c447.

    Did try to run Eclipse 3.7 on IBM JDK (from WAS 8), didn't change anything.
    Did try to run Eclipse on Java 7 Update 1 from Oracle, but I remember an Eclipse bug concerning updates and Java 7,
    so I didn't expect this to work, which it didn't, of course.

    Do you have some ideas? Any help is appreciated!

    Regards,
    Roman
  • Roman@aformatik
    Roman@aformatik
    3 Posts

    Re: Error installing Tools for Eclipse to Eclipse Indigo

    ‏2011-12-19T17:31:49Z  
    Tim,

    perhaps it's you who can bring light in my current situation.

    I have Eclipse 3.7 SR 1 for Java EE Developers, as stated in the project requirements.
    I'm running this on the newest oracle 6 JRE (1.6.0.29).
    I try to download the WAS V8.5 Tools and during plugin-installation, I get the following error:

    An error occurred while collecting items to be installed
    session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
    Problems downloading artifact: osgi.bundle,com.ibm.etools.webedit.xulrunner,1.0.0.v20111114_1856.
    MD5 hash is not as expected. Expected: 7ba3e2d94c1883a229a5ca9be3ffe405 and found 2d8c3173f6d1e5ed36e1a3db6c96c447.

    Did try to run Eclipse 3.7 on IBM JDK (from WAS 8), didn't change anything.
    Did try to run Eclipse on Java 7 Update 1 from Oracle, but I remember an Eclipse bug concerning updates and Java 7,
    so I didn't expect this to work, which it didn't, of course.

    Do you have some ideas? Any help is appreciated!

    Regards,
    Roman
    Sorry,

    forget to mention: this happens in drag-and-drop-installation and in
    Eclipse Marketplace installation as well.

    :-)