Topic
  • 7 replies
  • Latest Post - ‏2014-05-28T02:09:48Z by nathan_sz
gonzalo.alvarez
gonzalo.alvarez
7 Posts

Pinned topic Error setting up a Datasource for Oracle 9i in WAS 7.0.0.19

‏2011-09-28T20:45:05Z |
Hello, I'm having problems creating datasources for a database Oracle 9i.
I'm creating the datasources following the instructions provided in this link:
http://publib.boulder.ibm.com/infocenter/wasinfo/v7r0/topic/com.ibm.websphere.express.doc/info/exp/ae/rdat_minreqoracle.html

I'm using the driver 'ojdbc6.jar' and when creating the Datasource I'm selecting 'Oracle11g data store helper'.

When running the Test Connection for the datasources I receive this error in the Network Deployment Manager Console:

The test connection operation failed for data source aaa on server nodeagent at node rstadj2ee01Node01 with the following exception: javax.management.JMRuntimeException: ADMN0034E: The service is unable to obtain a valid administrative client to connect process "rstadj2ee01Node01" from process "dmgr", because of exception: com.ibm.websphere.management.exception.ConnectorException: com.ibm.ws.management.connector.ipc.RetryCandidateException: java.io.IOException: SSL connection was closed by peer. View JVM logs for further details.
The test connection operation failed for data source aaa on server nodeagent at node rstadj2ee02Node01 with the following exception: javax.management.JMRuntimeException: ADMN0034E: The service is unable to obtain a valid administrative client to connect process "rstadj2ee02Node01" from process "dmgr", because of exception: com.ibm.websphere.management.exception.ConnectorException: ADMC0009E: The system failed to make the SOAP RPC call: invoke. View JVM logs for further details.
This is the output printed in the SytemOut.log of the NodeAgent during the Test Connection (The complete stack trace is attached):

9/28/11 15:00:45:292 PET 0000002a NodeSyncTask A ADMS0003I: The configuration synchronization completed successfully.
9/28/11 15:02:59:058 PET 00000011 FfdcProvider W com.ibm.ws.ffdc.impl.FfdcProvider logIncident FFDC1003I: FFDC Incident emitted on /fs001/IBM/WebSphere/AppServer/profiles/profile01/logs/ffdc/nodeagent_2c832c83_11.09.28_15.02.59.0477199946517058571274.txt com.ibm.ws.rsadapter.DSConfigurationHelper.getPooledConnection 568
9/28/11 15:02:59:078 PET 00000011 FfdcProvider W com.ibm.ws.ffdc.impl.FfdcProvider logIncident FFDC1003I: FFDC Incident emitted on /fs001/IBM/WebSphere/AppServer/profiles/profile01/logs/ffdc/nodeagent_2c832c83_11.09.28_15.02.59.0746695237706305902540.txt com.ibm.ws.rsadapter.DSConfigurationHelper.testConnectionToDataSource 1486
9/28/11 15:02:59:082 PET 00000011 DSConfigurati W DSRA8201W: DataSource Configuration: DSRA8040I: Failed to connect to the DataSource. Encountered java.sql.SQLException: The Network Adapter could not establish the connectionDSRA0010E: SQL State = 61000, Error Code = 20.
java.sql.SQLException: The Network Adapter could not establish the connectionDSRA0010E: SQL State = 61000, Error Code = 20

9/28/11 15:02:59:147 PET 00000011 DataSourceCon E DSRA8040I: Failed to connect to the DataSource. Encountered "": java.sql.SQLException: The Network Adapter could not establish the connectionDSRA0010E: SQL State = 61000, Error Code = 20

9/28/11 15:02:59:200 PET 00000011 DMAdapter I com.ibm.ws.ffdc.impl.DMAdapter getAnalysisEngine FFDC1009I: Analysis Engine using data base: /fs001/IBM/WebSphere/AppServer/profiles/profile01/properties/logbr/ffdc/adv/ffdcdb.xml
9/28/11 15:02:59:335 PET 00000011 FfdcProvider W com.ibm.ws.ffdc.impl.FfdcProvider logIncident FFDC1003I: FFDC Incident emitted on /fs001/IBM/WebSphere/AppServer/profiles/profile01/logs/ffdc/nodeagent_2c832c83_11.09.28_15.02.59.1844816649573260761939.txt com.ibm.ws.management.AdminServiceImpl.invoke 679
9/28/11 15:03:45:326 PET 0000002d NodeSyncTask A ADMS0003I: The configuration synchronization completed successfully.
9/28/11 15:04:14:023 PET 00000017 DSConfigurati W DSRA8201W: DataSource Configuration: DSRA8040I: Failed to connect to the DataSource. Encountered java.sql.SQLException: The Network Adapter could not establish the connectionDSRA0010E: SQL State = 61000, Error Code = 20.
java.sql.SQLException: The Network Adapter could not establish the connectionDSRA0010E: SQL State = 61000, Error Code = 20

9/28/11 15:04:14:052 PET 00000017 DataSourceCon E DSRA8040I: Failed to connect to the DataSource. Encountered "": java.sql.SQLException: The Network Adapter could not establish the connectionDSRA0010E: SQL State = 61000, Error Code = 20

9/28/11 15:04:45:349 PET 0000002e NodeSyncTask A ADMS0003I: The configuration synchronization completed successfully.
I've also tried using the driver 'ojdbc14.jar' but I received this error:

DSRA8040I: Failed to connect to the DataSource. Encountered : java.lang.Exception: java.sql.SQLException: Io exception: The Network Adapter could not establish the connectionDSRA0010E: SQL State = null, Error Code = 17,002

Does somebody know what could be happening here?

Thanks in advance,
Regards,

--
Gonzalo Alvarez Flores
Follow the white rabbit...
Updated on 2013-02-28T15:20:35Z at 2013-02-28T15:20:35Z by SystemAdmin
  • gas
    gas
    892 Posts

    Re: Error setting up a Datasource for Oracle 9i in WAS 7.0.0.19

    ‏2011-09-30T09:39:11Z  
    Hi,

    Looking at log I can see:

    Caused by: oracle.net.ns.NetException: The Network Adapter could not establish the connection
    at oracle.net.nt.ConnStrategy.execute(ConnStrategy.java:328)
    at oracle.net.resolver.AddrResolution.resolveAndExecute(AddrResolution.java:421)
    at oracle.net.ns.NSProtocol.establishConnection(NSProtocol.java:630)
    at oracle.net.ns.NSProtocol.connect(NSProtocol.java:206)
    at oracle.jdbc.driver.T4CConnection.connect(T4CConnection.java:966)
    at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:292)
    ... 54 more
    Caused by: java.net.ConnectException: A remote host did not respond within the timeout period.
    at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:383)
    at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:245)
    So it looks like nothing is listening on the remote host.

    Verify if you can telnet to oracle host and port from the nodeagent machine.
    Maybe database is not started, is listening on different port or you have some firewall in between.
  • sarjak83
    sarjak83
    4 Posts

    Re: Error setting up a Datasource for Oracle 9i in WAS 7.0.0.19

    ‏2011-10-01T12:35:00Z  
    You might have firewall in between wherein required ports might not be open.

    See below link

    http://www.webspheretools.com/sites/webspheretools.nsf/docs/The%20Network%20Adapter%20could%20not%20establish%20the%20connectionDSRA0010E

    Regards,
    Sarjak
  • gonzalo.alvarez
    gonzalo.alvarez
    7 Posts

    Re: Error setting up a Datasource for Oracle 9i in WAS 7.0.0.19

    ‏2011-10-03T03:23:26Z  
    • sarjak83
    • ‏2011-10-01T12:35:00Z
    You might have firewall in between wherein required ports might not be open.

    See below link

    http://www.webspheretools.com/sites/webspheretools.nsf/docs/The%20Network%20Adapter%20could%20not%20establish%20the%20connectionDSRA0010E

    Regards,
    Sarjak
    Thanks for your replies.
    You were right, the IP address of the WAS7 server wasn't authorized in the firewall, the problem is solved! :)
    --
    Gonzalo Alvarez Flores
    Follow the white rabbit...
  • MPSERVICES
    MPSERVICES
    1 Post

    Re: Error setting up a Datasource for Oracle 9i in WAS 7.0.0.19

    ‏2012-02-17T07:23:57Z  
    • sarjak83
    • ‏2011-10-01T12:35:00Z
    You might have firewall in between wherein required ports might not be open.

    See below link

    http://www.webspheretools.com/sites/webspheretools.nsf/docs/The%20Network%20Adapter%20could%20not%20establish%20the%20connectionDSRA0010E

    Regards,
    Sarjak
    Hi,

    Thanks a lot...
    Regards,
    Mahesh(INDIA).
  • SystemAdmin
    SystemAdmin
    37422 Posts

    Re: Error setting up a Datasource for Oracle 9i in WAS 7.0.0.19

    ‏2013-02-28T15:20:35Z  
    Hi,

    Thanks a lot...
    Regards,
    Mahesh(INDIA).
    Hi,

    I'm getting similar kind of error which is:



    2/28/13 20:37:27:171 IST 00000014 MBeanHelper E Could not invoke an operation on object: WebSphere:name=DataSourceCfgHelper,process=server1,platform=dynamicproxy,node=AshishPNode01,version=7.0.0.25,type=DataSourceCfgHelper,mbeanIdentifier=DataSourceCfgHelper,cell=AshishPNode01Cell,spec=1.0 because of an mbean exception: java.sql.SQLException: The Network Adapter could not establish the connectionDSRA0010E: SQL State = 61000, Error Code = 20
    2/28/13 20:37:27:125 IST 00000014 SystemErr R java.sql.SQLException: The Network Adapter could not establish the connectionDSRA0010E: SQL State = 61000, Error Code = 20
    2/28/13 20:37:27:125 IST 00000014 SystemErr R at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:412)
    2/28/13 20:37:27:125 IST 00000014 SystemErr R at oracle.jdbc.driver.PhysicalConnection.<init>(PhysicalConnection.java:531)
    2/28/13 20:37:27:125 IST 00000014 SystemErr R at oracle.jdbc.driver.T4CConnection.<init>(T4CConnection.java:221)
    2/28/13 20:37:27:125 IST 00000014 SystemErr R at oracle.jdbc.driver.T4CDriverExtension.getConnection(T4CDriverExtension.java:32)
    2/28/13 20:37:27:125 IST 00000014 SystemErr R at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:503)



    I was able to successfully telnet the IP Port of the DB machine from the host.

    Not able to guess the probable cause for this problem. Any help would be highly appreciated.

    Thanks | Ashish
  • JuanMontalvoGodina
    JuanMontalvoGodina
    1 Post

    Re: Error setting up a Datasource for Oracle 9i in WAS 7.0.0.19

    ‏2013-04-25T20:19:35Z  
    Hi,

    I'm getting similar kind of error which is:



    2/28/13 20:37:27:171 IST 00000014 MBeanHelper E Could not invoke an operation on object: WebSphere:name=DataSourceCfgHelper,process=server1,platform=dynamicproxy,node=AshishPNode01,version=7.0.0.25,type=DataSourceCfgHelper,mbeanIdentifier=DataSourceCfgHelper,cell=AshishPNode01Cell,spec=1.0 because of an mbean exception: java.sql.SQLException: The Network Adapter could not establish the connectionDSRA0010E: SQL State = 61000, Error Code = 20
    2/28/13 20:37:27:125 IST 00000014 SystemErr R java.sql.SQLException: The Network Adapter could not establish the connectionDSRA0010E: SQL State = 61000, Error Code = 20
    2/28/13 20:37:27:125 IST 00000014 SystemErr R at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:412)
    2/28/13 20:37:27:125 IST 00000014 SystemErr R at oracle.jdbc.driver.PhysicalConnection.<init>(PhysicalConnection.java:531)
    2/28/13 20:37:27:125 IST 00000014 SystemErr R at oracle.jdbc.driver.T4CConnection.<init>(T4CConnection.java:221)
    2/28/13 20:37:27:125 IST 00000014 SystemErr R at oracle.jdbc.driver.T4CDriverExtension.getConnection(T4CDriverExtension.java:32)
    2/28/13 20:37:27:125 IST 00000014 SystemErr R at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:503)



    I was able to successfully telnet the IP Port of the DB machine from the host.

    Not able to guess the probable cause for this problem. Any help would be highly appreciated.

    Thanks | Ashish

    Hello

     

    Did you solve this problem? I would appreciate if you could help me.

     

    Best Regards

  • nathan_sz
    nathan_sz
    1 Post

    Re: Error setting up a Datasource for Oracle 9i in WAS 7.0.0.19

    ‏2014-05-28T02:09:48Z  

    Hello

     

    Did you solve this problem? I would appreciate if you could help me.

     

    Best Regards

    I change the jdbc jar (ojdbc6.jar) and it fix my problem.