Topic
  • 7 replies
  • Latest Post - ‏2011-09-26T20:27:39Z by mc01285
mc01285
mc01285
8 Posts

Pinned topic WTX and Subversion

‏2011-09-26T17:33:56Z |
Has anybody had success intalling the Subeclipse plugin for Subversion into WTX Design Studio?

I use WTX 8.2.0.4

Thanks, Mark
Updated on 2011-09-26T20:27:39Z at 2011-09-26T20:27:39Z by mc01285
  • Dhiren.Ghelani
    Dhiren.Ghelani
    76 Posts

    Re: WTX and Subversion

    ‏2011-09-26T17:57:05Z  
    works for me. If the initial install fails due to issues with dependencies, include the following under Callisto Discovery Site
    1. Charting and reporting
    2. Database Development
    3. Enabling features
    4. Java development

    Let us know how you get on.
  • mc01285
    mc01285
    8 Posts

    Re: WTX and Subversion

    ‏2011-09-26T18:12:08Z  
    I tried added the Callisto site and when I choose any of the features I get this:

    Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.

    Current configuration problems
    TPTP Platform Trace (4.2.3.v200701141614--2PD88Q8LCF_J_K) requires plug-in "org.eclipse.pde.core".
    Java Code Review Feature (4.2.3.v200701141614--1G955H668B6GAA) requires plug-in "org.eclipse.pde.core".
    BIRT Reporting for TPTP Feature (4.2.0.v200606131519--1G955G5G7A7E7M) requires plug-in "org.eclipse.birt.core".

    Configuration problems after the operation
    TPTP Platform Trace (4.2.3.v200701141614--2PD88Q8LCF_J_K) requires plug-in "org.eclipse.pde.core".
    Java Code Review Feature (4.2.3.v200701141614--1G955H668B6GAA) requires plug-in "org.eclipse.pde.core".
    Eclipse BIRT Report Designer Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.pde.ui (3.2.0)", or compatible.
    Visual Editor (1.2.1.v20060817_M-zXJUB0fxM-0vSdc) requires feature "org.eclipse.pde (3.2.0)", or compatible.
    Graphical Modeling Framework (Callisto Edition) (1.0.3.v20070202-1200) requires plug-in "org.eclipse.pde.ui (3.2.0)", or compatible.

    Thanks, Mark
  • Dhiren.Ghelani
    Dhiren.Ghelani
    76 Posts

    Re: WTX and Subversion

    ‏2011-09-26T18:17:24Z  
    • mc01285
    • ‏2011-09-26T18:12:08Z
    I tried added the Callisto site and when I choose any of the features I get this:

    Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.

    Current configuration problems
    TPTP Platform Trace (4.2.3.v200701141614--2PD88Q8LCF_J_K) requires plug-in "org.eclipse.pde.core".
    Java Code Review Feature (4.2.3.v200701141614--1G955H668B6GAA) requires plug-in "org.eclipse.pde.core".
    BIRT Reporting for TPTP Feature (4.2.0.v200606131519--1G955G5G7A7E7M) requires plug-in "org.eclipse.birt.core".

    Configuration problems after the operation
    TPTP Platform Trace (4.2.3.v200701141614--2PD88Q8LCF_J_K) requires plug-in "org.eclipse.pde.core".
    Java Code Review Feature (4.2.3.v200701141614--1G955H668B6GAA) requires plug-in "org.eclipse.pde.core".
    Eclipse BIRT Report Designer Feature (2.1.2.v20070205-1728) requires plug-in "org.eclipse.pde.ui (3.2.0)", or compatible.
    Visual Editor (1.2.1.v20060817_M-zXJUB0fxM-0vSdc) requires feature "org.eclipse.pde (3.2.0)", or compatible.
    Graphical Modeling Framework (Callisto Edition) (1.0.3.v20070202-1200) requires plug-in "org.eclipse.pde.ui (3.2.0)", or compatible.

    Thanks, Mark
    do you try to install everything under Subclipse?
  • mc01285
    mc01285
    8 Posts

    Re: WTX and Subversion

    ‏2011-09-26T18:22:14Z  
    Yes . . . I check the top level Subelipse box, and I get:

    Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.

    Current configuration problems
    TPTP Platform Trace (4.2.3.v200701141614--2PD88Q8LCF_J_K) requires plug-in "org.eclipse.pde.core".
    Java Code Review Feature (4.2.3.v200701141614--1G955H668B6GAA) requires plug-in "org.eclipse.pde.core".
    BIRT Reporting for TPTP Feature (4.2.0.v200606131519--1G955G5G7A7E7M) requires plug-in "org.eclipse.birt.core".

    Configuration problems after the operation
    TPTP Platform Trace (4.2.3.v200701141614--2PD88Q8LCF_J_K) requires plug-in "org.eclipse.pde.core".
    Java Code Review Feature (4.2.3.v200701141614--1G955H668B6GAA) requires plug-in "org.eclipse.pde.core".
    BIRT Reporting for TPTP Feature (4.2.0.v200606131519--1G955G5G7A7E7M) requires plug-in "org.eclipse.birt.core".
    CollabNet Merge Client (2.2.4) requires plug-in "org.eclipse.ui (3.3.0)", or later version.
    Subclipse Integration for Mylyn 3.x (Optional) (3.0.0) requires plug-in "org.eclipse.mylyn.tasks.core (3.0.0)", or compatible.
    Thanks, Mark
  • Dhiren.Ghelani
    Dhiren.Ghelani
    76 Posts

    Re: WTX and Subversion

    ‏2011-09-26T18:27:39Z  
    • mc01285
    • ‏2011-09-26T18:22:14Z
    Yes . . . I check the top level Subelipse box, and I get:

    Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.

    Current configuration problems
    TPTP Platform Trace (4.2.3.v200701141614--2PD88Q8LCF_J_K) requires plug-in "org.eclipse.pde.core".
    Java Code Review Feature (4.2.3.v200701141614--1G955H668B6GAA) requires plug-in "org.eclipse.pde.core".
    BIRT Reporting for TPTP Feature (4.2.0.v200606131519--1G955G5G7A7E7M) requires plug-in "org.eclipse.birt.core".

    Configuration problems after the operation
    TPTP Platform Trace (4.2.3.v200701141614--2PD88Q8LCF_J_K) requires plug-in "org.eclipse.pde.core".
    Java Code Review Feature (4.2.3.v200701141614--1G955H668B6GAA) requires plug-in "org.eclipse.pde.core".
    BIRT Reporting for TPTP Feature (4.2.0.v200606131519--1G955G5G7A7E7M) requires plug-in "org.eclipse.birt.core".
    CollabNet Merge Client (2.2.4) requires plug-in "org.eclipse.ui (3.3.0)", or later version.
    Subclipse Integration for Mylyn 3.x (Optional) (3.0.0) requires plug-in "org.eclipse.mylyn.tasks.core (3.0.0)", or compatible.
    Thanks, Mark
    Try with the following
    1. Unselect JNA and SVNKit
    2. Under subclipse, select the components labelled (required). you should see 3.
  • mc01285
    mc01285
    8 Posts

    Re: WTX and Subversion

    ‏2011-09-26T18:35:57Z  
    I tried that . . . I checked just the 3 Required items and:

    The current configuration contains errors and this operation can have unpredictable results.
    Java Code Review Feature (4.2.3.v200701141614--1G955H668B6GAA) requires plug-in "org.eclipse.pde.core".
    BIRT Reporting for TPTP Feature (4.2.0.v200606131519--1G955G5G7A7E7M) requires plug-in "org.eclipse.birt.core".
    TPTP Platform Trace (4.2.3.v200701141614--2PD88Q8LCF_J_K) requires plug-in "org.eclipse.pde.core".
    I'm no export on WTX, but I'm wondering if my base WTX install is not correct?? I have been using it for a few months with no issues (CVS included). We are just starting to moving all our CVS projects over to SVN.

    Thanks, Mark
  • mc01285
    mc01285
    8 Posts

    Re: WTX and Subversion

    ‏2011-09-26T20:27:39Z  
    I got it . . . here are the steps I took:

    Reinstall WTX 8.2.0.4
    Reinstall WTX Integration Services 8.2.0.4
    Reinstall WTX Interim_Fix03

    Start WTX with CleanExtenderStudio.bat

    Update from Callisto Discovery Site

    Update from Subeclipse site (http://subclipse.tigris.org/update_1.6.x)

    Thanks, Mark