Topic
  • 13 replies
  • Latest Post - ‏2015-04-20T11:18:19Z by U3U5_Javier_Quintana
roll81
roll81
1 Post

Pinned topic Deleting server with WAS 7 console

‏2011-09-26T06:36:46Z |
I have one server on my network deployment that i want to delete but i can't. When I try to delete it following error occurs:

An error occurred while deleting the server. ADMG0011E: An unexpected exception occurred com.ibm.websphere.management.exception.AdminException: Exception in removeTargetFromCUs().. Try to delete the server again. If the error persists, see the problem determination on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/."
Does anyone knows how to delete it?

Thnx.
Updated on 2013-01-08T19:47:26Z at 2013-01-08T19:47:26Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    37422 Posts

    Re: Deleting server with WAS 7 console

    ‏2011-10-19T22:11:46Z  
    Hopefully you have already figured out your problem, but I just saw something similar this week.

    For us, it was caused by an application that was corrupt in the configuration. The application was not deployed to the server we were trying to delete. However, since we were trying to delete a server, it was going through all the applications to see if it was deployed on the one we were trying to delete. It could not read the application data properly and we got the same exception.

    Cindy
  • SystemAdmin
    SystemAdmin
    37422 Posts

    Re: Deleting server with WAS 7 console

    ‏2011-10-26T20:02:32Z  
    Hopefully you have already figured out your problem, but I just saw something similar this week.

    For us, it was caused by an application that was corrupt in the configuration. The application was not deployed to the server we were trying to delete. However, since we were trying to delete a server, it was going through all the applications to see if it was deployed on the one we were trying to delete. It could not read the application data properly and we got the same exception.

    Cindy
    Unfortunately, not. :(

    There are no applications that are deployed to that server. Maybe there are some configuration parameters left for past applications.

    You are suggesting that the past application should be deployed again to the server, and then try to delete the server itself?

    Thanks in advance! ;)
  • SystemAdmin
    SystemAdmin
    37422 Posts

    Re: Deleting server with WAS 7 console

    ‏2011-10-26T21:08:44Z  
    Unfortunately, not. :(

    There are no applications that are deployed to that server. Maybe there are some configuration parameters left for past applications.

    You are suggesting that the past application should be deployed again to the server, and then try to delete the server itself?

    Thanks in advance! ;)
    The application does not have to be deployed to that server to cause the problem. Look through your configuration to see if you have application directories such as:

    ...profile/config/cells/mycell/blas/myapp
    ...profile/config/cells/mycell/cus/myapp

    For an application "myapp" that is not fully or properly installed. If you find such directories and delete them, you should be able to delete the server. There could be system application information there that you don't want to delete. Depending on the environment you are working with, you will want to be a careful. Try to delete the server using wsadmin and see if you get any better information on which application is causing the issue.
  • Kambiz123
    Kambiz123
    7 Posts

    Re: Deleting server with WAS 7 console

    ‏2012-02-10T20:23:12Z  
    Visit the two folders mentioned: cus and blas in the delpoyment manager config folder and remove any application folder that is no longer exist in the admin console. Our case there were two of them.

    /opt/IBM/WebSphere/AppServer/profiles/Custom01/config/cells/srpmxd01Cell01
  • asmoljo
    asmoljo
    14 Posts

    Re: Deleting server with WAS 7 console

    ‏2012-02-13T12:19:36Z  
    • Kambiz123
    • ‏2012-02-10T20:23:12Z
    Visit the two folders mentioned: cus and blas in the delpoyment manager config folder and remove any application folder that is no longer exist in the admin console. Our case there were two of them.

    /opt/IBM/WebSphere/AppServer/profiles/Custom01/config/cells/srpmxd01Cell01
    Hi ,
    I also have same problem :

    An error occurred while deleting the server. ADMG0011E: An unexpected exception occurred com.ibm.websphere.management.exception.AdminException: Exception in removeTargetFromCUs().. Try to delete the server again. If the error persists, see the problem determination on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/."

    As you suggested, I deleted the folders, but still get the same error !

    Some other ideas?

    Thanks
  • SystemAdmin
    SystemAdmin
    37422 Posts

    Re: Deleting server with WAS 7 console

    ‏2012-02-13T12:27:31Z  
    • asmoljo
    • ‏2012-02-13T12:19:36Z
    Hi ,
    I also have same problem :

    An error occurred while deleting the server. ADMG0011E: An unexpected exception occurred com.ibm.websphere.management.exception.AdminException: Exception in removeTargetFromCUs().. Try to delete the server again. If the error persists, see the problem determination on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/."

    As you suggested, I deleted the folders, but still get the same error !

    Some other ideas?

    Thanks
    Try to check if there is any records for this server in this file:

    <WAS_HOME>\profiles\Dmgr01\config\cells\<cell>\coregroups\<CoreGroup>\coregroup.xml

    //Ahmed
  • asmoljo
    asmoljo
    14 Posts

    Re: Deleting server with WAS 7 console

    ‏2012-02-13T13:21:00Z  
    Try to check if there is any records for this server in this file:

    <WAS_HOME>\profiles\Dmgr01\config\cells\<cell>\coregroups\<CoreGroup>\coregroup.xml

    //Ahmed
    no entries for the server that I want to delete :(
  • SystemAdmin
    SystemAdmin
    37422 Posts

    Re: Deleting server with WAS 7 console

    ‏2012-02-25T20:45:06Z  
    • asmoljo
    • ‏2012-02-13T13:21:00Z
    no entries for the server that I want to delete :(
    I have created profile in 6.1.41 and federated the node to WAS 7.0.17. When I tried to delete the server from the console I am getting the same error.

    I tried to remove the node from the cell and delete the server but still getting the error.

    Any suggestions. Thanks in advance
  • SystemAdmin
    SystemAdmin
    37422 Posts

    Re: Deleting server with WAS 7 console

    ‏2012-02-26T08:07:49Z  
    I have created profile in 6.1.41 and federated the node to WAS 7.0.17. When I tried to delete the server from the console I am getting the same error.

    I tried to remove the node from the cell and delete the server but still getting the error.

    Any suggestions. Thanks in advance
    Kindly make sure that you are using an administrative account while uninstalling this server!

    //Ahmed
  • IBMGary
    IBMGary
    1 Post

    Re: Deleting server with WAS 7 console

    ‏2012-04-20T10:54:52Z  
    An error occurred while deleting the server. ADMG0011E: An unexpected exception occurred com.ibm.websphere.management.exception.AdminException: Exception in removeTargetFromCUs().. Try to delete the server again. If the error persists, see the problem determination on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/."
  • SystemAdmin
    SystemAdmin
    37422 Posts

    Re: Deleting server with WAS 7 console

    ‏2012-08-23T08:12:16Z  
    I think that solution for this problem is fix 7.0.0.23. After applying fix, I had normally
    deleted server and nodes that I needed. :)

    Cheers!
  • SystemAdmin
    SystemAdmin
    37422 Posts

    Re: Deleting server with WAS 7 console

    ‏2013-01-08T19:47:26Z  
    I think that solution for this problem is fix 7.0.0.23. After applying fix, I had normally
    deleted server and nodes that I needed. :)

    Cheers!
    Thanks very much. it worked for me.
  • U3U5_Javier_Quintana
    1 Post

    Re: Deleting server with WAS 7 console

    ‏2015-04-20T11:18:19Z  
    I have created profile in 6.1.41 and federated the node to WAS 7.0.17. When I tried to delete the server from the console I am getting the same error.

    I tried to remove the node from the cell and delete the server but still getting the error.

    Any suggestions. Thanks in advance

    Hi

    I've deleted ServerEntrie registry from serverindex.xml servers located in

    PROFILE_PATH/config/cells/[cell_name]/nodes/[node_name] in node server where server was created

    and

    DMGR_PROFILE_PATH/config/cells/[cell_name]/nodes/[node_name] in dmgr server

    I've checked that server doesn't appear in systemapps.xml file located in paths above

    Furthermore, it's required to delete directory located in

    PROFILE_PATH/config/cells/[cell_name]/nodes/[node_name]/servers in node server where server was created

    with the name of the app server you want to delete.

    Updated on 2015-04-20T11:34:50Z at 2015-04-20T11:34:50Z by U3U5_Javier_Quintana