Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
4 replies Latest Post - ‏2011-09-22T12:39:03Z by kdemolder
kdemolder
kdemolder
3 Posts
ACCEPTED ANSWER

Pinned topic Settings the vbr.home property as a Java system property

‏2011-09-20T09:30:37Z |
Hi,

I'm using the Addressability Servlet included in the docs. I've deployed everything to a WAS server and it's up and running. The problem is when I want to retrieve metadata from an item it gives me a ERROR 500. When looking in the logs I found this

Caused by: com.venetica.vbr.client.ConfigurationException: COEC0001E: The content integration server cannot be initialized in direct mode because the vbr.home property is not set. Set the vbr.home property as a Java system property. The system vbr.home property must be set to a valid installation directory.  Check the configuration log 

for errors. at com.venetica.vbr.ejb.access.AccessServices.loadConfiguration(AccessServices.java:6745)


I've checked the run_sample.sh and the RMIBridge.sh. The VBR_HOME property is set correctly because the admin console of the ICI can be started. Do you need to set this property somewhere else?

Kind regards
Kris Demolder
Updated on 2011-09-22T12:39:03Z at 2011-09-22T12:39:03Z by kdemolder
  • SystemAdmin
    SystemAdmin
    254 Posts
    ACCEPTED ANSWER

    Re: Settings the vbr.home property as a Java system property

    ‏2011-09-20T23:06:48Z  in response to kdemolder
    Hi Kris,

    There are a few additional steps after deploying the addressibility servlet to WAS.

    (1) Add a definition for "vbr.home" Java system variable in the WAS Server.
    a) In WAS Administration console, navigate to: Servers > Application Servers > server1 > Java and Process Management > Process Definition > Java Virtual Machine > Custom Properties.
    (The exact path may vary depending on the WAS version.)

    b) Add a new property named "vbr.home"

    c) Set the value as the path to the installation directory of IBM Content Integrator.
    For example: C:\Program Files\IBM\ContentIntegrator

    (2) Define a Shared Library for "vbr.jar"
    a) In WAS Administration console, navigate to: Environment > Shared Libraries
    (The exact path may vary depending on the WAS version.)

    b) Create a new library named "vbrLib".

    c) Set the value of the Classpath field to the full path to the "vbr.jar" file.
    For example: C:\Program Files\IBM\ContentIntegrator\lib\vbr.jar
    (3) Add a reference to the Shared Library for the URL addressibility application.
    a) In WAS Administration console, navigate to: Enterprise Applications > urladdr_war > Shared Library references.
    (The exact path may vary depending on the WAS version and the name you chose for the URL application)

    b) Add a reference to the Shared Library "vbrLib" (created in Step 2)
    (4) Restart WAS.
    (5) Examples of how to access the URL:

    http://localhost:9081/urladdr/ITEM/?URN=vbr:/myRepo/0900006f80002dca/1.0/CONTENT

    http://localhost:9081/urladdr/NATIVECONTENT/PAGE/1/?URN=vbr:/myRepo/0900006f80002dca/1.0/CONTENT
    • kdemolder
      kdemolder
      3 Posts
      ACCEPTED ANSWER

      Re: Settings the vbr.home property as a Java system property

      ‏2011-09-21T07:12:30Z  in response to SystemAdmin
      Hi Darren,

      Thanks for the detailed information. I can now connect to my repository but now I get an classNotFound exception. This causes that I can't log into my repository. I checked my credentials via the Admin console and there everything works correctly. Would you have any idea what causes this? I've included a logging file of the error.

      Thanks
      Kris Demolder
      • SystemAdmin
        SystemAdmin
        254 Posts
        ACCEPTED ANSWER

        Re: Settings the vbr.home property as a Java system property

        ‏2011-09-21T22:08:22Z  in response to kdemolder
        Hi Kris,

        There's a few things I want to confirm regarding your setup.

        1) You mentioned you had checked your credentials in admin console. Do you mean that you performed a test connection to your Content Manager repo using IBM Content Integrator Administration Tool? If not, please do this first.

        2) Is the IBM Content Integrator installation you are using for the Administration Tool (from #1 above) on the same host machine as your WAS installation?

        3) Are you running the Content Manager connector as an RMIBridge (i.e. the RMI proxy server)? If you are not, please configure an RMIBridge for the Content Manager connector. Consult the IBM Content Integrator Information Center for more information about this setup.

        ---

        The reason these steps above are important is how the URL addressability application connects to the repository. When you configured your Content Manager connector through the IBM Content Integrator Administration Tool, it modified a "config.xml" in the "vbr.home" directory. The URL addressability application uses the "vbr.home" directory to locate this "config.xml" to find the connector configuration for Content Manager repo. If you configure the connector as an RMIBridge (RMI proxy server), you allow the URL addressability to connect to the repository through this RMI proxy server. Otherwise, the URL addressability application would also need the Content Manager connector JAR and the Content Manager client library JARs in its CLASSPATH.
        • kdemolder
          kdemolder
          3 Posts
          ACCEPTED ANSWER

          Re: Settings the vbr.home property as a Java system property

          ‏2011-09-22T12:39:03Z  in response to SystemAdmin
          Hi Darren,

          I was using a local connection. I've changed it and restarted the server. Apparently the WAS keeps the config.xml file in his memory.

          Thanks for all the help.
          Kris Demolder