Topic
  • 2 replies
  • Latest Post - ‏2011-09-21T21:34:57Z by SystemAdmin
SystemAdmin
SystemAdmin
203 Posts

Pinned topic Error when adding a System Resouce in the Warehouse Administration Console

‏2011-09-15T03:42:37Z |
Hi.

I'm using the Informix SQL Warehousing Tool.

I'm trying to add a System Resouce in the Warehouse Administration Console and I'm encountering the following error.

DBC0001
The system connot test the system resource informixdev. Reason Validation of System Resource failed. Reason: RES37626E: The system cannot validate system resource informixdev for the following reason Unknown host: informixdev

I have set the following in the 'Edit system resource' configuration:
Name: informixdev
Type: Plain Server
Host name: informixdev
Port number:22
User ID: my user
Password: ***********

The system resource is to be used by a Secure Command operator in a control flow. This operator is connecting via SSH to the server (informixdev) where the Informix database server is installed and is running a shell script.

Any insight on what I might be missing would be appreciated?
Updated on 2011-09-21T21:34:57Z at 2011-09-21T21:34:57Z by SystemAdmin
  • JP_Parkin
    JP_Parkin
    128 Posts

    Re: Error when adding a System Resouce in the Warehouse Administration Console

    ‏2011-09-21T14:53:26Z  
    Hi - this is a known limitation you are hitting. The validation logic for the system resources is always using FTP to validate whether the connection details and user/password information is correct. I expect that if you try running a flow that actually uses the resource for the Secure Command operation that it will run properly ( assuming the connection details are correct ).

    Best regards,
    JP
  • SystemAdmin
    SystemAdmin
    203 Posts

    Re: Error when adding a System Resouce in the Warehouse Administration Console

    ‏2011-09-21T21:34:57Z  
    • JP_Parkin
    • ‏2011-09-21T14:53:26Z
    Hi - this is a known limitation you are hitting. The validation logic for the system resources is always using FTP to validate whether the connection details and user/password information is correct. I expect that if you try running a flow that actually uses the resource for the Secure Command operation that it will run properly ( assuming the connection details are correct ).

    Best regards,
    JP
    Thanks JP.

    I proceeded with scheduling the warehouse application containing the secure command operator and using the system resource I had created as a plain server. The Warehouse Application ran successfully.

    Support have verified that this is known issue and the development team are looking to resolve it in the next major release.

    Regards, Brendon.