Topic
  • 4 replies
  • Latest Post - ‏2012-06-05T13:01:42Z by mburati
kellykerr
kellykerr
11 Posts

Pinned topic Unable to publish new project to WAS7

‏2011-09-14T17:30:18Z |
I have just installed WEF 7.01 on RAD 8.0 with Websphere 7, then created a WEF project with all the samples plus the new Mobile option selected. When I try to publish I get the following error:
Description Resource Path Location Type
An error occurred during publish: org/jdom/Element.detach()Lorg/jdom/Element; MobileApplicationWPF Unknown WebApp Publish Error

Any ideas on how to fix this error?

Thanks
Updated on 2012-06-05T13:01:42Z at 2012-06-05T13:01:42Z by mburati
  • kevintap
    kevintap
    111 Posts

    Re: Unable to publish new project to WAS7

    ‏2011-09-14T21:21:43Z  
    Hi Kelly,

    This error looks like a version mismatch involving jdom. WEF uses jdom internally to dynamically build various configuration files like web.xml and portlet.xml during the publish process. It looks like a version of jdom that WEF is not compatible with has already been loaded in the RAD environment. I'm not entirely sure where this incompatible version of jdom is being loaded from. Do you have a full stack trace of this exception available? If not, could you try running eclipse (RAD) using the -clean -debug -consolelog arguments to see if this provides more detail on the error.
  • kellykerr
    kellykerr
    11 Posts

    Re: Unable to publish new project to WAS7

    ‏2011-09-16T15:13:14Z  
    • kevintap
    • ‏2011-09-14T21:21:43Z
    Hi Kelly,

    This error looks like a version mismatch involving jdom. WEF uses jdom internally to dynamically build various configuration files like web.xml and portlet.xml during the publish process. It looks like a version of jdom that WEF is not compatible with has already been loaded in the RAD environment. I'm not entirely sure where this incompatible version of jdom is being loaded from. Do you have a full stack trace of this exception available? If not, could you try running eclipse (RAD) using the -clean -debug -consolelog arguments to see if this provides more detail on the error.
    Hi.. I have added the additional flags, restarted RAD and try to publish the application with the same error. I do not see any additional information in the .mete/log file for console. Any other suggestions? Thanks
  • SystemAdmin
    SystemAdmin
    1493 Posts

    Re: Unable to publish new project to WAS7

    ‏2012-06-05T04:16:43Z  
    • kellykerr
    • ‏2011-09-16T15:13:14Z
    Hi.. I have added the additional flags, restarted RAD and try to publish the application with the same error. I do not see any additional information in the .mete/log file for console. Any other suggestions? Thanks
    I am also getting the same error. I created a project using WEF 7.0.1. Then I create the WEF archive. Now when I am importing the .zip into a new project created in WEF 8.0, I am getting the error.

    Different versions w.r.t the New Project
    OS : Windows 7
    WAS 7.0
    WEF 8.0
  • mburati
    mburati
    425 Posts

    Re: Unable to publish new project to WAS7

    ‏2012-06-05T13:01:42Z  
    I am also getting the same error. I created a project using WEF 7.0.1. Then I create the WEF archive. Now when I am importing the .zip into a new project created in WEF 8.0, I am getting the error.

    Different versions w.r.t the New Project
    OS : Windows 7
    WAS 7.0
    WEF 8.0
    When you export a WEF archive, be sure to only include the artifacts that you created yourself, not artifacts that come with the version of WEF that you're using in the project, or when you import that archive into another WEF project, you may overwrite newer versions of WEF with older versions of jars, base models, Javascript, templates etc.

    ..mb1