• No replies
1 Post

Pinned topic J9 not running on Motorola MC75 device.

‏2011-09-01T20:17:41Z |
Good afternoon everyone. I'm having some trouble with WebSphere Everyplace Micro Environment (version 6.1.1) on a Motorola MC75 device running Windows Mobile 6.1. I purchased a copy of WEME through Handango (as told in the product's web page) and proceeded to install it on the device. Installation was "successful", J9 is recognized as an installed application and it's files were saved on the default location (+\Program Files\J9\PRO11+ directory) as indicated by the software's documentation.

After the installation, I tried running some Java sample applications provided by Motorola for the J9 JVM and wasn't able to run any single one of them. Every time I tried running and app I get an error message indicating that Windows can't open j9w.exe file. I checked if the file is in it's default location and it is there. Afterwards, I tried running that .exe file and nothing happens. Finally, I tried running the j9.exe file and I get a Java console with the following error message:

+JVMJ9VM011W Unable to load jclfoun10_23: (126) The specified module could not be found.
JVMEXE013E Internal VM error: Failed to create JVM+

After receiving that message I found something quite odd on the device. I opened the \Program Files\J9\PRO11\bin directory and noticed that, instead of having the jclfoun10_23 module, I have the jclfoun11_23 module (which I assume that it's newer).

So my questions are: Do I have to take additional installation steps besides those show in the documentation? Why is j9.exe searching for the jclfoun10_23 module when it came bundled with jclfoun11_23? Is there anyone who has been able to use the J9 JVM on a MC75?