IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 4 replies
  • Latest Post - ‏2011-09-07T09:36:31Z by Pharthiphan
PhaniMuraliKrishna
PhaniMuraliKrishna
4 Posts

Pinned topic Load Leveller settings

‏2011-08-28T17:55:49Z |
Hi,

When I submit my program by mentioning ConsumableMemory, it gives me with this note. Is this ok?
==========================
llsubmit: The "consumableCpus" value of keyword "resources" and the keyword "parallel_threads" are mutually exclusive. This value is ignored.
========================

Also, for a program which has very high I/O, MPI and intensive data sharing, below one is fine or are there any changes to be made/added?

======================================================
RSet: RSET_MCM_AFFINITY
Mcm Affinity Options: MCM_ACCUMULATE MCM_MEM_PREF MCM_SNI_NONE
Task Affinity: core(1)
Cpus Per Core: 0
Parallel Threads: 2
Env:
In: /dev/null
Dependency:
Data Stg Dependency:
Resources: ConsumableMemory(780.000 mb)
Node Resources:
Step Type: General Parallel
Node Usage: not_shared

Bulk Transfer: No
Step rCxt Blocks: 0
Adapter Requirement: (sn_all,MPI,US,shared,AVERAGE,instances=1,)
Step Cpus: 0
Step Virtual Memory: 0.000 mb
Step Real Memory: 195.000 gb
Step Large Page Mem: 0.000 mb
Cluster Option: none
========================================================

Regards,
Phani
Updated on 2011-09-07T09:36:31Z at 2011-09-07T09:36:31Z by Pharthiphan
  • PhaniMuraliKrishna
    PhaniMuraliKrishna
    4 Posts

    Re: Load Leveller settings

    ‏2011-09-06T05:45:11Z  
    I get the following error
    ERROR: 0031-250 task 83: Cputime limit exceeded


    Though I change the limit it does not change and says the following...

    llsubmit: The "WALL_CLOCK_LIMIT = 5000:15:00" hard limit of (18000900 seconds) is being adjusted down to administration file hard limit (864005 seconds).
    Can't I change the Wall Clock Limit according to the program?

    Phani
  • kmarthi
    kmarthi
    8 Posts

    Re: Load Leveller settings

    ‏2011-09-06T17:21:45Z  
    I get the following error
    ERROR: 0031-250 task 83: Cputime limit exceeded


    Though I change the limit it does not change and says the following...

    llsubmit: The "WALL_CLOCK_LIMIT = 5000:15:00" hard limit of (18000900 seconds) is being adjusted down to administration file hard limit (864005 seconds).
    Can't I change the Wall Clock Limit according to the program?

    Phani
    A cpu_limit has been set in the the LoadL_admin file by the administrator.
    Check the class stanzas for the cpu_limit keyword.
  • PhaniMuraliKrishna
    PhaniMuraliKrishna
    4 Posts

    Re: Load Leveller settings

    ‏2011-09-07T06:35:13Z  
    • kmarthi
    • ‏2011-09-06T17:21:45Z
    A cpu_limit has been set in the the LoadL_admin file by the administrator.
    Check the class stanzas for the cpu_limit keyword.
    The administrator has not set anything in the LoadL_admin file about cpu_limit.
    Though the administrator changed LoadL_admin and allocated cpu_limit = unlimited for my group, it has not been taken by the Load Leveller.

    I get the same comment
    "llsubmit: The "WALL_CLOCK_LIMIT = 5000:15:00" hard limit of (18000900 seconds) is being adjusted down to administration file hard limit (864005 seconds)."

    The program cannot run for more than 10 days!.

    Any help would be useful.
  • Pharthiphan
    Pharthiphan
    3 Posts

    Re: Load Leveller settings

    ‏2011-09-07T09:36:31Z  
    The administrator has not set anything in the LoadL_admin file about cpu_limit.
    Though the administrator changed LoadL_admin and allocated cpu_limit = unlimited for my group, it has not been taken by the Load Leveller.

    I get the same comment
    "llsubmit: The "WALL_CLOCK_LIMIT = 5000:15:00" hard limit of (18000900 seconds) is being adjusted down to administration file hard limit (864005 seconds)."

    The program cannot run for more than 10 days!.

    Any help would be useful.
    It is because user cannot exceed wall_clock_limit set on the Loadl_file!

    Regards,
    Pharthiphan