Topic
4 replies Latest Post - ‏2011-08-25T20:42:31Z by nista
nista
nista
3 Posts
ACCEPTED ANSWER

Pinned topic Error in Silent Installtion of WSRR 7.0 on Solaris

‏2011-08-25T14:18:28Z |
Hello All,

I am installing the WSRR7.0 for the first time on the solaris sparc 32-bit machine and with an Existing WAS ND ( 7.0.0.11)

But I anm running into the errors below

CRIMC2A9C925BE ERROR: The installation package 'WebSphere Service Registry and Repository Server' requires components supplied by other packages.
The required components may be supplied by the following installation packages:
Package: WebSphere Application Server 7.0.0.7
Package: com.ibm.ws.bspace 7.0.0.2
CRIMC2A9C925BE ERROR: The following additional components are required in installation location 'IBM WebSphere Application Server - ND_20110818_1452':
CRIMC2A9C925BE ERROR: The following additional components are required in installation location 'IBM WebSphere Application Server - ND_20110818_1452':
CRIMC2A9C925BE ERROR: In root installation context:
CRIMC2A9C925BE ERROR: Component "com.ibm.was.core.FP7007" required by component "com.ibm.wsrr.server.core" was not found
CRIMC2A9C925BE ERROR: Component "com.ibm.ws.bspace.pak.FP7002" required by component "com.ibm.wsrr.server.core" was not found
CRIMC2A9C925BE ERROR: In root installation context:
CRIMC2A9C925BE ERROR: Component "com.ibm.was.core.FP7007" required by component "com.ibm.wsrr.server.core" was not found
CRIMC2A9C925BE ERROR: Component "com.ibm.ws.bspace.pak.FP7002" required by component "com.ibm.wsrr.server.core" was not found

Can some one please guide me on this , please this is very important.
Updated on 2011-08-25T20:42:31Z at 2011-08-25T20:42:31Z by nista
  • RICKETTM
    RICKETTM
    2 Posts
    ACCEPTED ANSWER

    Re: Error in Silent Installtion of WSRR 7.0 on Solaris

    ‏2011-08-25T14:47:33Z  in response to nista
    Hi,

    Could you tell us exactly what steps you have performed to get to this point please?

    Also it would be useful if you could attach your response file.

    Thanks
  • nista
    nista
    3 Posts
    ACCEPTED ANSWER

    Re: Error in Silent Installtion of WSRR 7.0 on Solaris

    ‏2011-08-25T15:35:47Z  in response to nista
    Hello Rick,

    I have installed WAS 7.0.0.11 first and then updated my WSRR response files to install the IM and import my exisiting WAS into IM and install WSRR.

    Attached are my response files. Based on my google search on this error I am right now downgrading my WAS to 7.0.0.7 and applying a SDK fix pack , I would try again installing the WSRR after this and update it in the post.
    Attached are my response files , can you please look into it and let me know if I am missing some where.

    I can attach only 1 file , below is the information in my template
    _response.xml file


    <?xml version="1.0" encoding="UTF-8"?>
    <!-- begin_generated_IBM_copyright_prolog -->

    <!-- Licensed Materials - Property of IBM -->
    <!-- 5724-N72 5655-W17 -->
    <!-- (c) Copyright IBM Corp. 2009 All Rights Reserved -->
    <!-- US Government Users Restricted Rights - Use, duplication or -->
    <!-- disclosure restricted by GSA ADP Schedule Contract with -->
    <!-- IBM Corp. -->

    <!-- end_generated_IBM_copyright_prolog -->
    <agent-input clean='true' acceptLicense="true">

    <!-- ############
    If you do not have direct internet access from this machine then comment out the live WAS import repository location
    and change the searchForUpdates value to false.
    1. -->
    <!-- ######################################################################
    All repositories are listed here.
    A repository can be either a local location or a live repository.

    If you have a local repository, replace the appropriate value below.
    You do not need to remove the repository from this section if you decide not to install
    that product.
    ############################################################################-->
    <server>
    <!-- #################### IM Repository Location #####################-->
    <repository location='../IM/' temporary='true'/>
    <!-- ############### WAS Import Repository Location ##################-->
    <repository location="../WAS_SYNC/" />
    <!-- ################# WSRR Repository Location ###################-->
    <repository location="../repository/" />
    <!-- ################# WAS Import Repository Location (LIVE) ###################-->
    <!-- ### Comment this line out if you do not have direct internet access ### -->
    <!--<repository location="http://public.dhe.ibm.com/software/websphere/repositories/repository.config" /> -->
    </server>
    <!-- ### Change this value to false if you do not have direct internet access ### -->
    <preference value="false" name="com.ibm.cic.common.core.preferences.searchForUpdates" />

    <!-- ######################################################################
    This profile node defines where IBM Installation Manager (IM) is/or will be installed.

    If you want to modify where IM is installed modify both the
    installLocation and eclipseLocation values to specify the correct directory
    ############################################################################-->
    <profile kind='self' installLocation='/export/home/webspher/IBM/InstallationManager/eclipse' id='IBM Installation Manager'>
    <data key='eclipseLocation' value='/export/home/webspher/IBM/InstallationManager/eclipse'/>
    </profile>
    <!-- ######################################################################
    Modify to change the location of the eclipseCache (only if no cache has been created yet).
    ############################################################################-->
    <preference value="/export/home/webspher/IBM/InstallationManager/eclipseCache" name="com.ibm.cic.common.core.preferences.eclipseCache" />

    <!-- ######################################################################
    This installation node directs the IM installer to install IM.
    You do not need to edit this line. If IM is already installed, this instruction is skipped; if IM is not installed, this instruction installs it.
    ############################################################################-->
    <install>
    <offering features='agent_core,agent_jre' id='com.ibm.cic.agent'/>
    </install>
    <!-- ######################################################################
    This profile node defines where IBM WebSphere Application Server Network Deployment is installed

    Modify the installLocation and eclipseLocation values to the proper to specify the correct directory where WebSphere Application Server Network Deployment is installed.

    If the specified profile ID exists, you must also change the profile ID.

    If you would like to create the default profile uncomment and provide valid values for the ID and password properties below
    ############################################################################-->
    <profile installLocation='/export/home/webspher/IBM/WebSphere/AppServer' id='IBM WebSphere Application Server - ND_20110818_1452'>
    <data key='eclipseLocation' value='/export/home/webspher/IBM/WebSphere/AppServer'/>
    <data key="cic.selector.nl" value="en" />
    <data key="user.cic.imported,com.ibm.websphere.ND.70" value="WAS" />
    </profile>
    <!-- ######################################################################
    This command directs IM to import WebSphere Application Server Network Deployment, whose location is specified in the previous section, into IM.
    You do not need to modify this value.
    ############################################################################-->
    <import profile="IBM WebSphere Application Server - ND_20110818_1452" type="WAS" />
    <!-- ######################################################################
    This installation node directs the IM installer to install IM-based offering.

    The ID must match a valid offering ID of a repository that is specified in the first section of this file.
    The features value is optional. If it is ommitted, the default feature set is installed

    See the online documentation for more information about modifying
    this node.
    ############################################################################-->
    <install>
    <offering profile="IBM WebSphere Application Server - ND_20110818_1452" id="com.ibm.ws.bspace" />
    <offering profile="IBM WebSphere Application Server - ND_20110818_1452" id="com.ibm.wsrr.server" />
    </install>

    <!-- ######################################################################
    Do not modify the properties in this section.
    ############################################################################-->
    <preference value="30" name="com.ibm.cic.common.core.preferences.connectTimeout" />
    <preference value="30" name="com.ibm.cic.common.core.preferences.readTimeout" />
    <preference value="0" name="com.ibm.cic.common.core.preferences.downloadAutoRetryCount" />
    <preference value="true" name="offering.service.repositories.areUsed" />
    <preference value="false" name="com.ibm.cic.common.core.preferences.ssl.nonsecureMode" />
    <preference value="false" name="com.ibm.cic.common.core.preferences.http.disablePreemptiveAuthentication" />
    <preference value="true" name="com.ibm.cic.common.core.preferences.preserveDownloadedArtifacts" />
    <preference value="false" name="PassportAdvantageIsEnabled" />
    <preference value="true" name="com.ibm.cic.common.core.preferences.import.enabled" />
    </agent-input>



    Thanks In Advance

    Nish
  • RICKETTM
    RICKETTM
    2 Posts
    ACCEPTED ANSWER

    Re: Error in Silent Installtion of WSRR 7.0 on Solaris

    ‏2011-08-25T16:07:48Z  in response to nista
    Thanks for the info, I think that downgrading to 7.0.0.7 and applying the appropriate SDK pak should solve your issue.
    Please let us know either way.

    Out of interest, is there any reason for using WSRR 7.0 rather than 7.5?

    Also, I see you have commented out this line in your response file:
    <repository location="http://public.dhe.ibm.com/software/websphere/repositories/repository.config" />
    If your machine has a connection to the internet, adding this line might help as it would give you access to the WAS repositories for newer fixpacks.
    • nista
      nista
      3 Posts
      ACCEPTED ANSWER

      Re: Error in Silent Installtion of WSRR 7.0 on Solaris

      ‏2011-08-25T20:42:31Z  in response to RICKETTM
      Hello Rick,

      Thanks for your response , this issue is fixed now by downgrading my WAS to 7.0.0.7 and applying an appropraite SDK fix pack.

      I have also successfully augumented my wsrr profile to the dmgr profile and gave the dbscrips to the DBA , keeping my fingers crossed !!!

      I am just implementing a POC environment but I am definately planning to go for WSRR 7.5 when we move ahead after this POC. I do not think I can by-pass the firewall to get to the internt , the proxy should be adjusted and for which UNIX SA might not accept.

      Kindly let me know if you have any specific reasons to suggest WSRR 7.5?
      Thanks Again For your help.

      Thanks,
      Nish