Topic
  • 5 replies
  • Latest Post - ‏2015-07-16T22:52:54Z by KC_Mike
SystemAdmin
SystemAdmin
15496 Posts

Pinned topic Report Studio error message - 404 - Not Found

‏2011-08-24T18:52:22Z |
404 - Not Found
URL: cchl/res/promptLocale_en-US.xml

Response Text:
Error 404: SRVE0190E: File not found: /pat/cchl/res/promptLocale_en-US.xml
When trying to launch Report Studio for any package - I am getting the above error. I am now not able to get into Report Studio.

I have both the dispatcher and the gateway loaded on different instances of portal server. This has only happened recently and was fine.

I checked the cognos log file - and I only see
WebContainer : 5 CCS 4707 1 Audit.rds.CCS rest reportDataService Failure <messages><message><messageString>RDS-ERR-1012 Report Data Service was unable to discover the content providers.</messageString></message> <trace>com.cognos.ccs.exceptions.CCSGeneralException: DISCOVER_ERROR at com.cognos.ccs.content.ContentProvider.getProvider(Unknown Source) at com.cognos.ccs.service.CommandSession.getProviderFromID(Unknown Source) at com.cognos.ccs.service.command.AAsyncCommand.performRestAction(Unknown Source) at

In the dispatcher log file I am getting alot of these error messages :Analysis Engine using data base: C:\IBM\WebSphere\AppServer\profiles\CognosAppsrv01\properties\logbr\ffdc\adv\ffdcdb.xml
8/24/11 10:57:57:168 BST 0000002c FfdcProvider W com.ibm.ws.ffdc.impl.FfdcProvider logIncident FFDC1003I: FFDC Incident emitted on C:\IBM\WebSphere\AppServer\profiles\CognosAppsrv01\logs\ffdc\server1_32373237_11.08.24_10.57.56.7931058658852095347656.txt com.ibm.ws.http.channel.inbound.impl.HttpInboundServiceContextImpl.finishResponseMessage 1010
8/24/11 11:58:00:168 BST 0000003e HttpMethodDir I org.apache.commons.httpclient.HttpMethodDirector executeWithRetry I/O exception (java.net.ConnectException) caught when processing request: Connection refused: connect
8/24/11 11:58:00:293 BST 0000003e HttpMethodDir I org.apache.commons.httpclient.HttpMethodDirector executeWithRetry Retrying request
8/24/11 11:58:01:262 BST 0000003e HttpMethodDir I org.apache.commons.httpclient.HttpMethodDirector executeWithRetry I/O exception (java.net.ConnectException) caught when processing request: Connection refused: connect
8/24/11 11:58:01:293 BST 0000003e HttpMethodDir I org.apache.commons.httpclient.HttpMethodDirector executeWithRetry Retrying request

Any advice
Updated on 2013-01-15T08:25:31Z at 2013-01-15T08:25:31Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    15496 Posts

    Re: Report Studio error message - 404 - Not Found

    ‏2011-08-25T11:29:21Z  
    I resolved this problem by reinstalling Cognos and re-deploying the EAR files :)
  • SystemAdmin
    SystemAdmin
    15496 Posts

    Re: Report Studio error message - 404 - Not Found

    ‏2013-01-15T08:25:31Z  
    I resolved this problem by reinstalling Cognos and re-deploying the EAR files :)
    I have same problem when I launch Report Studio from IOC 1.5. How can I resolve this error?
  • chao_chao
    chao_chao
    1 Post

    Re: Report Studio error message - 404 - Not Found

    ‏2014-03-27T07:25:27Z  
    I have same problem when I launch Report Studio from IOC 1.5. How can I resolve this error?

    For anyone who also met the problem: Change your browser language from en_us to en, that should solve the problem

     

  • ZaytsevAndrey
    ZaytsevAndrey
    2 Posts

    Re: Report Studio error message - 404 - Not Found

    ‏2014-12-21T12:20:50Z  
    • chao_chao
    • ‏2014-03-27T07:25:27Z

    For anyone who also met the problem: Change your browser language from en_us to en, that should solve the problem

     

    The same problem trying to run Report Studio (Cognos 10.2 from IOC 1.6). This problem occurs on one machine under Win7. On another machine (Windows XP) it starts.

    Changing the browser language does not help, I have the same error

    404 - Not Found
    URL: cchl/res/promptLocale_ru-RU.xml

    Response Text:
    Error 404: java.io.FileNotFoundException: SRVE0190E: File not found: /pat/cchl/res/promptLocale_ru-RU.xml
     

    I have not ru-RU in browser at all. If I change language in windows regional settings, the error changes

    404 - Not Found
    URL: cchl/res/promptLocale_en-US.xml

    Response Text:
    Error 404: java.io.FileNotFoundException: SRVE0190E: File not found: /pat/cchl/res/promptLocale_en-US.xml
     

    I have files like promptLocale_en-us.xml in my filesystem. So the case of locale is incorrect (en-US vs en-us).

    But how can I take the settings from browser and not from windows?

  • KC_Mike
    KC_Mike
    1 Post

    Re: Report Studio error message - 404 - Not Found

    ‏2015-07-16T22:52:54Z  

    I fixed this problem on my server by finding the file '/pat/cchl/res/promptLocale_en-us.xml' and copying it to '/pat/cchl/res/promptLocale_en-US.xml'  -- lower case us to upper case US.

    Updated on 2015-07-16T22:55:39Z at 2015-07-16T22:55:39Z by KC_Mike