Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
No replies
SystemAdmin
SystemAdmin
800 Posts
ACCEPTED ANSWER

Pinned topic Configuring EIF Connector using TDI

‏2011-08-18T21:21:36Z |
Hi all,
Here's the situation. I have a server firing off EIF events and I would like to integrate them into a Tivoli Directory Integrator assembly line. I am using the included EIF Connector, however there is not very much guidance as to its use in the docs. All I want it to do is receive events on the standard port (5529), I don't need any bi-directionality for this workflow. However, the config file for the connector is very confusing (at least to me), and no matter how I set it up, even after running and receiving a "EIFConnector CTGDJK106I Waiting for an event to occur..." message, netstat -a shows nothing listening on that port. I have specified Socket_ChannelPort=5529, but that doesn't seem to be doing anything.

With tracing turned on, the relevant part of the trace file shows this:
"2011.08.18 17:13:45.252 com.tivoli.tec.event_delivery.TECAgent initTECAgent
Using RECEIVER_MODE

2011.08.18 17:13:45.252 com.tivoli.tec.event_delivery.transport.TransportComponentFactory createReceiver
Create SOCKET Receiver

2011.08.18 17:13:45.252 com.tivoli.tec.event_delivery.transport.socket.ReceiverSocketTransport init
Using ReadRetryInterval = 120 seconds

2011.08.18 17:13:45.252 com.tivoli.tec.event_delivery.transport.socket.ReceiverSocketTransport init
Using CheckClosed = 10

2011.08.18 17:13:45.252 com.tivoli.tec.event_delivery.transport.socket.ReceiverSocketTransport init
Using ReceiveEventMaxSize = 1000000

2011.08.18 17:13:45.470 com.tivoli.tec.event_delivery.TECAgent initTECAgent
Receiver created"

No mention of a port, that seems odd.

Any insights or ideas?

-Thanks