Topic
  • 3 replies
  • Latest Post - ‏2011-09-23T21:13:58Z by SystemAdmin
glsander@us.ibm.com
glsander@us.ibm.com
1 Post

Pinned topic Migration Toolkit Installation Error

‏2011-08-17T18:44:59Z |
Customer is having trouble installing Migration Toolkit, any help would be appreciated. >>>

I'm running Eclipse Indigo which is JEE IDE version 1.4, and Eclipse Platform 3.7. I've downloaded the migration tool:
Application_Migration_Tool_JBoss_AS_to_WebSphere_v3.0.0.zip

And following the install instructions through Eclipse Help/Install New Software/Add and specifying the zip above, I get the following errors:

Cannot complete the install because one or more required items could not be found.
Software being installed: Application Migration Tool - JBoss AS to WebSphere 3.0.0.201105031453 (com.ibm.ws.appconversion_feature.jboss.feature.group 3.0.0.201105031453)
Missing requirement: Rational Software Analyzer Framework Core 7.1.200.201105031453 (com.ibm.rsaz.analysis.core 7.1.200.201105031453)
requires 'bundle com.ibm.icu [3.4.4,4.2.2)' but it could not be found
Cannot satisfy dependency:
From: Rational Software Analyzer User Interface Core 7.1.200.201105031453 (com.ibm.rsaz.analysis.core.ui 7.1.200.201105031453)
To: bundle com.ibm.rsaz.analysis.core [7.0.0,8.0.0)
Cannot satisfy dependency:
From: Rational Code Analyst Core Services Feature 7.0.1.201105031453 (com.ibm.rsaz.analysis_feature.feature.group 7.0.1.201105031453)
To: com.ibm.rsaz.analysis.core.ui http://7.1.200.201105031453
Cannot satisfy dependency:
From: Application Migration Tool - Common Feature 3.0.0.201105031453 (com.ibm.ws.appconversion_feature.common.feature.group 3.0.0.201105031453)
To: com.ibm.rsaz.analysis_feature.feature.group http://7.0.1.201105031453
Cannot satisfy dependency:
From: Application Migration Tool - JBoss AS to WebSphere 3.0.0.201105031453 (com.ibm.ws.appconversion_feature.jboss.feature.group 3.0.0.201105031453)
To: com.ibm.ws.appconversion_feature.common.feature.group 3.0.0
Updated on 2011-09-23T21:13:58Z at 2011-09-23T21:13:58Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    102 Posts

    Re: Migration Toolkit Installation Error

    ‏2011-08-17T20:06:49Z  
    The toolkit is not supported on Eclipse 3.7.
  • SystemAdmin
    SystemAdmin
    102 Posts

    Re: Migration Toolkit Installation Error

    ‏2011-09-23T03:43:20Z  
    The toolkit is not supported on Eclipse 3.7.
    Is there a timeline for when Eclipse 3.7 (Indigo) will be supported?
  • SystemAdmin
    SystemAdmin
    102 Posts

    Re: Migration Toolkit Installation Error

    ‏2011-09-23T21:13:58Z  
    Is there a timeline for when Eclipse 3.7 (Indigo) will be supported?
    We have a maintenance release currently scheduled for the fourth quarter of this year. The current plan is to introduce support for Eclipse 3.7 then.