Topic
  • 2 replies
  • Latest Post - ‏2011-08-29T10:12:12Z by SystemAdmin
RikuJ.K.
RikuJ.K.
1 Post

Pinned topic Are there any updates for SolidDB's Hibernate Dialect class?

‏2011-07-27T10:55:32Z |
Hi,
I use Hibernate framework for mapping SolidDB tables to Java objects, and vice versa. Now, I had to update the Hibernate from 3.2.6 to 3.6.1. Unfortunately after this, the SolidDBDialect, that I uploaded from IBM's website https://www-304.ibm.com/support/docview.wss?uid=swg21440246, doesn't work anymore. I get a java.lang.NoSuchFieldError when the SolidDBDialect is initialized. It says on the website that the dialect class is tested with Hibernate 3.5.1. Are there any plans to update the dialect class to be compatible with newer Hibernate versions? Is there a workaround?
Updated on 2011-08-29T10:12:12Z at 2011-08-29T10:12:12Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    115 Posts

    Re: Are there any updates for SolidDB's Hibernate Dialect class?

    ‏2011-08-26T08:22:11Z  
    We have an upgraded version of SolidDBDialec for Hibernate 3.6.1. It will be shortly published in a support TechNote.

    The information about it will appear here.

    --Antoni Wolski
    (solidDB)
  • SystemAdmin
    SystemAdmin
    115 Posts

    Re: Are there any updates for SolidDB's Hibernate Dialect class?

    ‏2011-08-29T10:12:12Z  
    We have an upgraded version of SolidDBDialec for Hibernate 3.6.1. It will be shortly published in a support TechNote.

    The information about it will appear here.

    --Antoni Wolski
    (solidDB)
    The new SolidDBDialect for Hibernate 3.6.1 is published here:

    https://www-304.ibm.com/support/docview.wss?uid=swg21440246
    --Antoni
    (solidDB)