• 1 reply
  • Latest Post - ‏2011-08-02T00:15:59Z by JPerry
11 Posts

Pinned topic Programmatic Rules Validation

‏2011-07-21T15:57:38Z |
Using the vce.validate ant task, I find that I am not able to control what rules are executed. I tried removing .rules files from the plugins/ directory, but the rules in those files still execute. How can I control execution of rules in my ant task?
Updated on 2011-08-02T00:15:59Z at 2011-08-02T00:15:59Z by JPerry
  • JPerry
    11 Posts

    Re: Programmatic Rules Validation

    Problem solved: place the rules file(s) in <VCE_HOME>/vce/startup directory to enable them; in fact this is documented in "VCEHeadlessRuntimeReadme.txt".

    To disable the default .rules I had to rename the files (in vce/plugins/ directory); there might be another way. I tried commenting them out in plugin.xml but they still executed. But this workaround is ok for me.