Topic
6 replies Latest Post - ‏2011-08-12T10:49:23Z by HAL-9000
HAL-9000
HAL-9000
6 Posts
ACCEPTED ANSWER

Pinned topic TBSM 4.2.1 installation failure - URGENT

‏2011-07-19T11:14:34Z |
Hi Everyone,

I do hope that you can help me. I am in the process of getting TBSM 4.2.1 installed onto several servers here.
I have tried both the gui installation and also the console installation. both fail.

we are using AIX.

in the console installation i get:

Install Complete


The installation failed at step: Data Server Installation.

For additional information, please review the log files stored in the archive:
/opt/IBM/TBSM/tip/logs.zip
ive attached the re;evant log files from te above .zip
we have tried this on several differnt lpars and get the same thing.
Updated on 2011-08-12T10:49:23Z at 2011-08-12T10:49:23Z by HAL-9000
  • HAL-9000
    HAL-9000
    6 Posts
    ACCEPTED ANSWER

    Re: TBSM 4.2.1 installation failure - URGENT

    ‏2011-07-21T09:36:57Z  in response to HAL-9000
    Hi All,

    finally figuired out what that error is :

    sys-package-mgr: processing new jar, '/opt/IBM/TBSM/tip/lib/tcljava.jar'
    org.eclipse.emf.ecore.resource.Resource$IOWrappedException: bold Value '16311 ' is not legal. bold (file:///opt/IBM/TBSM/tip/bin/serverindex.xml, 32, 79)
    at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.handleErrors(XMLLoadImpl.java:80)
    at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.load(XMLLoadImpl.java:189)
    at org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doLoad(XMLResourceImpl.java:179)
    that number was taken from the /mnt/Samples/modofied_port_value_file.txt

    #Create the required WAS port properties for TIP
    WC_defaulthost=16310
    WC_adminhost=16315
    WC_defaulthost_secure=16311 *bold*< there is a tabbed space here or equivalent bold
    WC_adminhost_secure=16316
    BOOTSTRAP_ADDRESS=16312
    SOAP_CONNECTOR_ADDRESS=16313
    SAS_SSL_SERVERAUTH_LISTENER_ADDRESS=16321
    CSIV2_SSL_SERVERAUTH_LISTENER_ADDRESS=16323
    CSIV2_SSL_MUTUALAUTH_LISTENER_ADDRESS=16322
    ORB_LISTENER_ADDRESS=16320
    DCS_UNICAST_ADDRESS=16318
    the space had some hex characters in it that for some reason were not visible in a normal editor? however ive remvoed them and have removed the
    old DE and am currently waiting fo rthis installation to complete...
    • HAL-9000
      HAL-9000
      6 Posts
      ACCEPTED ANSWER

      Re: TBSM 4.2.1 installation failure - URGENT

      ‏2011-07-22T09:55:33Z  in response to HAL-9000
      INstallation was successful - although i did run into a few hiccups on the way which were to do with removal of certain files and also killing of 2 processes, here is a rough guid eon what i had to do to make the install disappear:

      Removal of the DE

      cd /opt/IBM/TBSM

      rm -r license
      rm -r tbsm
      rm -r tip
      rm -r _uninst

      DO NOT DELETE THE lost+found folder

      do not try to delete the /opt/IBM/TBSM folder this is a mount point
      cd /home/tbsm/.acsi_tbsm

      set environment: . ./setenv.sh

      cd bin

      si_inst.sh -r -f
      ACUINI0036W Unable to remove /home/tbsm/.acsi_tbsm/bin. It may be in use. Please remove it manually.
      ACUINI0004I UnInstallation completed successfully!
      bash-3.00$ pwd
      /home/tbsm/.acsi_tbsm/bin
      bash-3.00$
      cd ../..

      remove .asci_tbsm folder <----- this is a hidden folder

      rm -r .acsi.tbsm
      ps -ef | grep ibm

      kill process
      ps -ef | grep postgr
      kill process

      cd /tmp

      rm anything created by tbsm user
      ======
      no onward to installing FP3
  • HAL-9000
    HAL-9000
    6 Posts
    ACCEPTED ANSWER

    Re: TBSM 4.2.1 installation failure - URGENT

    ‏2011-07-22T15:25:12Z  in response to HAL-9000
    The fix pack failed ot install for some unknown reason it hung
    right after asking me for the tipadmin password, the log shows that it was successful in verifying the user and password, from 1145am until just over 14:00 it just sat there without any activity, nmon shows 0.1 cpu usage no disk usage no i/o so i had to kill it all off:

    ADMU0508I: The Application Server "server1" is STARTED
    (from com.ibm.tivoli.tip.install.common.util.WASUtilFP.validateCredentials)
    Fri Jul 22 11:45:35.653 BST 2011 : INFO : User name and password validated. (from com.ibm.tivoli.tip.install.common.util.WASUtilFP.validateCredentials)
    Fri Jul 22 11:45:35.655 BST 2011 : FINER : RETURN (from com.ibm.tivoli.tip.install.common.util.WASUtilFP.validateCredentials)
    Fri Jul 22 11:45:35.656 BST 2011 : INFO : validateWASCredential, result=true (from com.ibm.tivoli.tip.install.common.ia.WASCredentialValidationReuseUpgradeAction.validateWASCredential)
    Fri Jul 22 11:45:35.658 BST 2011 : FINER : RETURN (from com.ibm.tivoli.tip.install.common.ia.WASCredentialValidationReuseUpgradeAction.validateWASCredential)
    Fri Jul 22 11:45:35.658 BST 2011 : FINER : RETURN com.zerog.ia.api.pub.InstallerProxy@78a078a0 (from com.ibm.tivoli.tip.install.common.ia.WASCredentialValidationReuseUpgradeAction.install)
    Fri Jul 22 11:45:35.662 BST 2011 : FINER : ENTRY com.zerog.ia.api.pub.InstallerProxy@351a351a (from com.ibm.netcool.wizard.TBSMWASCredentialValidationReuseUpgradeAction.install)
    Fri Jul 22 11:45:35.662 BST 2011 : INFO : Checking for WAS credentials for Reuse and Upgrade (from com.ibm.netcool.wizard.TBSMWASCredentialValidationReuseUpgradeAction.install)
    Fri Jul 22 11:45:35.664 BST 2011 : FINER : ENTRY (from com.ibm.netcool.wizard.TBSMWASCredentialValidationReuseUpgradeAction.validateWASCredential)
    Fri Jul 22 11:45:35.664 BST 2011 : INFO : IAGLOBAL_installLocation=/opt/IBM/TBSM/tip (from com.ibm.netcool.wizard.TBSMWASCredentialValidationReuseUpgradeAction.validateWASCredential)
    Fri Jul 22 11:45:35.666 BST 2011 : INFO : IAGLOBAL_WASServer=server1 (from com.ibm.netcool.wizard.TBSMWASCredentialValidationReuseUpgradeAction.validateWASCredential)
    Fri Jul 22 11:45:35.668 BST 2011 : INFO : IAGLOBAL_WASUserID=tipadmin (from com.ibm.netcool.wizard.TBSMWASCredentialValidationReuseUpgradeAction.validateWASCredential)
    Fri Jul 22 11:45:35.669 BST 2011 : FINER : ENTRY (from com.ibm.tivoli.tip.install.common.util.WASUtilFP.validateCredentials)
    Fri Jul 22 11:45:35.671 BST 2011 : STDOUT : Building Status Cmd=/opt/IBM/TBSM/tip/profiles/TBSMProfile/bin/serverStatus.sh

    now when i try to start the server up i get:
    $ tbsm_suite.sh start
    ADMU0116I: Tool information is being logged in file
    /opt/IBM/TBSM/tip/profiles/TBSMProfile/logs/server1/startServer.log
    ADMU0128I: Starting tool with the TBSMProfile profile
    ADMU3100I: Reading configuration for server: server1
    ADMU3200I: Server launched. Waiting for initialization status.
    ADMU3000I: Server server1 open for e-business; process id is 6946998
    ADMU0116I: Tool information is being logged in file
    /opt/IBM/TBSM/tip/profiles/TIPProfile/logs/server1/startServer.log
    ADMU0128I: Starting tool with the TIPProfile profile
    ADMU3100I: Reading configuration for server: server1
    ADMU3028I: Conflict detected on port 16313. Likely causes: a) An instance of
    the server server1 is already running b) some other process is
    using port 16313
    ADMU3027E: An instance of the server may already be running: server1
    ADMU0111E: Program exiting with error:
    com.ibm.websphere.management.exception.AdminException: ADMU3027E: An
    instance of the server may already be running: server1
    ADMU1211I: To obtain a full trace of the failure, use the -trace option.
    ADMU0211I: Error details may be seen in the file:
    /opt/IBM/TBSM/tip/profiles/TIPProfile/logs/server1/startServer.log

    netstat shows that neither ports are in use so what now??
    • devil786
      devil786
      126 Posts
      ACCEPTED ANSWER

      Re: TBSM 4.2.1 installation failure - URGENT

      ‏2011-07-25T18:42:11Z  in response to HAL-9000
      Try after restarting your machine once.
      • HAL-9000
        HAL-9000
        6 Posts
        ACCEPTED ANSWER

        Re: TBSM 4.2.1 installation failure - URGENT

        ‏2011-08-12T10:26:25Z  in response to devil786
        Hi,

        apologies for the late response, i had the lpar bounced and before trying again carried out netstat -Aan |grep 16310 and 16313 just to make
        sure they are not in use.

        i then attempted to start tbsm

        from
        /opt/IBM/TBSM/tbsm/bin/

        using
        ./tbsm_suite.sh start

        i get the same error indicating "Conflict detected on port 16313. Likely causes: a) An instance of the server server1 is already running b) some other process is using port 16313" and then it stops.

        any ideas?
        • HAL-9000
          HAL-9000
          6 Posts
          ACCEPTED ANSWER

          Re: TBSM 4.2.1 installation failure - URGENT

          ‏2011-08-12T10:49:23Z  in response to HAL-9000
          I found an old pid file in /opt/IBM/TBSM/tip/profiles/TIPProfile/logs/server1
          and removed this, after i shutdown tbsm / postgre

          i tried to start it back up again however it still fails with
          the same error.

          can anyone point out any other files that are created dynamically as a result of starting up tbsm, that might not hav ebeen removed properly?