Topic
4 replies Latest Post - ‏2012-06-04T08:05:53Z by JeffYin
SystemAdmin
SystemAdmin
238 Posts
ACCEPTED ANSWER

Pinned topic About SAP Connector module on a virtual appliance(6.0.0.2)

‏2011-07-07T07:21:13Z |
Hi All,

I created an orchestration that connects with SAP(use BAPI) and confirmed it worked well on the Studio(with Jco2.1.8) .

But I have struggled to operate on a virtual appliance(6.0.0.2).
I tried the following JCo version, but it all failed.

2.1.8 32bit intel
2.1.8 64bit
2.1.10 32bit intel
2.1.10 64bit intel

I understand that Cast Iron's official support version in Studio is Jco 2.1.6 by it's manual.
(However, I heard There is only available 2.1.10 in in the SAP marketplace.)
Here is the question.

1.Could you tell me the version of JCo proven.(on virtutal appliance 6.0.0.2)
2.Do you know JCo2.1.6 available where supported by Cast Iron available?

Thanks in advance.
Updated on 2012-06-04T08:05:53Z at 2012-06-04T08:05:53Z by JeffYin
  • SystemAdmin
    SystemAdmin
    238 Posts
    ACCEPTED ANSWER

    Re: About SAP Connector module on a virtual appliance(6.0.0.2)

    ‏2011-07-08T05:06:55Z  in response to SystemAdmin
    The problem is resolved. :-)
    SAP JCo version 2.1.8 is worked well.

    It was my mistake.
    I thought that sapidocjco.jar and sapidoc.jar are not necessary not to use the IDOC activities.
  • PrabhuAppirio
    PrabhuAppirio
    2 Posts
    ACCEPTED ANSWER

    Re: About SAP Connector module on a virtual appliance(6.0.0.2)

    ‏2011-08-15T16:48:49Z  in response to SystemAdmin
    I have a similar issue, we are able to successfully connect to SAP from studio (Jco 2.1.0) but Appliance is not able to connect to SAP.

    I have uploaded the same set of libraries which am using in the Studio.

    sapjco.jar
    sapidoc.jar
    sapidocjco.jar
    librfc32.dll
    sapjcorfc.dll

    Error message is pretty generic - Exception while activating the sap. The exception is because the sap libraries are not installed. Exception is

    Any inputs on this is highly appreciated.
    • SystemAdmin
      SystemAdmin
      238 Posts
      ACCEPTED ANSWER

      Re: About SAP Connector module on a virtual appliance(6.0.0.2)

      ‏2011-08-15T23:55:03Z  in response to PrabhuAppirio
      Hello PrabhuAppirio, I guess it's a platform issue.

      It is necessary to place the module for Linux(32bit) instead the windows module.
      .
      Specifically speaking, the following modules.

      librfccm.so
      libsapjcorfc.so
  • JeffYin
    JeffYin
    2 Posts
    ACCEPTED ANSWER

    Re: About SAP Connector module on a virtual appliance(6.0.0.2)

    ‏2012-06-04T08:05:53Z  in response to SystemAdmin
    Hello, I'm using 6.1.0.0
    I can connect to SAP from studio (using sapjco3.jar, sapjco3.dll and sapidoc3.jar), but I cannot connect from appliance (using sapjco3.jar, libsapjco3.so and sapidoc3.jar).
    I tested with both 32bit and 64bit version of intel compatible version of libs.
    Any inputs on this is highly appreciated