Topic
  • 2 replies
  • Latest Post - ‏2011-06-23T15:20:39Z by masterzorag
masterzorag
masterzorag
25 Posts

Pinned topic 0.2 demos, build failed

‏2011-06-23T10:35:33Z |
Fedora12 on PS3, xlc installed, see attachment;

./perlin -a
Compiling and Creating kernel...
clBuildProgram failed: (CL_BUILD_PROGRAM_FAILURE)
spu-xlcl: 1501-221 (S) cannot exec program /opt/ibmcmp/xlc/opencl/0.2/exe/ipa - No such file or directory
ERROR: build failed

./perlin -c
Compiling and Creating kernel...
clBuildProgram failed: (CL_BUILD_PROGRAM_FAILURE)
ppu-xlcl: 1501-221 (S) cannot exec program /opt/ibmcmp/xlc/opencl/0.2/exe/ipa - No such file or directory
ERROR: build failed

What's no such file! Here:
ls -lnh /opt/ibmcmp/xlc/opencl/0.2/exe/
total 60M
-rwxr-xr-x 1 0 0 17K Jun 16 2010 bolt
-rwxr-xr-x 1 0 0 194K Apr 14 2010 dis
-rwxr-xr-x 1 0 0 40M Jun 15 2010 ipa
-rw-r--r-- 1 0 0 1.3K Jun 16 2010 token.pl
-rwxr-xr-x 1 0 0 17M Jun 9 2010 xlCcode
-rwxr-xr-x 1 0 0 3.9M Jun 7 2010 xlcentry

ipa is there, what's this!
I've reinstalled a fresh Fedora12, I've got 0.2 demos running in previous environment;
also upgraded to 0.3, but now I'm freezed
Updated on 2011-06-23T15:20:39Z at 2011-06-23T15:20:39Z by masterzorag
  • SystemAdmin
    SystemAdmin
    131 Posts

    Re: 0.2 demos, build failed

    ‏2011-06-23T13:37:47Z  
    masterzorag:

    I'm not sure what the problem is. Do you want to run with version 0.2 or version 0.3? A list of installed packages would be helpful. Can you attach the output from "rpm -qa | grep -i opencl"?
  • masterzorag
    masterzorag
    25 Posts

    Re: 0.2 demos, build failed

    ‏2011-06-23T15:20:39Z  
    masterzorag:

    I'm not sure what the problem is. Do you want to run with version 0.2 or version 0.3? A list of installed packages would be helpful. Can you attach the output from "rpm -qa | grep -i opencl"?
    rpm -qa | grep -i opencl
    OpenCL-0.2-0.ppc
    OpenCL-cell-devel-0.2-0.ppc
    opencl-xlc-man-0.2.0.0-100616a.ppc64
    opencl-xlc-help-0.2.0.0-100616a.ppc64
    opencl-cell-xlc-lib-0.2.0.0-100616a.ppc64
    opencl-xlc-rte-lnk-0.2.0.0-100616a.ppc64
    OpenCL-devel-0.2-0.ppc
    OpenCL-cell-0.2-0.ppc
    opencl-xlc-cmp-0.2.0.0-100616a.ppc64
    opencl-xlc-rte-0.2.0.0-100616a.ppc64
    opencl-xlc-lib-0.2.0.0-100616a.ppc64
    opencl-cell-xlc-cmp-0.2.0.0-100616a.ppc64

    ldd /opt/ibmcmp/xlc/opencl/0.2/exe/ipa
    linux-vdso64.so.1 => (0x00000fff89910000)
    libdl.so.2 => /lib64/libdl.so.2 (0x00000fff898c0000)
    libpthread.so.0 => /lib64/libpthread.so.0 (0x00000fff8988a000)
    libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00000fff896f4000)
    libm.so.6 => /lib64/libm.so.6 (0x00000fff895f9000)
    libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00000fff895d2000)
    libc.so.6 => /lib64/libc.so.6 (0x00000fff893ee000)
    /lib64/ld64.so.1 (0x00000fff898e1000)

    I'm running a 32bit system, was missing libstdc++.ppc64;
    I've forced some ppc64 rpm, like: rpm -ivh --force RPM --nodeps
    many lib over lib64 conflicts to resolve, but I'm building fine and running demos now;
    dirty installation.