Topic
  • 5 replies
  • Latest Post - ‏2012-09-12T13:57:14Z by SystemAdmin
SystemAdmin
SystemAdmin
1250 Posts

Pinned topic Salesfrce.com Endpoint

‏2010-08-04T20:44:35Z |
I have an endpoint to Salesforce.com that I can connect to from my office behind a firewall.
However, I can NOT connect to the endpoint when I am connected to my netwrok thru a VPN connection.
I can connect to Salesforce.com from my browser using the same proxy setting I have setup in CastIron.
I need to use the VPN becasue I am connecting to databases that exist behind the firewall.  I can connect to the database endpoints while connected to VPN.
This is going to start to be a real issues when we have offshore resources develop as they must connect thru VPN
Anyone have any thoughts on how to get this working?
Updated on 2012-09-12T13:57:14Z at 2012-09-12T13:57:14Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    1250 Posts

    Have you tried using the

    ‏2010-08-04T21:27:53Z  

    Have you tried using the Salesforce.com IP Address in the Endpoint Config, WSDL Login URL?

  • SystemAdmin
    SystemAdmin
    1250 Posts

    RESOLVED

    ‏2010-08-09T19:24:32Z  
    OK The issue here was that CastIron was binding to the wrong IP Address.  SO it was not going thru my proxy.
    To fix this we had to make sure that my proxy setting were not only correctly set in the endpoint but also set in the Session Login under edit prefrences. 
    Once we set it there and loged in it worked fine.
  • DnyaneshwarDhumal
    DnyaneshwarDhumal
    1 Post

    Re: RESOLVED

    ‏2012-09-12T05:50:39Z  
    OK The issue here was that CastIron was binding to the wrong IP Address.  SO it was not going thru my proxy.
    To fix this we had to make sure that my proxy setting were not only correctly set in the endpoint but also set in the Session Login under edit prefrences. 
    Once we set it there and loged in it worked fine.
    I Updated Cast Iron with suggested settings in this Post. Now I am getting below error. I verified That Host Name , User ID and Password is correct.
    Could Not Connect to
    Salesforce.com.comapprouter.module.http.protocol.HttpOperationException
    Received Http Code :407 from test.salesforce.com
  • SystemAdmin
    SystemAdmin
    1250 Posts

    Re: RESOLVED

    ‏2012-09-12T07:24:41Z  
    I Updated Cast Iron with suggested settings in this Post. Now I am getting below error. I verified That Host Name , User ID and Password is correct.
    Could Not Connect to
    Salesforce.com.comapprouter.module.http.protocol.HttpOperationException
    Received Http Code :407 from test.salesforce.com
    Hi,
    HTTP 407 means that you did not provide the appropriate credentials to your proxy server. Did you mention a username and password in the Edit>Preferences>Session Login menu?
  • SystemAdmin
    SystemAdmin
    1250 Posts

    Re: RESOLVED

    ‏2012-09-12T13:57:14Z  
    Hi,
    HTTP 407 means that you did not provide the appropriate credentials to your proxy server. Did you mention a username and password in the Edit>Preferences>Session Login menu?
    You may also try to set the proxy details from your SFDC endpoint.