Topic
2 replies Latest Post - ‏2012-06-11T18:21:42Z by JohnCroson
SystemAdmin
SystemAdmin
1250 Posts
ACCEPTED ANSWER

Pinned topic Insert Error

‏2010-07-28T18:10:47Z |
I have a Insert Activity to a SQL Database.  The insert works fine except for on field.  The field is defined inthe data base as <email address>.  Yes it has the space in it.
 
When I do the insert it throws a sql error.  Is there a way to force the brackets are around the coulmn name email address so that the insert won't fail.
Thanks
 
Updated on 2012-06-11T18:21:42Z at 2012-06-11T18:21:42Z by JohnCroson
  • SystemAdmin
    SystemAdmin
    1250 Posts
    ACCEPTED ANSWER

    1.Go To SQL Endpoint

    ‏2010-07-29T18:47:55Z  in response to SystemAdmin
    1.Go To SQL Endpoint settings
    2. Check "Quoted Identifiers for tables, columns and objects with quotes.
    3.Test Connection.
    4. Try to insert the data.
    This solutions works specially if you have spaces in SQL field names.
     
     
    • JohnCroson
      JohnCroson
      4 Posts
      ACCEPTED ANSWER

      Re: 1.Go To SQL Endpoint

      ‏2012-06-11T18:21:42Z  in response to SystemAdmin
      Thanks for this. My issue wasn't a space in the column header, but a dash "-" in the column header name, resulting in a meaningful error message (Jk):

      
      SQLSTATE: HY000 ERRORCODE: 102 Error Message: [CastIron Systems][SQLServer JDBC Driver][SQLServer]Incorrect syntax near 
      '-'.