Topic
  • 4 replies
  • Latest Post - ‏2011-07-25T18:39:11Z by devil786
devil786
devil786
126 Posts

Pinned topic Unable to apply Incoming Text based rule

‏2011-06-08T18:35:37Z |
Hi, We are using TBSM 4.2.1 with FP2-ifix3 along with existing omnibus 7.3.1 on a separate machine. I tried to create a simple custom canvas showing nodes UP/DOWN status using incoming text based rule, but the rule was not applying i.e. the service status was not changing, it take affect when we restarted the object server. Also i tested it by creating a simple data fetcher with only alert.status table selected along with some specific selected fields. and the rule applied successfully i.e. the service status was changing according to the rule. Does any body faces the same problem?
Updated on 2011-07-25T18:39:11Z at 2011-07-25T18:39:11Z by devil786
  • wesgyure
    wesgyure
    2 Posts

    Re: Unable to apply Incoming Text based rule

    ‏2011-06-14T13:55:41Z  
    The canvas status should have been updating as well if you were seeing status changes in the service tree. The best approach to get a solution for this problem would be to open a PMR with the support team, in the event that a code change is necessary. Thank you.
  • devil786
    devil786
    126 Posts

    Re: Unable to apply Incoming Text based rule

    ‏2011-07-18T08:48:06Z  
    • wesgyure
    • ‏2011-06-14T13:55:41Z
    The canvas status should have been updating as well if you were seeing status changes in the service tree. The best approach to get a solution for this problem would be to open a PMR with the support team, in the event that a code change is necessary. Thank you.
    Hi, Can anyone please guide me where to check the logs about the rules, so that I can check whether the rules are applying successfully or not.
  • mrmr
    mrmr
    13 Posts

    Re: Unable to apply Incoming Text based rule

    ‏2011-07-22T20:47:06Z  
    • devil786
    • ‏2011-07-18T08:48:06Z
    Hi, Can anyone please guide me where to check the logs about the rules, so that I can check whether the rules are applying successfully or not.
    From Level 3...

    If you turn the logs on FINER for impact, statemodel, and beans you should see on the data server if the RADEventProcessor is processing your text based rules:
    $TBSM_HOME/bin/setTraceLevel.sh <tipadmin user> <tip admin pass> data -addtrace
    "com.micromuse.sla.impact=finer:com.micromuse.sla.statemodel=finer:com.micromuse.sla.beans=finer"

    As for what to look for to see the exact rule being processed:
    Try looking for sendInstancesToStateModel1 in the data server logs.
    The last parameter on that line will either say true or false.
    If it is true, the event that was processed matched a text based rule, and that should answer
    the question.

    If this does not yield results, please open a PMR.

    = Michael
  • devil786
    devil786
    126 Posts

    Re: Unable to apply Incoming Text based rule

    ‏2011-07-25T18:39:11Z  
    • mrmr
    • ‏2011-07-22T20:47:06Z
    From Level 3...

    If you turn the logs on FINER for impact, statemodel, and beans you should see on the data server if the RADEventProcessor is processing your text based rules:
    $TBSM_HOME/bin/setTraceLevel.sh <tipadmin user> <tip admin pass> data -addtrace
    "com.micromuse.sla.impact=finer:com.micromuse.sla.statemodel=finer:com.micromuse.sla.beans=finer"

    As for what to look for to see the exact rule being processed:
    Try looking for sendInstancesToStateModel1 in the data server logs.
    The last parameter on that line will either say true or false.
    If it is true, the event that was processed matched a text based rule, and that should answer
    the question.

    If this does not yield results, please open a PMR.

    = Michael
    OK Michael thanks again, but one more problem i am facing is that we are using TBSM 4.2.1 with an existing Omnibus Object server 7.3.1 , all is working fine, i have created some dashboards on the TBSM, but sometimes the same rules are not applying i.e. the service status doesnot changes until the TBSM services are restarted. I will be thankful to you if you can help/guide me in solving this Problem. FYI i have already updated the object server schema as mentioned on IBM website.