Topic
3 replies Latest Post - ‏2011-06-07T19:54:56Z by SystemAdmin
SystemAdmin
SystemAdmin
126 Posts
ACCEPTED ANSWER

Pinned topic Problem when deploying SCA/OSGi application on Websphere

‏2011-06-07T16:53:40Z |
I'm trying to deploy our application on a non-RAD install of WebSphere 7.0 we have on our test machine. As far as I can tell both the OSGi and SCA feature pack has been installed on it. Yet, the app fails to start once deployed. It works fine on my local RAD install of WAS 7.0. A full set of ffdc logs are attached, but I'm assuming that the section below might be where the problem lies. Any tips on what I'm missing would be greatly appreciated.
The ffdc section:


com.ibm.ws.soa.sca.admin.cdf.codegen.SCAValidationException: CWSOA1007E: The implementation.osgiapp implementation type is not supported. at com.ibm.ws.soa.sca.contribution.monitor.impl.WASLoggingMonitorImpl.problem(WASLoggingMonitorImpl.java:106) at org.apache.tuscany.sca.contribution.processor.ExtensibleStAXArtifactProcessor.warning(ExtensibleStAXArtifactProcessor.java:95) at org.apache.tuscany.sca.contribution.processor.ExtensibleStAXArtifactProcessor.read(ExtensibleStAXArtifactProcessor.java:142) at org.apache.tuscany.sca.assembly.xml.CompositeProcessor.read(CompositeProcessor.java:463) at org.apache.tuscany.sca.assembly.xml.CompositeProcessor.read(CompositeProcessor.java:90) at org.apache.tuscany.sca.contribution.processor.DefaultStAXArtifactProcessorExtensionPoint$LazyStAXArtifactProcessor.read(DefaultStAXArtifactProcessorExtensionPoint.java:387) at org.apache.tuscany.sca.contribution.processor.ExtensibleStAXArtifactProcessor.read(ExtensibleStAXArtifactProcessor.java:152) at org.apache.tuscany.sca.contribution.processor.ExtensibleStAXArtifactProcessor.read(ExtensibleStAXArtifactProcessor.java:203) at com.ibm.ws.soa.sca.admin.module.loader.TuscanyLoader.load(TuscanyLoader.java:43) at com.ibm.ws.soa.sca.admin.cdf.content.AssetUtil.createQNameMapping(AssetUtil.java:101) at com.ibm.ws.soa.sca.admin.cdf.content.operation.CheckForScaContent.checkForAddCompUnit(CheckForScaContent.java:182) at com.ibm.ws.soa.sca.admin.cdf.content.operation.CheckForScaContent.execute(CheckForScaContent.java:107) at com.ibm.wsspi.management.bla.op.compound.Phase.execute(Phase.java:151) at com.ibm.wsspi.management.bla.op.compound.CompoundOperation._doPhaseExecute(CompoundOperation.java:102) at com.ibm.wsspi.management.bla.op.compound.CompoundOperation.doExecute(CompoundOperation.java:85) at com.ibm.wsspi.management.bla.op.Operation.execute(Operation.java:158) at com.ibm.wsspi.management.bla.op.compound.CompoundOperation.execute(CompoundOperation.java:68) at com.ibm.ws.management.bla.commands.ADTCommand$OperationScheduler.run(ADTCommand.java:543) at java.lang.Thread.run(Thread.java:736)

Attachments

Updated on 2011-06-07T19:54:56Z at 2011-06-07T19:54:56Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    126 Posts
    ACCEPTED ANSWER

    Re: Problem when deploying SCA/OSGi application on Websphere

    ‏2011-06-07T17:06:25Z  in response to SystemAdmin
    Hello.

    The log says that the server doesn't have the OSGi FeP. You said that both SCA and OSGi FePs are installed, but I wonder if you profile is augmented with the OSGi FeP.
    Go to your profile on Profile Management Tool and ensure you have the OSGi FeP installed in this profile.

    Let us know the results.

    "Software development has been, is, and will remain fundamentally hard"
    - Grady Booch
  • SystemAdmin
    SystemAdmin
    126 Posts
    ACCEPTED ANSWER

    Re: Problem when deploying SCA/OSGi application on Websphere

    ‏2011-06-07T18:25:11Z  in response to SystemAdmin
    Unfortunately, the profile seems to be augmented with the correct FeP.
  • SystemAdmin
    SystemAdmin
    126 Posts
    ACCEPTED ANSWER

    Re: Problem when deploying SCA/OSGi application on Websphere

    ‏2011-06-07T19:54:56Z  in response to SystemAdmin
    Can you try recycling the server and seeing if the problem goes away?

    This happened to me once but I couldn't recreate it at never got to the bottom of it.